Skip to main content

sata hard disk not taking linux

15 years 1 week ago #30525 by sose
my new sata hardisk is not taking oracle linux may some driver problem
15 years 1 week ago #30550 by sys-halt
hi sose, could you please explain more about your problem.

do you mean that you inserted your new SATA HDD onto your chassis and you are unable to mount it or access it from your Linux OS?

or are your trying to install Linux from sratch onto your new SATA HDD?

or maybe your PC Motherboard unable to detect your new SATA HDD?

please give us more explanation please, because basically you don't need any driver to install Linux on a SATA HDD, the normal booted kernel image already has SATA driver module to detect SATA HDDs.

Please first check if you can see the new SATA HDD from your BIOS and if your BIOS is actually seeing the SATA HDD size, model and speed properly.

I once faced such problem my motherboard was unable to detect properly my SATA HDD and it turns out my motherboard buit-in SATA where of old type and I had to use a Jumper to my SATA HDD to drop it from SATA2 to SATA1 and things worked fine after it.

Also note if your Motherboad has certain default configuration like new ACER PCs comes with default HDD settings as AHCI or even the HDD controller comes as built-in RAID!! and in this case you need to use a RAID driver or AHCI driver to mount your SATA HDD during installation, or there could be an option in your BIOS to make it IDE Compatible, in this way your BIOS will mount and talk to your SATA HDD as an IDE HDD.

I hope I did manage to give you some insights on what your problem might be. And it would be helpful if you gave us more information regarding your problem.
15 years 1 week ago #30553 by sose
the sata disk is already running xp with unallocated space which I want to install oracle linux, but the linux installation kept telling me that the device driver is not detected that i should make a sellection. i tried all the driver option but to no avail.
15 years 1 week ago #30554 by sys-halt
Could you please check the BIOS setting regarding your "Drive configuration". even if you have Windows XP installed it could have a RAID or AHCI Controller that is preventing Linux from detecting your HDD geometric.

I have HP Laptop that has such options and I first managed to install Linux using the "IDE Compatible" option from the BIOS, after while I figured out how to install Linux using RAID or AHCI controller options.

Please try to check this option first from your BIOS. sorry I'm stressing this idea first because I faced such problem.

my second option would be to find another distribution like Ubuntu or Knoppix or Fedora Core a live bootable distribution and boot from the CD to see if it will detect your hardware and your HDD properly. this could be of a great help since if a live distribution managed to detect your HDD settings then it could be your specific distro has a little bug towards such settings.

And if possible can you throw here the boot process for your Oracle Linux Distro so that we can see where it is hanging out, where it is stopping and what the exact message it is saying.

if I am getting your right it sounds like your distro is asking you to make a selection for the proper kernel image that will match your hardware. the generic kernel we all boot from it should basically works fine with our hardware, unless we have a special hardware configuration settings, like RAID or SCSI controllers or PCMCIA or such things then there are other bunch of kernel images tweaked towards supporting these configurations.
Time to create page: 0.112 seconds