Skip to main content

Frame-Relay Point-to-Point

More
14 years 1 month ago #33926 by broadcaststorm
I doubt it's split horizon. If we could route at layer 3 across the hub then it'd be a point to point network, so split horizon wouldn't apply. Remember that the spokes interfaces must be in the same subnet 'cos the frame relay cloud is transparent to layer 3 traffic.

And for the spokes to be able to ping the hub there must be a layer 3 route, so one assumes the interfaces on the hub have layer 3 addresses. This then is not strictly Frame Relay, but point to point layer 3 directly attached interfaces.
For a Frame Relay hub and spoke network like this, the hub has no layer 3 routes or config at all, as you configure the router at global config to be a Frame Relay Switch:
(Router (config)#frame-relay switching)
Once done, you configure the serial ports with clock rate, bandwidth, encapsulation frame-relay, and the frame relay DLCI number to identify the PVC. Inverse arps on the spokes take care of the mapping and can ping each other, but they cannot ping the hub.
What you will find is that with inverse arps running, you can ping the other spoke, but you will not be able to ping your local interface. To do so, you have to map your local interface layer 3 address to your local interface DLCI. Then you can ping yourself. Strange but true!
More
14 years 1 month ago #33927 by broadcaststorm
Ok...

Frame-relay topology

Spoke 1
HUB
Spoke 2

Config for spoke_one:

SPOKE_ONE#
SPOKE_ONE#sho run
Building configuration...

Current configuration : 548 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SPOKE_ONE
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
interface Serial0/0
ip address 100.140.10.1 255.255.255.0
encapsulation frame-relay
frame-relay lmi-type cisco
!
ip classless
ip http server
!
!
dial-peer cor custom
!
line con 0
exec-timeout 0 0
logging synchronous
!
end

SPOKE_ONE#ping 100.140.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.140.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
SPOKE_ONE#ping 100.140.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.140.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms


As you can see, the router can't ping itself, but it can ping the other spoke, Spoke 2.

Here's the config for Spoke 2.

SPOKE_TWO#
SPOKE_TWO#sho run
Building configuration...

Current configuration : 527 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname SPOKE_TWO
!
ip subnet-zero
!
no ip domain-lookup
!
call rsvp-sync
!
interface Serial0/0
ip address 100.140.10.2 255.255.255.0
encapsulation frame-relay
!
ip classless
!
end

SPOKE_TWO#ping 100.140.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.140.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/32 ms
SPOKE_TWO#ping 100.140.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.140.10.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


As you can see, Spoke 2 can't ping itself but it can ping Spoke 1.

The hub has no layer 3 addresses on it at all, so you can't ping it. Here is the output from the hub for this Frame Relay network.

HUB#
HUB#sho run
Building configuration...

Current configuration : 928 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HUB
!
ip subnet-zero
!
!
no ip domain lookup
frame-relay switching
!
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 128000
no fair-queue
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 100 interface Serial0/1 200
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 200 interface Serial0/0 100
!
ip http server
ip classless
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
end


As you can see, there are no layer 3 addresses on the hub.
Note the frame-relay switching command in global config.
To make the hub pingable like the spokes (and I'm not 100% sure this would actually work) I think you need to create layer 3 sub interfaces on the hub and the spokes. The sub-if's betwen the hub and spoke 1 need to be in the same subnet, and the sub-ifs on the interfaces between the hub and Spoke 2 need to be in the same subnet, but not the same subnet as the hub - Spoke 1 sub-ifs. If you make them point to point sub-ifs, then it might work. I'm going to try it with the set up I have displayed here. Not sure if it'll work or not, 'cos I'm not very good with Frame Relay stuff!
More
14 years 2 weeks ago #34209 by Losh
Replied by Losh on topic Re: Frame-Relay Point-to-Point
with frame-relay hub and spoke configured with point to point, the hub router is the only one that knows how to reach all spoke routers therefore all spoke definitely know how to reach the hub.

However if you want the spoke routers to communicate or rather ping each others ip address then you should configure frame relay mappings on the spoke routers also.

i.e if Rtr1=hub Rtr2=spoke Rtr3=spoke.

for spoke Rtr2 and Rtr3 to be able to ping each other, on Rtr2 - map ip address of Rtr3 to local dlci of Rtr2.
likewise on Rtr3 map ip address of Rtr 2 to local dlci of Rtr3.

This way Rtr2 and Rtr3 know how to reach each other. Of course you should run a routing protocol over the network.

~ Networking :- Just when u think its starting to make sense......... ~
____________________________________________
CCNA, CCNP, CCNA Security, JNCIA, APDS, CISA
More
14 years 2 weeks ago #34233 by broadcaststorm

Of course you should run a routing protocol over the network.

Which means remembering to add the broadcast key word to the frame-relay map commands, and of course you need to turn off in-arps if they are currently switched on.
More
14 years 2 weeks ago #34258 by krik
Replied by krik on topic Re: Frame-Relay Point-to-Point
The setup you've done is not an hub-and-spoke but a simple point-to-point frame relay between spoke_one and spoke_two... The router you call hub is actually a frame-relay switch (as stated by the command frame-relay switching).

As far as I know, it is normal that a router can't ping its own IP on a frame relay PVC.I don't remember exactly the technical details behind it but I think you can see it like a kind of split horizon. Why would spoke_two send back a packet from spoke_one to spoke_one?

Christophe Lemaire
www.exp-networks.be/blog/
More
14 years 1 week ago #34282 by broadcaststorm
Yes hub and spoke as that is what the OP described.
The reason Hub 1 can't send a frame back to Hub 1 is because the IP address of the Hub 1 interface isn't mapped to the DLCI on the Hub 1 interface. That's why you can't ping your local interface when you set this up. If you do want to ping yourself, you have to map the local interface to the local DLCI with the frame-relay map command.
As Losh has said, you would need to add some layer 3 point to point interfaces to the Hub router pointing to each spoke, but in that instance I don't think that spoke would be able to ping spoke as the frame-relay switching global config command on the hub precludes the addition of point to point sub interfaces... I think... and which I was getting at (badly) back on page 1.
More testing required :?
Time to create page: 0.152 seconds