Skip to main content

Distributed traffic on 2 ISPs based on traffic typ

More
8 years 8 months ago #38674 by snipy9981
Dears,
Please I need a help to distribure the traffic of a network that CISCO devices are used on two ISPs. The policy of Routing the data packets to two ISPs is based on packet types. I mean that I want to carry the web traffic on ISP1 and mail traffic on ISP2. I used some PBR, ACL, and NAT configuration steps to do that using GNS3 as shown in the attachment.
Please, anyone can support and find if the following steps can handle this issue:



!
interface Loopback0
ip address 10.1.1.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/0
ip address 200.1.1.1 255.255.255.0
ip nat outside

!
interface FastEthernet0/1
ip address 200.2.2.1 255.255.255.0
ip nat outside

!
!
!
ip nat inside source route-map isp1 interface FastEthernet0/0 overload
ip nat inside source route-map isp2 interface FastEthernet0/1 overload
!
access-list 100 deny tcp 10.1.1.0 0.0.0.255 any eq smtp
access-list 100 deny tcp 10.1.1.0 0.0.0.255 any eq pop3
access-list 100 permit ip any any

access-list 110 deny tcp 10.1.1.0 0.0.0.255 any eq www
access-list 110 permit ip any any

route-map isp2 permit 10
match ip address 110
match interface FastEthernet0/1
!
route-map isp1 permit 10
match ip address 100
match interface FastEthernet0/0
!
!
!
!
!
!
end
Attachments:
Time to create page: 0.142 seconds