Skip to main content

ISDN link establishment failure

More
17 years 7 months ago #17273 by cbtg2006
HI guys,

I'm new here, so hi :)

I was browsing these forums and happened to come accross this post.

I too have been having problems with NetSim.

I recently went on a CCNA training course and configured ISDN between two 2503's using an ISDN simulator. I used the same command set in Boson's Netsim and it doesn't work.

The problem seems to be that the interface does not appear as 'Spoofing' as it should do.

Here is the relevent part of my config: [the entire config is posted at the bottom of the post, taken from Sequential Lab 19]

[code:1]
interface Bri0
no ip address
no ip directed-broadcast
backup interface
no fair-queue
isdn spid1 32177820020100
dialer pool-member 1
encapsulation ppp
ppp authentication chap
!
interface Dialer1
ip address 200.10.1.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name router1
dialer string 7782001
dialer-group 1
ppp authentication chap
[/code:1]

Here is the output of 'sh isdn status':

[code:1]
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI 64, ces = 1, state = 8(established)
spid1 configured, no LDN, spid1 sent, spid1 valid
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0x80000003
Number of L2 Discards = 0, L2 Session ID = 100
Total Allocated ISDN CCBs = 0
[/code:1]

And finally the output of 'sh int bri0':

[code:1]
Bri0 is up, line protocol is up
Hardware is BRI
MTU 1500 bytes, BW Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of show interface counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 1000 bits/sec, 2 packets/sec
5 minute output rate 1000 bits/sec, 2 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
[/code:1]

As you can see, no spoofing!

Any ideas?

Manyt thanks,

-cbtg2006[/code][/b]


ENTIRE CONFIG FILE

[code:1]

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router2
enable secret bhrbn
!
username router1 password cisco
!
!
!
ip subnet-zero
!
!
!
!
!
!
controller T1 0/0
!
!
!
!
!
!
interface Serial0
no ip address
no ip directed-broadcast
backup interface
!
interface FastEthernet0/0
ip address 160.10.1.2 255.255.255.0
no ip directed-broadcast
backup interface
no fair-queue
ip ospf cost 1
!
interface Bri0
no ip address
no ip directed-broadcast
backup interface
no fair-queue
isdn spid1 32177820020100
dialer pool-member 1
encapsulation ppp
ppp authentication chap
!
interface Dialer1
ip address 200.10.1.2 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name router1
dialer string 7782001
dialer-group 1
ppp authentication chap
!
router ospf 1
network 160.10.1.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
dialer-list 1 protocol ip permit
!
isdn switch-type basic-ni
line con 0
transport input none
line aux 0
line vty 0 4
login
password cisco
!
no scheduler allocate
end

[/code:1]
More
17 years 7 months ago #17279 by bvnmani
hi all,
I had came across this situation in real time..
I think Static routing should be there.And also make sure that you had written the configuration in Dial on Demand Routing concept.
i.e.,
step1:Static Route
step 2.with access-list
step 3:dialer string

Regards,
Bvnmani
More
17 years 7 months ago #17300 by cbtg2006
Hmm, static routes are definately defined, as is the ACL and dialer sting.

I have tried configuring using legacy DDR and this results in the same problem.

Cheers,
More
17 years 7 months ago #17348 by cbtg2006
OK, I have got my hands on a real 2503 router. If I enter commands like for like I get the working config on the REAL 2503. When I run sh interface bri0:

[code:1]
BRI0 is up (spoofing), line protocol is up (spoofing)
Hardware is BRI
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
2 packets output, 16 bytes, 0 underruns
0 output errors, 0 collisions, 11 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions[/code:1]

And the broken SIMULATED 2503 - no spoofing!:

[code:1]
Bri0 is up, line protocol is up
Hardware is BRI
MTU 1500 bytes, BW Kbit, DLY 1000 usec, rely 255/255, load 1/255
Encapsulation PPP, loopback not set, keepalive set (10 sec)
LCP Open
Open: IPCP, CDPCP
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of show interface counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 1000 bits/sec, 2 packets/sec
5 minute output rate 1000 bits/sec, 2 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
[/code:1]

Commands enetered:

[code:1]
(config)# isdn switch-type basic-net3
(config)# username router1 password cisco
(config)# dialer-list 1 protocol ip permit
(config)#int bri0
(config-if)#encaps ppp
(config-if)#ppp auth chap
(config-if)#dialer pool-member 1
(config-if)#no shut
(config-if)#exit
(config)#int dialer1
(config-if)#ip address 10.0.1.1 255.255.255.252
(config-if)#dialer remote-name router1
(config-if)#dialer idle-timeout 20
(config-if)#dialer string 222
(config-if)#dialer pool 1
(config-if)#dialer-group 1
(config-if)#encaps ppp
(config-if)#ppp auth chap
[/code:1]

With debug dialer turned on the working REAL 2503 tries to dial and fails. The SIM 2503 just bombs out before it even tries to dial.... probably becuase it thinks the connection is live?

Any thoughts?
Time to create page: 0.137 seconds