Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: public ip

public ip 5 years 6 months ago #36960

  • sais
  • sais's Avatar
  • Offline
  • Frequent Member
  • Posts: 59
  • Karma: 0
a company request pool of ip from isp. my question his this configuration work. IT-person of that co. ask to configure like this . he said he have switch which he will do. i have dout this configure will work or not. if work than hw will switch configuration (2950-sw) router used 871 - for internet connection.

WIMAX#sh run
Building configuration...

Current configuration : 928 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco
!
boot-start-marker
boot-end-marker
!
enable password xxxxxx
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description
no ip address
duplex auto
speed auto
!
interface FastEthernet4.20
encapsulation dot1Q 20
ip address 172.1.1.142 255.255.255.252
ip nat outside
ip virtual-reassembly

no snmp trap link-status
!
interface Vlan1
ip address 83.96.x.x 255.255.255.240
ip nat inside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.1.1.141
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password xxxx
login
!
The administrator has disabled public write access.

Re: public ip 5 years 6 months ago #36972

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
The outside interface is a FastEthernet interface. I assume this is connected to the switch. Usually, there is WAN link somewhere.
But, the 2950 switch doesn't come with a WAN interface. Infact, most switches I've seen don't. So my question is, What physically connects the company to the ISP?

I can't find some thing obviously wrong with the config except that the inside IP is using a public range. It should use some thing in the private ranges: 192.168.x.x or 172.16.x.x to 172.31.x.x or 10.x.x.x

Any one else can see what I can't, be my guest to post.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: public ip 5 years 6 months ago #36978

  • sais
  • sais's Avatar
  • Offline
  • Frequent Member
  • Posts: 59
  • Karma: 0
hai solo : this is wimax internet connection
from wimax cable is connected to interface FastEthernet4 . int0-3 is used for lan connection.

whether we need to create dhcp pool or access -list for public ip .

ip dhcp pool fast we create whn lan use private ip........
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1

or just applying vlan ok.? same when we use private ip is ?
int fst 0 is directly connected to switch ?
wat should be swith configuration 2950 ?

interface FastEthernet4.20
encapsulation dot1Q 20
ip address 172.1.1.142 255.255.255.252
ip nat outside
ip virtual-reassembly

is connected to isp...............172.1.1.141 is isp adres
i can ping . is it internal problem. same where in switch.

my mail -id This email address is being protected from spambots. You need JavaScript enabled to view it.
can u give ur mail -id............
The administrator has disabled public write access.

Re: public ip 5 years 6 months ago #36985

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
whether we need to create dhcp pool or access -list for public ip .

If you did not set static IPs on your PC, then YES you need DHCP to distribute IPs. Access lists are for applying extra policies. You don't n need it for a basic config.
or just applying vlan ok.? same when we use private ip is ?

If your goal is just to connect to the internet, then you don't need VLANs. Still you can apply VLANs, and this has NO relation to DHCP. You need DHCP whether you apply VLANs or not.
wat should be swith configuration 2950 ?

Nothing if you don't want VLANs. Just configure DHCP on the router.

is connected to isp...............172.1.1.141 is isp adres
i can ping . is it internal problem. same where in switch.

I assume here that you meant that you can ping the ISPs IP 172.1.1.141 from your router.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: public ip 5 years 6 months ago #36999

  • sais
  • sais's Avatar
  • Offline
  • Frequent Member
  • Posts: 59
  • Karma: 0
interface Vlan1
ip address 83.96.x.x 255.255.255.240
ip address 192.168.1.0 255.255.255.0 sec
ip nat inside
ip virtual-reassembly

this vlan is default configutation in router 800 series.

ie we should apply some ip -address . in this case for private ip to assign for system i create private ip
pool. for public ip also i can create pool or wat or just apply to vlani........
The administrator has disabled public write access.
Time to create page: 0.085 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup