Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: RIP Not showing in Show ip route

RIP Not showing in Show ip route 5 years 4 months ago #37239

  • rizin
  • rizin's Avatar
  • Offline
  • Distinguished Member
  • Posts: 203
  • Karma: 0
Hi All,

Please look at this table, my problem is i cannot able to find any RIP Routes in show ip route table :(

Where i'm going wrong ?



Thanks in advance,

Rizin
Known is a drop, unknown is an Ocean
The administrator has disabled public write access.

Re: RIP Not showing in Show ip route 5 years 4 months ago #37240

  • Nevins
  • Nevins's Avatar
  • Offline
  • Expert Member
  • Posts: 438
  • Thank you received: 9
  • Karma: 4
Your link is broken.


Configuring and troubleshooting rip is VERY easy here are the requirements of rip:


Interfaces in the UP/UP state (check with show ip interface brief)
(note: to be in an UP/UP state ip addresses have to be given out, the cable has to be connected and both ends must be using the proper encapsulation and authentication)

Router RIP command enabled (check with show run)
Version (check with show run)
Networks properly advertized (check with show run)
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
The administrator has disabled public write access.

Re: RIP Not showing in Show ip route 5 years 4 months ago #37242

  • rizin
  • rizin's Avatar
  • Offline
  • Distinguished Member
  • Posts: 203
  • Karma: 0
Known is a drop, unknown is an Ocean
The administrator has disabled public write access.

Re: RIP Not showing in Show ip route 5 years 4 months ago #37243

  • Nevins
  • Nevins's Avatar
  • Offline
  • Expert Member
  • Posts: 438
  • Thank you received: 9
  • Karma: 4
The link appears to work now. In any case you are going to need to do more show commands to pinpoint the issue.

Check the output for

Show ip interface brief
(check link status)

Show run (check overall config for issues)


In the future just paste the text, it's so much easier then hosting.
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
The administrator has disabled public write access.

Re: RIP Not showing in Show ip route 5 years 4 months ago #37247

  • rizin
  • rizin's Avatar
  • Offline
  • Distinguished Member
  • Posts: 203
  • Karma: 0
I'm afraid it is very long text, please bear with me :)

R1#show run
Building configuration...

Current configuration : 1017 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
interface Loopback1
ip address 192.168.27.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.26.2 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.25.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router rip
network 192.168.25.0
network 192.168.26.0
network 192.168.27.0
no auto-summary
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end

R1#
R1#

R1#show ip interfa
R1#show ip interface brie
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.26.2 YES NVRAM up up

Serial1/0 192.168.25.1 YES NVRAM up up

Serial1/1 unassigned YES NVRAM administratively down down

Serial1/2 unassigned YES NVRAM administratively down down

Serial1/3 unassigned YES NVRAM administratively down down

Loopback1 192.168.27.2 YES NVRAM up up

R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 14 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 1 1 2
Serial1/0 1 1 2
Loopback1 1 1 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.25.0
192.168.26.0
192.168.27.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.25.0/24 is directly connected, Serial1/0
C 192.168.27.0/24 is directly connected, Loopback1
C 192.168.26.0/24 is directly connected, FastEthernet0/0
R1#

Thanks in advance,

Rizin
Known is a drop, unknown is an Ocean
The administrator has disabled public write access.

Re: RIP Not showing in Show ip route 5 years 4 months ago #37248

  • Nevins
  • Nevins's Avatar
  • Offline
  • Expert Member
  • Posts: 438
  • Thank you received: 9
  • Karma: 4
Lets go over our checklist:

Interfaces in the UP/UP state
Networks properly advertised
Version (check with show run)
Router RIP command enabled


[code:1]!
interface Loopback1
ip address 192.168.27.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.26.2 255.255.255.0
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.25.1 255.255.255.0
serial restart-delay 0
!
[/code:1]

Networks and interfaces defined:

network 192.168.25.0 = Serial1/0
network 192.168.26.0 = FastEthernet0/0
network 192.168.27.0 = Loopback1


[code:1]R1#show ip interface brie
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.26.2 YES NVRAM up up

Serial1/0 192.168.25.1 YES NVRAM up up

Serial1/1 unassigned YES NVRAM administratively down down

Serial1/2 unassigned YES NVRAM administratively down down

Serial1/3 unassigned YES NVRAM administratively down down

Loopback1 192.168.27.2 YES NVRAM up up [/code:1]

Interfaces in the UP/UP state
network 192.168.25.0 = S1/0 = UP/UP
network 192.168.26.0 = Fa0/0 = UP/UP
network 192.168.27.0 = L1 = UP/UP

[code:1]!
router rip
network 192.168.25.0
network 192.168.26.0
network 192.168.27.0
no auto-summary
! [/code:1]

Router RIP command enabled
Version (default is version1)


network 192.168.25.0 = S1/0 = UP/UP = Rip version 1 advertisements
network 192.168.26.0 = Fa0/0 = UP/UP = Rip version 1 advertisements
network 192.168.27.0 = L1 = UP/UP = Rip version 1 advertisements







You'll notice that I didn't check off Networks properly advertised and there is a reason for that. Namely the networks are not being properly advertized.

Here is you need to look:

How does RIP version 1 differ from RIP version 2 specifically for advertizing networks.
Are all devices properly configured (advertizements work more then one direction)






Here are some tools for you:

#Debug IP RIP (will show you what advertizements are being sent from where)
(think classless vs classful)

At this point I can pretty much tell you the problem but given that we are dealing with RIPv1 I'm guessing that this is a lab so I'll let you dwell on it. But in the mean time keep in mind that there are only a few parts to rip:

Is rip enabled
Is rip the same version (only sort of matters)
Are the links up/up

Are you properly advertising your networks. (most problems generally found here)
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
The administrator has disabled public write access.
Time to create page: 0.093 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup