Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: BGP Route Advertisement Question

BGP Route Advertisement Question 7 years 4 months ago #31362

I'm sorry if this is kind of long. I'm sure there's a simple answer. Hoping someone can shed some light:

Let’s say the “major” network for my site is 10.11.0.0 /16

Let’s say I had an interface that I sub’d out into 3 vlans. (gig1/0 sub’d into g1/0.10, g1/0.20 & g1/0.30)
Networks are
vlan 10 = 10.11.0.0 /24
vlan 20 = 10.11.1.0 /24
vlan 30 = 10.11.2.0 /24

I have 2 different bgp peers I want to advertise networks to.
One peer I want to advertise the whole 10.11.0.0 /16. The other peer I only want to advertise 10.11.2.0 /24.

Regarding the peer that I wanted to advertise 10.11.0.0 /16, I noticed that I couldn’t just put "network 10.11.0.0 mask 255.255.0.0" under my “router bgp” section of the config. I didn’t have any loopback interfaces with any 10.11.0.0 /16 IP’s assigned to them. Nor did I have “redistribute connected” within my “router bgp” section of the config.

So I generated the router by adding a static route to Null 0. (ip route 10.11.0.0 255.255.0.0 null 0) then I added the command “redistribute static” under the “router bgp” portion of the config. By doing this, I was able to generate the 10.11.0.0 /16 route. (NOTE, I haven’t or didn’t need to add the “network 10.11.0.0 mask 255.255.0.0” statement under the “router bgp portion of my config.)

So now I am sending my 10.11.0.0 /16 route to the peer accepting my 10.11.0.0 /16 advertisement.

I want to send ONLY the 10.11.2.0 /24 to my other peer.
I was able to do this by simply adding the statement “redistribute connected” under the “router bgp” portion of my config. (Easy enough) BUT my question is…..is there a way to advertise my 10.11.2.0 /24 to the peer who wants to see it, without using the “redistribute connected” command?

And secondly, if I were to add the network statement under my “router bgp” for the 10.11.0.0 /16, could I also add the 10.11.2.0 /24 network statement under router bgp? (And removing the redistribute connected statement.)

Is there a way to advertise routes to different BGP peers without using redistribute static and/or redistribute connected?

So it would look like

Router bgp 65425
network 10.11.0.0 mask 255.255.0.0
network 10.11.2.0 mask 255.255.255.0

Your input is greatly appreciated
The administrator has disabled public write access.

Re: BGP Route Advertisement Question 7 years 4 months ago #31369

  • Perlhack
  • Perlhack's Avatar
  • Offline
  • Frequent Member
  • Posts: 49
  • Karma: 0
Hi,
There needs to be an exact match in the routing table when using the network command. network 10.11.2.0 mask 255.255.255.0 should work for you since it is tied to a connected interface (VLAN 30). network 10.11.0.0/16 will not work but you could add an aggregate statement to do this.

Below Neighbor 192.168.1.2 is the one that should not recieve the summary route 192.168.0.0/16), neighbor 172.16.1.2 will receive the summary.

router bgp 44
no synchronization
bgp log-neighbor-changes
network 10.0.1.0 mask 255.255.255.0
aggregate-address 192.168.0.0 255.255.0.0
neighbor 172.16.1.2 remote-as 100
neighbor 192.168.1.2 remote-as 901
neighbor 192.168.1.2 route-map BGP out

ip prefix-list BGP seq 5 permit 192.168.0.0/16

! Deny the aggregate route. This is tied in neighbor statement.
route-map BGP deny 10
match ip address prefix-list BGP
!
route-map BGP permit 100
!

! Route map 100 is needed. An empty route-map has implict match everything.
The administrator has disabled public write access.

Re: BGP Route Advertisement Question 7 years 4 months ago #31370

Thank you Perlhack. I will try this in the lab.

You rock!

(Thanks!)
The administrator has disabled public write access.
Time to create page: 0.074 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup