Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: ASA 5505 VPN almost working

ASA 5505 VPN almost working 6 years 8 months ago #34097

  • Zani
  • Zani's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi Everyone,

I have a ipsec remote vpn that seems to be working, i can see clients logon but users cant reach any remote resources or ping them what am I doing wrong below is my config:


: Saved
: Written by administrator at 22:59:19.257 WST Mon Mar 29 2010
!
ASA Version 8.0(3)
!
hostname zani
domain-name zaniinc.local
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group isp
ip address pppoe
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
regex domainlist1 "xxx"
regex domainlist2 "xxx"
regex domainlist3 "xxx"
regex domainlist4 "xxx"
regex domainlist5 "xxx"
regex domainlist6 "xxx"
boot system disk0:/asa803-k8.bin
ftp mode passive
clock timezone WST 8
dns server-group DefaultDNS
domain-name zaniinc.local
same-security-traffic permit inter-interface
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit tcp any interface outside eq www
access-list outside_access_in extended permit tcp any interface outside eq ftp
access-list zaniincvpn_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1492
ip local pool vpnpool 192.168.1.100-192.168.1.200 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-611.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.1.2 3389 netmask 255.255.255.255
static (inside,outside) tcp interface www 192.168.1.2 www netmask 255.255.255.255
static (inside,outside) tcp interface ftp 192.168.1.2 ftp netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.1.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
aaa authentication serial console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 30
console timeout 0
vpdn group isp request dialout pppoe
vpdn group isp localname loppy
vpdn group isp ppp authentication pap
vpdn username loppy password c3ztxcbfz
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
!

threat-detection basic-threat
threat-detection statistics
tftp-server inside 192.168.1.2 C:\TFTP-Root
group-policy DfltGrpPolicy attributes
ipsec-udp enable
group-policy zaniincvpn internal
group-policy zaniincvpn attributes
dns-server value 192.168.1.2
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value zaniincvpn_splitTunnelAcl
default-domain value zaniinc.local
username administrator password woVD0EbRlBnBW1dA encrypted privilege 15
tunnel-group zaniincvpn type remote-access
tunnel-group zaniincvpn general-attributes
address-pool vpnpool
default-group-policy zaniincvpn
tunnel-group zaniincvpn ipsec-attributes
pre-shared-key P@ssw0rd
!
class-map type regex match-any DomainBlockList
match regex domainlist1
match regex domainlist3
match regex domainlist2
match regex domainlist5
match regex domainlist4
match regex domainlist6
class-map type inspect http match-all BlockDomainsClass
match request header host regex class DomainBlockList
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map type inspect http http_inspection_policy
parameters
class BlockDomainsClass
reset log
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect http http_inspection_policy
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:5f6c428c0b5a7ebb8b6137e21d103fa6
: end
The administrator has disabled public write access.

Re: ASA 5505 VPN almost working 6 years 8 months ago #34107

  • r0nni3
  • r0nni3's Avatar
  • Offline
  • Distinguished Member
  • Posts: 107
  • Karma: 0
Try giving your VPN users a different IP range.
Because you have 192.168.1.0/24 on both your inside network and your VPN pool.

This way you have 192.168.1.0/24 at both your outside (VPN users) and inside. And because 192.168.1.0/24 is a directly connected network at the inside the ASA will only look for the IP addresses on the inside.
So it might work from the VPN clients to the internal network but there is no way you can go back to your VPN clients.
Currently working as Cisco Engineer at Neon-Networking.

Certifications:
CCNA - Have it
CCNA Security - Have it
CCSP - Almost!!!!
CCIE Security - Not so far away dream
The administrator has disabled public write access.

Re: ASA 5505 VPN almost working 6 years 8 months ago #34120

  • Zani
  • Zani's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Thanks r0nni3, I changed my VPN Pool Range

I changed my nat0_outbound to reflect the new range too but still no joy
The administrator has disabled public write access.
Time to create page: 0.090 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup