Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Cisco ASA 5505 throttling/bandwidth issue

Cisco ASA 5505 throttling/bandwidth issue 7 years 2 weeks ago #32364

  • Rozzwell
  • Rozzwell's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hey all -

First off, thanks for such a wonderful resource. Lots of great info on here. I followed r0nni3's excellent howto setup for the ASA 5505 and have one glaring issue that I'm trying to overcome...speed.

The 5505 is slated to replace an aging (and dying) IPCop firewall in our office, so it's duty will be pretty light. We have a 50Mb Comcast line coming into the office, and when that line is plugged into the IPCop I get a consistent 40-50mb downstream and 10-12mb upstream. After following r0nni3's primer, I do have internet connectivity on the 5505 but I cannot get any faster than 2-3mb/sec down, and less than 1mb/sec upstream. Any idea why?

I've included my config in the hopes that we can determine if this is a config issue (likely), or a hardware problem (just unpacked it today).

Thanks in advance for any help!
: Saved
ASA Version 7.2(4)
hostname terrytate
enable password ******* encrypted
passwd ******* encrypted
interface Vlan1
nameif inside
security-level 100
ip address
interface Vlan2
nameif outside
security-level 0
ip address *.*.*.26
interface Ethernet0/0
switchport access vlan2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
ftp mode passive
pager lines 24
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10
route outside *.*.*.27 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0

username ***** password *********** encrypted privilege 15
class-map inspection_default
match default-inspection-traffic
policy-map type inspect dns preset_dns_map
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
service-policy global_policy global
prompt hostname context
: end
The administrator has disabled public write access.

Re: Cisco ASA 5505 throttling/bandwidth issue 7 years 2 weeks ago #32365

  • Kajitora
  • Kajitora's Avatar
  • Offline
  • Frequent Member
  • Posts: 40
  • Karma: 0
I dont see anything standing out in your config. Try hard coding the interface to 100/full or what every it should be.


Thought I should explain a little better =P. I had a asa with a similar problem, I didn't see any errors on interface, but setting it to 100/full fixed it. I believe it was because every time it lost a packet do to collision it was setting tcp windowing way back down and it could never really get going.
The administrator has disabled public write access.

Re: Cisco ASA 5505 throttling/bandwidth issue 7 years 1 week ago #32371

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Rozzwell, may I ask what did you use to measure those down/up speeds ?
Studying CCNP...

Ammar Muqaddas
Forum Moderator
The administrator has disabled public write access.
Time to create page: 0.079 seconds


Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V


  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup