Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Cisco ASA 5510 Configuration help

Cisco ASA 5510 Configuration help 7 years 6 months ago #30139

  • upatel
  • upatel's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hello, i am trying to configure the asa 5510 for my office but am having trouble. Any help will be appreciated. My network is configured as follows:

I have a LAN with a DHCP server and exchange server Which is connected to two routers one for mail on for internet.

On the VPN i have port 0/0 going to a separate router. which then goes to the net.

On port 0/1 i have it connected to my LAN with a local ip address. I want to setup a tunnel from the outside net to the LAN.

Here is my current configuration.

ASA Version 7.2(4)
hostname ciscoasa
domain-name *****.us
enable password KGDRrM9MGHiCzOYS encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
name gateway
name mail
interface Ethernet0/0
nameif Outside
security-level 0
ip address
interface Ethernet0/1
nameif Inside
security-level 0
ip address
interface Ethernet0/2
interface Ethernet0/3
no nameif
no security-level
no ip address
interface Management0/0
nameif management
security-level 100
ip address
ftp mode passive
dns domain-lookup Inside
dns domain-lookup Outside
dns server-group DefaultDNS
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list Outside_access_in extended permit tcp any any
access-list Outside_access_in extended permit udp any any
access-list Inside_access_in extended permit ip any any
access-list Inside_access_in extended permit tcp any any
access-list optext_splitTunnelAcl standard permit host
access-list optext_splitTunnelAcl standard permit any
access-list Outside_authentication extended permit tcp any any
access-list Outside_authentication extended permit udp any any
access-list Inside_authentication extended permit tcp any any
access-list Inside_authentication extended permit udp any any
access-list management_nat0_outbound extended permit ip interface Inside any
pager lines 24
logging enable
logging asdm informational
mtu management 1500
mtu Inside 1500
mtu Outside 1500
ip local pool optext mask
icmp unreachable rate-limit 1 burst-size 1
icmp permit any Inside
icmp permit any Outside
asdm image disk0:/asdm-524.bin
no asdm history enable
nat (management) 0 access-list management_nat0_outbound
nat (management) 0
access-group Inside_access_in in interface Inside
access-group Outside_access_in in interface Outside
route Inside gateway gateway 1
route Inside gateway 255
route Inside mail gateway 1
route Outside 1
router rip
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication match Outside_authentication Outside LOCAL
aaa authentication match Inside_authentication Inside LOCAL
http server enable
http Inside
http management
http redirect Outside 80
no snmp-server location
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto isakmp enable Inside
crypto isakmp enable Outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp ipsec-over-tcp port 10000
client-update enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcp-client client-id interface Outside
dhcpd address management
dhcpd dns interface management
dhcpd wins interface management
dhcpd domain interface management
dhcprelay server Inside
dhcprelay enable Outsidedhcprelay setroute Outside
enable Outside
tunnel-group-list enable
group-policy DfltGrpPolicy attributes
banner none
wins-server value
dns-server value
vpn-access-hours none
vpn-simultaneous-logins 3
vpn-idle-timeout 30
vpn-session-timeout none
vpn-filter none
vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
password-storage disable
ip-comp disable
re-xauth disable
group-lock none
pfs disable
ipsec-udp disable
ipsec-udp-port 10000
split-tunnel-policy tunnelall
split-tunnel-network-list none
default-domain none
split-dns none
intercept-dhcp disable
secure-unit-authentication disable
user-authentication disable
user-authentication-idle-timeout 30
ip-phone-bypass disable
leap-bypass disable
nem disable
backup-servers keep-client-config
msie-proxy server none
msie-proxy method no-modify
msie-proxy except-list none
msie-proxy local-bypass disable
nac disable
nac-sq-period 300
nac-reval-period 36000
nac-default-acl none
address-pools none
smartcard-removal-disconnect enable
client-firewall none
client-access-rule none
functions url-entry
http-comp gzip
filter none
url-list none
customization value DfltCustomization
port-forward none
port-forward-name value Application Access
sso-server none
deny-message value Login was successful, but because certain criteria have not
been met or due to some specific group policy, you do not have permission to us
e any of the VPN features. Contact your IT administrator for more information
svc none
svc keep-installer installed
svc keepalive none
svc rekey time none
svc rekey method none
svc dpd-interval client none
svc dpd-interval gateway none
svc compression deflate
group-policy optext internal
group-policy optext attributes
wins-server value
dns-server value
split-tunnel-policy tunnelspecified
split-tunnel-network-list value optext_splitTunnelAcl
default-domain value
client-firewall none
client-access-rule none
username upatel password 04OI33jec40Gh3vI encrypted privilege 15
tunnel-group DefaultL2LGroup ipsec-attributes
pre-shared-key *
tunnel-group DefaultRAGroup general-attributes
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
tunnel-group optext type ipsec-ra
tunnel-group optext general-attributes
address-pool optext
default-group-policy optext
tunnel-group optext ipsec-attributes
pre-shared-key *
tunnel-group-map default-group optext
class-map inspection_default
match default-inspection-traffic
<--- More --->!
policy-map type inspect dns preset_dns_map
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ctiqbe
inspect dcerpc
inspect http
inspect icmp
inspect icmp error
inspect ils
inspect ipsec-pass-thru
inspect mgcp
inspect pptp
inspect snmp
inspect waas
service-policy global_policy global
prompt hostname context
: end

Any help will be greatly appreciated.
The administrator has disabled public write access.

Re: Cisco ASA 5510 Configuration help 7 years 6 months ago #30142

  • sp1k3tou
  • sp1k3tou's Avatar
  • Offline
  • Frequent Member
  • Posts: 65
  • Karma: 0
Sorry I can't help you with the tunnel config since I don't remember how to set it up. I think it might be easy to set it up using ASDM and just point and click. One thing that stands out after looking at your config quick is that your inside interface is shutdown. You will want to configure it with the no shutdown command under interface e0/1.

interface Ethernet0/1
nameif Inside
security-level 0
ip address
The administrator has disabled public write access.

Re: Cisco ASA 5510 Configuration help 5 years 8 months ago #36195

  • sandtri
  • sandtri's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
1- You need to execute no shut on inside interface.
2- you need to configure outside (global) 1 interface.

For VPN.

You need first to create an access-list for vpn.
then transform-set
then you need to create crypto
afterthat you need to create isakmp policy.
thene you nrrd to create tunnel group for exchanging the preshared key.

Apply mentioned things. It will work.
The administrator has disabled public write access.
Time to create page: 0.092 seconds


Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V


  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup