Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: WebSite/FTP accessible from Internet but not local lan

WebSite/FTP accessible from Internet but not local lan 7 years 7 months ago #30105

  • pvr02
  • pvr02's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Alright. I got my router setup quite some time ago with a web server and FTP server (in the DMZ) but the only issue I have is that it is only able to be accessed by an internet connection outside of my own. Now I have been doing a little bit of research and have basically found 2 options.

Option 1 - Redirect the website with DNS
Option 2 - Open the DMZ to access from the LAN

Option 2 would be ideal, but not sure what this will do to the security of my local LAN. What would you recommend?

I am also pretty new to Cisco so help on the configuration would also be appreciated.

Thanks in advance.

[code:1]
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name xxxxx.local
enable password xxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxx encrypted
multicast-routing
names
!
interface Vlan1
nameif inside
security-level 100
ip address 172.16.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 50
ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 3
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
domain-name xxxxx.local
object-group service DM_INLINE_TCP_1 tcp
port-object eq ftp
port-object eq www
access-list inside_nat0_outbound extended permit ip any 172.16.0.64 255.255.255.192
access-list access_outside_dmz extended permit tcp any interface outside object-group DM_INLINE_TCP_1
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
ip local pool MyVPNDHCPPool 172.16.0.91-172.16.0.100 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (dmz,outside) tcp interface www 172.16.1.2 www netmask 255.255.255.255
static (dmz,outside) tcp interface ftp 172.16.1.2 ftp netmask 255.255.255.255
access-group access_outside_dmz in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 172.16.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

group-policy MyVPNTunnelGroup internal
group-policy MyVPNTunnelGroup attributes
dns-server value 172.16.0.4
vpn-tunnel-protocol IPSec
default-domain value xxxxx.local
username xxxxx password xxxxxxxxxxxxxx encrypted privilege 0
username xxxxx attributes
vpn-group-policy MyVPNTunnelGroup
tunnel-group MyVPNTunnelGroup type ipsec-ra
tunnel-group MyVPNTunnelGroup general-attributes
address-pool MyVPNDHCPPool
default-group-policy MyVPNTunnelGroup
tunnel-group MyVPNTunnelGroup ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:1d9ddc08b7f0bfaee05e300d84b54d75
: end
[/code:1]
The administrator has disabled public write access.

Re: WebSite/FTP accessible from Internet but not local lan 7 years 7 months ago #30127

  • hanapurna
  • hanapurna's Avatar
  • Offline
  • New Member
  • Posts: 9
  • Karma: 0
Hi,

I think option 2 would be ideal also. To allow your local lan to access the dmz, you need a nat 0 rule like this one :

[code:1]access-list inside_nat0_outbound extended permit ip 172.16.0.0 255.255.255.0 172.16.1.0 255.255.255.0
[/code:1]

I hope it will help
The administrator has disabled public write access.
Time to create page: 0.079 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup