Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: asa5510

asa5510 7 years 8 months ago #29867

  • lc
  • lc's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
hi, i configured asa 5510 via asdm for vpn remote access only but its not working. can you look at my config and please let me know ifyou have any suggestions?
thanks,

buzznetasa# sh run
: Saved
:
ASA Version 8.0(3)
!
hostname buzznetasa
enable password 769tV6dU0ihT01GQ encrypted
names
!
interface Ethernet0/0
nameif internal
security-level 100
ip address 10.100.1.18 255.255.255.0
!
interface Ethernet0/1
nameif external
security-level 0
ip address 216.xxx.xx.158 255.255.255.224
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.1.1 255.255.255.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
boot system disk0:/asa803-k8.bin
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list buzznetvpn_splitTunnelAcl standard permit host 10.100.1.10
access-list buzznetvpn_splitTunnelAcl standard permit 10.100.1.0 255.255.255.0
access-list internal_nat0_outbound extended permit ip host 10.100.1.10 192.168. 1.32 255.255.255.224
access-list nonat extended permit ip 10.100.1.0 255.255.255.0 192.168.11.0 255. 55.255.0
pager lines 24
logging asdm informational
mtu management 1500
mtu internal 1500
mtu external 1500
ip local pool buzznetvpn 192.168.11.40-192.168.11.60 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
nat (internal) 0 access-list nonat
nat (internal) 0 0.0.0.0 0.0.0.0
route external 0.0.0.0 0.0.0.0 216.116.103.129 tunneled
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 10.100.1.0 255.255.255.0 internal
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map external_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map external_map interface external
crypto isakmp enable external
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 10.100.1.0 255.255.255.0 internal
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
group-policy buzznetvpn internal
group-policy buzznetvpn attributes
dns-server value 10.100.1.10 10.100.1.13
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value buzznetvpn_splitTunnelAcl
username admin password 8FRdps//pBc2pG35 encrypted privilege 0
username admin attributes
vpn-group-policy buzznetvpn
username rick password PXafBFza4AVV7xpj encrypted privilege 0
username rick attributes
vpn-group-policy buzznetvpn
username lcardona password 46QPx/zCSAKth2Qw encrypted privilege 0
username lcardona attributes
vpn-group-policy buzznetvpn
tunnel-group buzznetvpn type remote-access
tunnel-group buzznetvpn general-attributes
address-pool buzznetvpn
default-group-policy buzznetvpn
tunnel-group buzznetvpn ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b74dcb026d63c62460448a4ff6b8371a
: end
The administrator has disabled public write access.

Re: asa5510 7 years 8 months ago #29900

  • sys-halt
  • sys-halt's Avatar
  • Offline
  • Frequent Member
  • Posts: 68
  • Karma: 0
Please can you give us some design plan, like are you making a VPN between your ASA and a Router or between 2 ASA's?

I would suggest you to build the VPN from scratch through the CLI, in that way you will have a clean config and you will be abel to track problesm easily since you have the code you used.

Please check this great article it might help you well in your VPN config:

www.routeralley.com/ra/docs/ipsec_site2site_pix_asa.pdf
The administrator has disabled public write access.

Re: asa5510 7 years 8 months ago #29925

Your default route command
(route external 0.0.0.0 0.0.0.0 216.116.103.129 tunneled )
does not look right.

Remove the "tunneled" keyword and point your default route to the external gateway next hop.

I agree also to delete all configuration and do it from scratch using CLI. (I don't know why but I hate ASDM :) )
The administrator has disabled public write access.
Time to create page: 0.082 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup