Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: ASA 5505 Permit RDP

ASA 5505 Permit RDP 7 years 7 months ago #29262

  • clayty
  • clayty's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hi,

I have recently purchased a asa 5505 and I am trying permit rdp on the outside interface to a host on the inside (10.15.1.50) I am also trying Nat a dhcp range on the outside to my inside interface. THe dhcp range 192.168.2.128/27

Any help would be much-appreciatied :(

hostname PIX
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.100.1 External
name 192.168.2.128 Client_DHCP
!
interface Vlan1
nameif inside
security-level 100
ip address 10.15.3.254 255.255.0.0
!
interface Vlan2
nameif outside
security-level 0
ip address External 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone GMT/BST 0
clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
dns server-group DefaultDNS
domain-name default.domain.invalid
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list Outside_IN extended permit tcp any eq 3389 host 10.15.1.50 log
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
asdm location External 255.255.255.255 inside
asdm location 192.168.100.2 255.255.255.255 inside
asdm location Client_DHCP 255.255.255.224 inside
no asdm history enable
arp timeout 14400
global (inside) 1 interface
nat (outside) 1 Client_DHCP 255.255.255.224 outside
access-group Outside_IN in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 10.15.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 10.15.0.0 255.255.0.0 inside
telnet timeout 10
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:373120c7d52d738318bd920989538288
The administrator has disabled public write access.

Re: ASA 5505 Permit RDP 7 years 7 months ago #29267

  • Patiot
  • Patiot's Avatar
  • Offline
  • Frequent Member
  • Posts: 45
  • Karma: 0
Hello ,

You need statics and access-lists for RDP issue.

Staic (inside,outside) tcp public ip 3389 private ip 3389 netmask 255.255.255.255
access-list outside_in permit tcp any host public ip eq 3389

And regarding the NAT for DHCP range there are different options and you got to choose from them.

one way is

nat (inside) 2 0.0.0.0 0.0.0.0
global (outside) 2 dhcp start ip - dhcp end ip netmask x.x.x.x

Thanks
Patiot
The administrator has disabled public write access.

Re: ASA 5505 Permit RDP 7 years 6 months ago #29629

  • ramasamy
  • ramasamy's Avatar
  • Offline
  • Frequent Member
  • Posts: 67
  • Karma: 0
Yes, PAT is used only for outbound traffic and you cannot establish a inbound connection to a PAT IP address, for a Inbound connection you need to One to One NAT / Static. with a ACL permitting the traffic.
The administrator has disabled public write access.

Re: ASA 5505 Permit RDP 7 years 6 months ago #29635

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Backing on Patiot's for RDP allowance.

For NAT, it seams that your config is wrongly using outside NAT in those two lines:

[code:1]global (inside) 1 interface
nat (outside) 1 Client_DHCP 255.255.255.224 outside [/code:1]

(Unless this was done for something else), You need normal inside NAT, like this:

[code:1]global (outside) 1 interface
nat (inside) 1 Client_DHCP 255.255.255.224[/code:1]

By the way, the network 192.168.2.128/27 is not defined any where in your interfaces!! :?
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: ASA 5505 Permit RDP 7 years 6 months ago #29814

the replies you got about static and acl are correct. Regarding nat/global statements, always have in mind that you must use global command on a lower security level and the nat command on the higher security level.

example: nat(inside) 1 0.0.0.0 0.0.0.0
global(outside) 1 interface
The administrator has disabled public write access.
Time to create page: 0.086 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup