Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Help, Easy ASA5505 Port forward

Help, Easy ASA5505 Port forward 8 years 1 month ago #27261

  • ajass
  • ajass's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
I have read dozens of posts on how to configure NAT and ACL and after trying just about everything I still can't get this.
Simple setup, simple need.
I have 1 static IP from ISP, 1 web server, 5 workstations. Workstations are on same VLAN as server.
All I need is for any internet computer to be able to surf my web server using my outside static IP. How hard can this be!? Please help!
Here's what I can do:

1. Surf the internet
2. Surf the web server from inside (


Result of the command: "show running-config"

: Saved
ASA Version 7.2(3)
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
interface Vlan1
nameif inside
security-level 100
ip address
interface Vlan2
nameif outside
security-level 0
ip address xx.xx.45.28
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
interface Ethernet0/2
interface Ethernet0/3
interface Ethernet0/4
interface Ethernet0/5
interface Ethernet0/6
interface Ethernet0/7
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list INBOUND extended permit tcp any host xx.xx.45.28 eq www
access-list outside_access_in extended permit tcp any host xx.xx.45.28 eq www
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1
static (outside,inside) xx.xx.45.28 netmask
static (inside,outside) xx.xx.45.28 netmask
route outside xx.xx.45.30 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns
dhcpd auto_config outside
dhcpd address inside
dhcpd enable inside

class-map inspection_default
match default-inspection-traffic
policy-map type inspect dns preset_dns_map
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
service-policy global_policy global
prompt hostname context
: end

P.s. When I enter ACL's via command line, they don't show up in the ASDM GUI? Am I missing something here?
I really need this device up and running, any help is greatly appreciated! Thanks!
The administrator has disabled public write access.

Re: Help, Easy ASA5505 Port forward 8 years 1 month ago #27294

  • dihas
  • dihas's Avatar
  • Offline
  • New Member
  • Posts: 9
  • Karma: 0
Remove the following NAT configurations:

static (outside,inside) xx.xx.45.28 netmask
static (inside,outside) xx.xx.45.28 netmask

and replace with:

static (inside,outside) tcp interface 80 80

Then enable your ACL on the outside interface:

access-group INBOUND in interface outside
The administrator has disabled public write access.
Time to create page: 0.078 seconds


Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V


  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup