Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: ASA 5505 Newbie - simple config question RE: VNC

ASA 5505 Newbie - simple config question RE: VNC 8 years 1 month ago #27099

  • AbeFroman
  • AbeFroman's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Apologies for the newbie question but I'm apparently having a brain fart on how Cisco does their ACL to NAT relationship.

The setup is pretty easy:

xxx.xxx.8.0 network ---> outside (xxx.xxx.8.9) FW inside (192.168.1.1) ---> 192.168.1.2 (running VNC)

I want to access the 1.2 machine using VNC from the 8.0 network

I believe the NAT statement is correct but I'm missing the ACL to allow just port 5900 through to the machine with that service.

Any help would be appreciated.

Here is my config on the ASA box:
: Saved
:
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name xxx.xxx.xxx.xxx
enable password kw1Ayt7qBiBRTjg. encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address xxx.xxx.8.9 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server xxx.xxx.xxx.xxx
domain-name xxx.xxx.xxx.xxx
same-security-traffic permit inter-interface
access-list outside_access_in extended permit icmp any any
???

pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp xxx.xxx.8.9 5900 192.168.1.2 5900 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.8.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns xxx.xxx.xxx.xxx
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.129 inside
dhcpd dns xxx.xxx.xxx.xxx interface inside
dhcpd domain xxx.xxx.xxx.xxx interface inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:90610666da7a3bdc892952aa30edd832
: end
The administrator has disabled public write access.

Re: ASA 5505 Newbie - simple config question RE: VNC 8 years 1 month ago #27113

  • AbeFroman
  • AbeFroman's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
lol

seriously folks this is not a hard question...unfortunately I'm using the GUI SDM deal so apologies if I didn't state earlier.


Simple deal...ACL to allow port 5900 to workstation 192.168.1.2

(**sorry**)

My experience with Cisco ACL is on router applications only...I figured it was the same simple deal.

Please post any glaring details I might have missed.
The administrator has disabled public write access.

Re: ASA 5505 Newbie - simple config question RE: VNC 8 years 1 month ago #27115

  • dihas
  • dihas's Avatar
  • Offline
  • New Member
  • Posts: 9
  • Karma: 0
Abe,

Try the following, let me know if it works.

access-list outside_access_in extended permit tcp xxx.xxx.8.0 255.255.255.0 host xxx.xxx.8.9 eq 5900
The administrator has disabled public write access.

Re: ASA 5505 Newbie - simple config question RE: VNC 8 years 1 month ago #27157

  • AbeFroman
  • AbeFroman's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Cool...yes that works.

Does anyone have a link to a guide on how the SDM works? That thing is a pain in the ass to navigate.
The administrator has disabled public write access.

Re: ASA 5505 Newbie - simple config question RE: VNC 8 years 1 month ago #27249

  • stub
  • stub's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi,


Could u try this one? It shout work.


static (inside,outside) tcp interface 5900 192.168.1.2 5900 netmask 255.255.255.255

access-list access outside_access_in permit tcp any interfce outside eq 5900

access-group outside_access_in in intface outside.

Please let me know if it is working.



Regards,

Muthu.

This email address is being protected from spambots. You need JavaScript enabled to view it.
The administrator has disabled public write access.
Time to create page: 0.085 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup