Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Problem with asa 5505

Problem with asa 5505 8 years 8 months ago #25600

  • ajnabeeaj
  • ajnabeeaj's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
well i have a problem with my asa 5505.my isp has given a range of public ip to me 255.255.255.240 and i want to pat a single ip XXX.XXX.XXX.83 out to the internet for the users. in middle there is a router given my isp and its ip address is in the same range. i have a problem when i connect my pc to the firewall with ip address 192.168.20.2 my explorer is not showing my any web site. and i cannot ping inside to outside interface.please help me out i will be really thank full
my runing configuration of asa is

: Saved
: Written by enable_15 at 04:30:58.287 UTC Fri Apr 4 2008
!
ASA Version 7.2(3)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.20.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address XX.XXX.XXX.82 255.255.255.240
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list inside_access_out extended permit ip host 192.168.20.2 host XX.XXX.XXX.82
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 1 XX.XXX.XXX.83 netmask 255.255.255.240
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_out out interface inside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.20.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.20.2-192.168.20.254 inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:5920e90905047af30641aced0ee849d3
: end
The administrator has disabled public write access.

Re: Problem with asa 5505 8 years 8 months ago #25605

  • saidfrh
  • saidfrh's Avatar
  • Offline
  • Distinguished Member
  • Posts: 92
  • Karma: 0
Setting PAT and DHCP on ASA5505

global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
dhcpd address 172.16.1.101-172.16.1.132 inside
dhcpd dns x.x.x y.y.y.y
dhcpd wins x.x.x..x
dhcpd enable inside

The above changes your private IPs to the ASA's outside interface public IP.

Since you can not exclude any static private IPs, I set the DHCP range so it does not overlap with any static IPs. You want to assign static IPs to LAN printers, servers.
The administrator has disabled public write access.

Re: Problem with asa 5505 8 years 8 months ago #25608

  • ajnabeeaj
  • ajnabeeaj's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
yes but i want to finish this first i cannot access internet from my pc when i connect to the inside interface. when i connect to the inside and ping the inside interface its getting the reply but when i ping the outside interface there is not reply. i dont knw i am fresher in this field of security i would really appreciate that thank you
The administrator has disabled public write access.

Re: Problem with asa 5505 8 years 6 months ago #26090

  • aphex
  • aphex's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
You havent established a static route.

"route 0.0.0.0 0.0.0.0 gatewayipaddress 1"
The administrator has disabled public write access.

Re: Problem with asa 5505 8 years 6 months ago #26091

  • sp1k3tou
  • sp1k3tou's Avatar
  • Offline
  • Frequent Member
  • Posts: 65
  • Karma: 0
Like stated you need a route command to get to the outside but you will need to use


route outside 0.0.0.0 0.0.0.0 gateway ip
The administrator has disabled public write access.
Time to create page: 0.083 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup