Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Cisco ASA route public ip

Cisco ASA route public ip 8 years 10 months ago #24858

Dears

Good Day

I need help how to configure this topology



internet
ASA
Mikrotik
hotspot clients (public IP)
|
|
Squid


Dears
From internet to ASA I had public IP let say (X.X.X.X/25) and from ASA to mikrotik and Squid I have Private IP (10.250.1.0/24) and from Mikrotik to clients I have another Public IP range (Y.Y.Y.Y/22)



So in Mikrotik I remove NAT for all ports except browsing I forward it to squid and other destnation port route them to ASA ie default route it ASA Inside IP

In ASA I PAT the network (10.250.1.0/24) and route the Y.Y.Y.Y to outside and route back the Y.Y.Y.Y to Mikrotik I put allow access list fron any inside to any and allow any to Y.Y.Y.Y for outside interface

The problem is I can browse but cant let other to work like yahoo messenger

I disable NAT control its not work use NAT 0 for Y.Y.Y.Y and not work and use Nat exempt and not work I not see the Y.Y.Y.Y in firewall Log

By the way I just change ASA with other firewall name clavister its work great

Please any help and sorry for my bad english.



Regards
The administrator has disabled public write access.

Re: Cisco ASA route public ip 8 years 10 months ago #24864

  • sp1k3tou
  • sp1k3tou's Avatar
  • Offline
  • Frequent Member
  • Posts: 65
  • Karma: 0
I think your problem is in your allow list. I think you need to allow the port yahoo uses. I would open ASDM and turn on the logging and see what happens when they try to access yahoo.


Can you post up the running-config of the ASA?
The administrator has disabled public write access.

Re: Cisco ASA route public ip 8 years 10 months ago #24870

: Saved
:
PIX Version 8.0(3)
!
hostname pixfirewall
domain-name XYXYXYX
names
name 10.250.1.120 ISP1_GW
name 10.200.0.0 ISP1_net
name 10.250.1.109 ISP2_GW
name 10.203.0.0 ISP2_net
name 10.250.1.110 ISP3_GW
name 10.204.0.0 ISP3_net
name 10.250.1.44 Squid
name 10.250.1.108 Wifi_GW
name Y.Y.Y.129 World_GW
name 10.202.0.0 WiFi_net
!
interface Ethernet0
nameif outside
security-level 100
ip address Y.Y.Y.133 255.255.255.128
!
interface Ethernet1
nameif inside
security-level 100
ip address 10.250.1.253 255.255.255.0
!
!
ftp mode passive
clock timezone AST 3
dns server-group DefaultDNS
domain-name XYXYXYXY
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list inside_access_in extended permit ip any any log debugging

access-list inside_access_in extended permit ip X.X.X.0 255.255.252.0 any
access-list outside_access_in extended deny ip any any
access-list outside_access_in_1 extended permit ip any X.X.X.0 255.255.252.0 log
access-list inside_nat0_outbound extended permit ip X.X.X.0 255.255.252.0 any
access-list inside_nat0_outbound_1 extended permit ip X.X.X.0 255.255.252.0 any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu DMZ 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit 10.250.1.0 255.255.255.0 inside
asdm image flash:/asdm-603.bin
no asdm history enable
arp timeout 14400
global (outside) 103 interface
nat (inside) 0 access-list inside_nat0_outbound_1
nat (inside) 0 access-list inside_nat0_outbound outside
nat (inside) 103 10.250.1.0 255.255.255.0
nat (inside) 103 WiFi_net 255.255.252.0
access-group outside_access_in_1 in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 World_GW 1
route inside ISP1_net 255.255.248.0 ISP1_GW 1
route inside WiFi_net 255.255.252.0 Wifi_GW 1
route inside X.X.X.0 255.255.252.0 ISP1_GW 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication telnet console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 outside
http 10.250.1.0 255.255.255.0 inside
snmp-server host inside 10.250.1.111 community public version 2c
no snmp-server location
no snmp-server contact
snmp-server community IsPublic
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt connection tcpmss 0
no crypto isakmp nat-traversal
telnet 0.0.0.0 0.0.0.0 outside
telnet 10.250.1.0 255.255.255.0 inside
telnet timeout 5
ssh scopy enable
ssh 0.0.0.0 0.0.0.0 outside
ssh 10.250.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
priority-queue outside
queue-limit 488
tx-ring-limit 8
priority-queue inside
no threat-detection basic-threat
threat-detection statistics access-list
!

!
class-map global-class
match port tcp eq www
class-map inspection_default
match default-inspection-traffic
class-map global-class1
match port tcp eq domain
class-map global-class2
match port udp eq domain
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class global-class
priority
class global-class1
priority
class global-class2
priority
class inspection_default
inspect dns preset_dns_map
inspect esmtp
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect sip
inspect skinny
inspect sqlnet
inspect sunrpc
inspect tftp
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:412bf8836aab36d7c479f0e60bad4924
: end
asdm image flash:/asdm-603.bin
asdm location ISP2_net 255.255.252.0 inside
asdm location ISP3_net 255.255.252.0 inside
asdm location Wifi_GW 255.255.255.255 inside
asdm location ISP2_GW 255.255.255.255 inside
asdm location ISP3_GW 255.255.255.255 inside
asdm location ISP1_GW 255.255.255.255 inside
asdm location World_GW 255.255.255.255 inside
asdm location ISP1_net 255.255.248.0 inside
asdm location WiFi_net 255.255.252.0 inside
no asdm history enable
The administrator has disabled public write access.

Re: Cisco ASA route public ip 8 years 10 months ago #24871

Dear


In ASDM LOG I cant see the X.X.X.X network just 10.250.1.0/24


Regards
The administrator has disabled public write access.

Re: Cisco ASA route public ip 8 years 10 months ago #24875

  • sp1k3tou
  • sp1k3tou's Avatar
  • Offline
  • Frequent Member
  • Posts: 65
  • Karma: 0
I would think this is what is stopping your messenger traffic from being able to come in.

access-list outside_access_in extended deny ip any any
access-list outside_access_in_1 extended permit ip any X.X.X.0 255.255.252.0 log



I think you need to put a access-list before them like this below. I think the messenger software use https but I'm not sure.

access-list outside_access_in extended permit tcp 10.250.1.0 255.255.255.0 eq https
The administrator has disabled public write access.

Re: Cisco ASA route public ip 8 years 10 months ago #24878

Do I need to put an access list for inbound my outside interface with my inside privare network !!??

buy the way this
access-list outside_access_in extended deny ip any any

not assaig for interface group list
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.086 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup