Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: ASA 5510 initial setup. Can't reach the outside from inside.

ASA 5510 initial setup. Can't reach the outside from inside. 9 years 4 months ago #21941

  • Sielle
  • Sielle's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
I'm having trouble setting up an ASA 5510, more specifically trying to ping an outside IP from the inside interface. When using the ASDM and pinging from the outside interface I can ping and get a response from the internet, but when trying to ping the internet from the inside interface I'm not getting any response. I'm sure its something simple that I've overlooked so I've attached my sanitized config if anyone could take a look at it? Thanks.


: Saved
:
ASA Version 7.2(2)
!
hostname *****
domain-name ****.**
enable password ***** encrypted
names
!
interface Ethernet0/0
nameif Outside
security-level 0
ip address *.*.198.2 255.255.255.0
!
interface Ethernet0/1
shutdown
nameif VPN
security-level 0
no ip address
!
interface Ethernet0/2
nameif DMZ
security-level 50
ip address 10.1.102.1 255.255.255.0
!
interface Ethernet0/3
nameif Inside
security-level 100
ip address 10.30.11.1 255.255.255.0
!
interface Management0/0
nameif management
security-level 100
ip address 192.168.0.9 255.255.255.0
management-only
!
passwd ***** encrypted
ftp mode passive
dns domain-lookup Outside
dns domain-lookup VPN
dns domain-lookup DMZ
dns domain-lookup Inside
dns server-group DefaultDNS
name-server *.*.*.2
name-server *.*.*.250
domain-name fulcrum.net
same-security-traffic permit intra-interface
access-list Inside_nat_outbound extended permit ip any any
pager lines 24
logging asdm informational
mtu Outside 1500
mtu VPN 1500
mtu DMZ 1500
mtu Inside 1500
mtu management 1500
no failover
monitor-interface Outside
monitor-interface VPN
monitor-interface DMZ
monitor-interface Inside
monitor-interface management
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
nat (Inside) 1 0.0.0.0 0.0.0.0
route Outside 0.0.0.0 0.0.0.0 *.*.198.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.0.0 255.255.255.0 management
http 0.0.0.0 0.0.0.0 Inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map Outside_dyn_map 20 set pfs
crypto dynamic-map Outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map Outside_map 65535 ipsec-isakmp dynamic Outside_dyn_map
crypto map Outside_map interface Outside
crypto isakmp enable Outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
management-access management
dhcpd address 192.168.0.10-192.168.0.254 management
dhcpd enable management
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:******
: end
asdm image disk0:/asdm-522.bin
no asdm history enable
The administrator has disabled public write access.

Re: ASA 5510 initial setup. Can't reach the outside from inside. 9 years 4 months ago #21944

  • Sielle
  • Sielle's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
Just to add a bit more information, a couple of things I thought it could be, but which look right to me were the route outside or the NAT settings. I know it's going to be something simple, but I'm just overlooking it.
The administrator has disabled public write access.

Re: ASA 5510 initial setup. Can't reach the outside from inside. 9 years 4 months ago #21951

  • Sielle
  • Sielle's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
It wouldn't have anything to do with the access lists would it? By default the sec level 100 should be able to access the sec level 0 interface, right?
The administrator has disabled public write access.

Re: ASA 5510 initial setup. Can't reach the outside from inside. 9 years 4 months ago #21960

  • Smurf
  • Smurf's Avatar
  • Offline
  • Moderator
  • Posts: 1390
  • Karma: 1
I am just doing a search on this because there is a specific term that is happening here (well i think is happening).

I have no experience with the ASA but, the Pix will not allow (by default, i beleive it can be changed) anyone to ping through the pix to another interface on the pix. So for example, if i was on the inside network and i tried to ping the outside interface, even with no access-lists on any interface, it will not be allowed. I beleive its the same thing thats happening because i am unable to do the same thing on my Pix firewall.

Its something like Hair Pinning or something but cannot quite remember the term, someone posted it in another thread.
Wayne Murphy
Firewall.cx Team Member
www.firewall.cx

Now working for a Security Company called Sec-1 Ltd in the UK, for any
Penetration Testing work visit www.sec-1.com or PM me for details.
The administrator has disabled public write access.

Re: ASA 5510 initial setup. Can't reach the outside from inside. 9 years 4 months ago #21963

  • skepticals
  • skepticals's Avatar
  • Offline
  • Expert Member
  • Posts: 783
  • Karma: 0
Smurf,

You are correct, it is Hairpinning. I believe you have to create an ACL that will allow the ICMP traffic.
The administrator has disabled public write access.

Re: ASA 5510 initial setup. Can't reach the outside from inside. 9 years 4 months ago #21964

  • Sielle
  • Sielle's Avatar
  • Offline
  • New Member
  • Posts: 6
  • Karma: 0
I'm not actually trying to ping the interface though, I'm attempting to ping through it to an address on the internet.


Client --> Inside Interface --> Outside interface --> Router --> Internet


From the client I shouldn't be able to ping the outside interface itself, but I should be able to hit the router or anything on the internet, correct?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.089 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup