Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: inherit ASA5505 - VPN issue

inherit ASA5505 - VPN issue 1 year 6 months ago #38641

  • kbd
  • kbd's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
Hi all, just to be clear, I know just enough to setup a Cisco ASA and also remote & site vpn, but the troubleshooting portion is where I need help on all the time.
here's the issue, I've just started with this company and they have no networking people, they had an sql person setup this ASA5505 and it seems to work so far, but now I'm trying to setup Remote VPN so that we have capability to work from from or outside of office instead of RDPs. I've went thru the setup wizard for remote VPN and have done it all the time and it works before but could not figured out why it's not working on this particular one. After going thru wizard, i was able to connect and get an IP from the Pool I setup (172.31.254.x/24), but could not hit any inside traffic (192.168.0.x/23), even though I exposed the inside network already. I use the packet tracer tool from asdm from "inside to inside" but the NAT drop it. I also turn on NAT traversal but not good either. I'm not good with NAT portion so that's where I'm stuck.
A week later, since I get side track with other stuffs, now I cannot even connect via vpn at all. Please help.
Also, there is however a "Site2Site VPN" tunnel that's working and cannot knock it out since it's crucial 24x7.
Please see the attached config and guide me in the right direction. Thank you all in advance.
Oh yes, I'm well aware of the statement that the sql person "allows all connection" from outside, and will correct that once I get this Remote VPN working.
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2015.05.27 16:57:52 =~=~=~=~=~=~=~=~=~=~=~=
show run
: Saved
:
ASA Version 8.2(5)
!
hostname ciscoasaFiber
enable password n3SR9j./hWrWL7P. encrypted
passwd 7XPcqq3rA5one2rP encrypted
names
name 10.0.0.0 Tunnel1_Remote_LAN
name 10.144.208.224 BVI-Server
name 192.168.0.150 AppServer1
name 192.168.0.35 Wins-FTP
name 192.168.0.250 StorageServer1 description StorageServer1
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!

!
interface Ethernet0/5
switchport access vlan 12
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
mac-address 00a0.c56b.fb59
nameif Inside-1.3
security-level 100
ip address 192.168.1.3 255.255.254.0
!
interface Vlan2
mac-address 00a0.c56b.fb58
nameif T1-Public-62
security-level 0
ip address x.x.x.14 255.255.255.248
!
interface Vlan12
no nameif
no security-level
ip address 192.168.40.1 255.255.255.0
!


ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service BVI tcp
description BVI Video ports
port-object range 34000 36000
object-group protocol DM_INLINE_PROTOCOL_1
protocol-object udp
protocol-object tcp
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
object-group service SSL-446 tcp
port-object eq 446
object-group service ftp--ftp-data tcp
port-object eq ftp
port-object eq ftp-data
access-list outside_1_cryptomap extended permit ip x.x.x.8 255.255.255.248 Tunnel1_Remote_LAN 255.0.0.0
access-list inside_nat0_outbound extended permit ip x.x.x.8 255.255.255.248 Tunnel1_Remote_LAN 255.0.0.0
access-list Inside-1.3_access_in extended permit ip any any
access-list Inside-1.3_mpc extended permit tcp host BVI-Server any object-group BVI inactive
access-list T1-Public-62_nat0_outbound extended permit ip any 192.168.0.0 255.255.254.0


access-list Inside-1.3_nat0_outbound extended permit ip 192.168.0.0 255.255.254.0 192.168.1.240 255.255.255.252
access-list Inside-1.3_nat0_outbound extended permit ip 192.168.0.0 255.255.254.0 192.168.1.248 255.255.255.252
access-list Inside-1.3_nat0_outbound extended permit ip 192.168.0.0 255.255.254.0 172.31.254.0 255.255.255.0
access-list T1-Public-62_access_in extended permit tcp any host Wins-FTP object-group ftp--ftp-data
access-list M$E-RemoteVPN_splitTunnelAcl standard permit host StorageServer1
access-list M$E-RemoteVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.254.0
pager lines 24
logging enable
logging timestamp
logging buffer-size 8192
logging asdm-buffer-size 256
logging buffered errors
logging trap errors
logging asdm errors
logging from-address This email address is being protected from spambots. You need JavaScript enabled to view it.
logging recipient-address This email address is being protected from spambots. You need JavaScript enabled to view it. level critical
logging recipient-address This email address is being protected from spambots. You need JavaScript enabled to view it. level errors
logging host Inside-1.3 192.168.0.5
logging rate-limit 1 300 level 4
logging rate-limit 1 300 level 5
logging rate-limit 1 300 level 6
logging rate-limit 1 300 level 7
mtu Inside-1.3 1500
mtu T1-Public-62 1500


ip local pool RemoteVPNPool 172.31.254.1-172.31.254.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm history enable
arp timeout 14400
global (T1-Public-62) 1 interface
nat (Inside-1.3) 0 access-list Inside-1.3_nat0_outbound
nat (Inside-1.3) 1 0.0.0.0 0.0.0.0
nat (T1-Public-62) 0 access-list T1-Public-62_nat0_outbound outside
static (Inside-1.3,T1-Public-62) tcp interface ftp Wins-FTP ftp netmask 255.255.255.255
static (Inside-1.3,T1-Public-62) tcp interface ftp-data Wins-FTP ftp-data netmask 255.255.255.255
access-group Inside-1.3_access_in in interface Inside-1.3
access-group T1-Public-62_access_in in interface T1-Public-62
route T1-Public-62 0.0.0.0 0.0.0.0 x.x.x.9 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL


aaa authentication ssh console LOCAL
http server enable
http 192.168.0.0 255.255.254.0 Inside-1.3
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt connection preserve-vpn-flows
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto ipsec df-bit clear-df T1-Public-62
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA

ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer x.x.x.114


crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set nat-t-disable
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface T1-Public-62
crypto ca trustpoint _SmartCallHome_ServerCA
crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
6c2527b9 deb78458 c61f381e a4c4cb66
quit
crypto isakmp identity address
crypto isakmp enable T1-Public-62
crypto isakmp policy 170
authentication pre-share
encryption 3des
hash md5
group 2
lifetime none
crypto isakmp policy 190
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400

telnet timeout 5
ssh x.x.x.61 255.255.255.255 Inside-1.3
ssh 192.168.0.0 255.255.254.0 Inside-1.3
ssh 172.31.254.0 255.255.255.0 Inside-1.3
ssh timeout 10
console timeout 0
dhcpd auto_config T1-Public-62
!

threat-detection basic-threat
no threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server x.x.x.111 source T1-Public-62
ntp server x.x.x.95 source T1-Public-62
webvpn
group-policy GroupPolicyx.x.x.114 internal
group-policy GroupPolicyx.x.x.114 attributes
vpn-tunnel-protocol IPSec
group-policy M$E-RemoteVPN internal
group-policy M$E-RemoteVPN attributes
dns-server value 8.8.8.8 4.2.2.2
vpn-filter value M$E-RemoteVPN_splitTunnelAcl
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified


split-tunnel-network-list value M$E-RemoteVPN_splitTunnelAcl
username xxx xxx xxx encrypted privilege 15
username xxx xxx xxx encrypted privilege 15
username xxx xxx xxx encrypted privilege 15
username xxx xxx xxx encrypted privilege 15
username xxx xxx xxx encrypted privilege 15
tunnel-group x.x.x.114 type ipsec-l2l
tunnel-group x.x.x.114 general-attributes
default-group-policy GroupPolicyx.x.x.114
tunnel-group x.x.x.114 ipsec-attributes
pre-shared-key *****
isakmp keepalive disable
tunnel-group M$E-RemoteVPN type remote-access
tunnel-group M$E-RemoteVPN general-attributes
address-pool RemoteVPNPool
default-group-policy M$E-RemoteVPN
tunnel-group M$E-RemoteVPN ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic


class-map Inside-1.3-class
match access-list Inside-1.3_mpc
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map Inside-1.3-policy
class Inside-1.3-class
police output 500000 1500
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp

inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
service-policy Inside-1.3-policy interface Inside-1.3
smtp-server 192.168.0.15 x.x.x.65
prompt hostname context
call-home reporting anonymous
Cryptochecksum:e2834f5dab2b7e31ba50fdf5a0f77606
: end

ciscoasaFiber#

ciscoasaFiber#

ciscoasaFiber# show run acce

ciscoasaFiber# show run access-lis

ciscoasaFiber# show run access-list
access-list outside_1_cryptomap extended permit ip x.x.x.8 255.255.255.248 Tunnel1_Remote_LAN 255.0.0.0
access-list inside_nat0_outbound extended permit ip x.x.x.8 255.255.255.248 Tunnel1_Remote_LAN 255.0.0.0
access-list Inside-1.3_access_in extended permit ip any any
access-list Inside-1.3_mpc extended permit tcp host BVI-Server any object-group BVI inactive
access-list T1-Public-62_nat0_outbound extended permit ip any 192.168.0.0 255.255.254.0
access-list Inside-1.3_nat0_outbound extended permit ip 192.168.0.0 255.255.254.0 192.168.1.240 255.255.255.252
access-list Inside-1.3_nat0_outbound extended permit ip 192.168.0.0 255.255.254.0 192.168.1.248 255.255.255.252
access-list Inside-1.3_nat0_outbound extended permit ip 192.168.0.0 255.255.254.0 172.31.254.0 255.255.255.0
access-list T1-Public-62_access_in extended permit tcp any host Wins-FTP object-group ftp--ftp-data
access-list M$E-RemoteVPN_splitTunnelAcl standard permit host StorageServer1
access-list M$E-RemoteVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.254.0

ciscoasaFiber#

ciscoasaFiber#

ciscoasaFiber#

ciscoasaFiber# show cryp isa sa

Active SA: 1
Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1 IKE Peer: x.x.x.114
Type : L2L Role : initiator
Rekey : no State : MM_ACTIVE

ciscoasaFiber#

ciscoasaFiber#

ciscoasaFiber# show run nat
nat (Inside-1.3) 0 access-list Inside-1.3_nat0_outbound
nat (Inside-1.3) 1 0.0.0.0 0.0.0.0
nat (T1-Public-62) 0 access-list T1-Public-62_nat0_outbound outside

ciscoasaFiber#

ciscoasaFiber#

ciscoasaFiber# exit

Logoff
Last Edit: 1 year 6 months ago by kbd.
The administrator has disabled public write access.

inherit ASA5505 - VPN issue 1 year 6 months ago #38654

  • kbd
  • kbd's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
issues resolved. Mods, you can close this thread.
Last Edit: 1 year 6 months ago by kbd.
The administrator has disabled public write access.

inherit ASA5505 - VPN issue 1 year 6 months ago #38658

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
Kdb,

Thanks for your reply. Mind telling us what your solution was? Just so that anyone else experiencing the same issue can benefit from your solution?

Thanks,

Chris.
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.

inherit ASA5505 - VPN issue 1 year 5 months ago #38659

  • kbd
  • kbd's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Thank you received: 1
  • Karma: 1
there was another router/filtering device in place, which serves as the gateway that i wasnt aware of. once i added the route to that router for the VPN Pool subnet, all was routing properly.
The administrator has disabled public write access.
The following user(s) said Thank You: Chris

inherit ASA5505 - VPN issue 1 year 5 months ago #38667

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
Awesome! Thanks for taking the time to inform us.

Chris.
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.
Time to create page: 0.148 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup