Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Double Nat with Cisco asa 5505

Double Nat with Cisco asa 5505 5 years 10 months ago #35794

  • MavsX
  • MavsX's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi-

I'm hoping i can get some help for an issue i'm having. I'm double natting with a verizon action tec router and my cisco asa 5505 behind that. I had everything working when i had a linksys router/wifi AP , but i pulled out the linksys and put the asa 5505 in it's place. I thought i had everything looking good, but, it doesn't work. When the outside interface is set to dhcp it works. but later on i want to add port forwarding to my network, so i want to get the outside interface of the cisco asa to 192.168.1.251/24

Here is my setup:

internet > fios action tec router > cisco asa 5505

i've got a dynamic IP from Verizon > the action tec router hands out IP's in the 192.168.1.2 -192.168.1.250 /24 subnet. the action tec is 192.168.1.1

the asa outside interface is 192.168.1.X/24 (it's getting it via dhcp from the actiontec) and the inside interfaces are 10.1.1.2-10.1.1.26. Mangement interface is 10.1.1.1

Everything is working fine, but, when i change the cisco outside interface to a static IP of 192.168.1.251/24 i can't get out onto the internet. If i set the outside interface back to get an IP from the action tec, the interface comes up and i'm fine on the net.
ciscoasa> en
Password: ***********
ciscoasa# show run
: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password oUptWweif9uVqAXo encrypted
passwd oUptWweif9uVqAXo encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Vlan3
shutdown
no forward interface Vlan1
nameif dmz
security-level 50
no ip address
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 10.1.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh 10.1.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcp-client client-id interface outside
dhcpd auto_config outside
!
dhcpd address 10.1.1.2-10.1.1.26 inside
dhcpd dns x.252.0.x x.242.0.x interface inside
dhcpd enable inside
!

username admin password 4F5RVIJxqcaUyNKc encrypted privilege 15
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
message-length maximum client auto
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:e69bef80afbc3dd75c5fdc88772f3127
: end
ciscoasa#
The administrator has disabled public write access.

Re: Double Nat with Cisco asa 5505 5 years 9 months ago #35802

  • MavsX
  • MavsX's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
i figured it out. Since the command "ip address dhcp setroute" is setting the default route based on my dhcp ip address, once i set it too a static ip, the outside interface didn't know what to do. So i set a default route of route outside 0.0.0.0 0.0.0.0 192.168.1.1 i also waited for the action tec router to let the arp time out, and i was back in business...
The administrator has disabled public write access.
Time to create page: 0.081 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup