Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Cisco 2620 to Comcast trouble.

Cisco 2620 to Comcast trouble. 12 years 5 months ago #3540

Hi there all. I picked up a Cisco 2620 router to learn on, and wanted to use it for NAT on my Comcast Broadband to save the trouble of buying a cheap router. While troubleshooting, I ran across another person that seemed to have the same trouble in one of your forums. However, there was no follow up to it saying that he solved his problem.

So, I'm wondering if anyone can help. The cable modem is an RCA DCM 305, and the Cisco is a 2620 running IOS 12.2 The cable modem is connected to Ethernet 1/0 and Fast Ethernet 0/0 is connected to a Catalyst 2924. There are about 5 PC's and a WAP connected to the Catalyst.

The problem is that I can't communicate with the Internet. I can ping the inside and outside interface from any computer on the network. I can also ping the network computers from the router. But I cannot ping any computer on the internet from the router.

Here is the show version from the router:

show version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JK9O3S-M), Version 12.2(12a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 24-Sep-02 03:47 by pwade
Image text-base: 0x8000808C, data-base: 0x815AC664

ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

2600 uptime is 59 minutes
System returned to ROM by power-on
System image file is "flash:c2600-jk9o3s-mz.122-12a.bin"

cisco 2620 (MPC860) processor (revision 0x600) with 61440K/4096K bytes of memory.
Processor board ID JAD05220KFF (509908001)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
1 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

And here is the show config:

show config
Using 1219 out of 29688 bytes
version 12.2
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname 2600
enable password XXXXXXX
clock timezone central -6
ip subnet-zero
no ip dhcp conflict logging
ip dhcp excluded-address
ip dhcp ping packets 3
ip dhcp ping timeout 100
ip dhcp pool homedhcppool
lease 3
ip audit notify log
ip audit po max-events 100
no call rsvp-sync

interface FastEthernet0/0
ip address
ip nat inside
no ip mroute-cache
duplex auto
speed auto
no cdp enable
no mop enabled
interface Ethernet1/0
ip address dhcp
ip nat outside
no cdp enable
no mop enabled
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
ip route Ethernet1/0
no ip http server
access-list 1 permit any
dial-peer cor custom
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password XXXXXX
ntp authenticate
ntp source Ethernet1/0
ntp server


Any ideas on what's wrong? Thanks a lot!

Chris Stoopes <silver133 (at)>
[code:1] I have sanitized your post to remove the password hashes and spam-proof your email address. We get all sorts of creepy-crawlees here
-- sahirh, moderator. [/code:1]
The administrator has disabled public write access.

Re: Cisco 2620 to Comcast trouble. 12 years 5 months ago #3548

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
Hi Speedy,

With a first quick look, the configuration seems fine so I would expect it to work.
However, since your trying to troublelshoot the problem, I'd suggest you assing a static IP address to your ethernet interface, disable all DHCP services on the router, remove commands such as "duplex auto" , "speed auto". The goal here is to try and see if you can 'see' the outside world using minimum configuration. If that works, then you can start adding the commands previously removed until you find out which command is causing the problem.

In the case the router cannot see the outside world with the minimum configuration, doublecheck your modem to ensure there isnt something you have overlooked.

Lastly, the debug commands are your best friend so make good use of them. If your telnetting into the router, make sure you give the "terminal monitor" command to send the debug output to the VTY terminal your connected.

A few important debug commands:

- debug ip packet
- debug ip packet detail (if the above command shows there is a problem)
- debug interface [ethernet 0/1] [fastethernet 0/1]

Let us know of your finding!

Chris Partsenidis.
Founder & Editor-in-Chief
The administrator has disabled public write access.

Reply to post 12 years 5 months ago #3562

I attempted to do what you said. I ran into a couple of snags. I took out the duplex statements with a "no duplex full" and "no duplex auto", but the router simply put them back in. I believe my only options were full, half, or auto. The fast ethernet interface defaulted back to auto, and the ethernet one defaulted to half.

The DHCP is a toughy. The only way Comcast will send me an ip address is through DHCP. I suppose I could try putting in a static one assigned from the DHCP server, but I don't know the gateway. I know it gives me an ip. I'll work on that one. I think I did get something important out of the ip debug though:

00:20:11: IP: s= (local), d= (Ethernet1/0), len 100, encapsulation failed

That is the result of a ping sent to from the 2620. I got an ip debug for the broadcast packets my cable modem receives also:

00:07:20: IP: s= (local), d= (Ethernet1/0), len 50, sending broad/multicast

Those are the 2 common messages I got. Does this help?


The administrator has disabled public write access.

Re: Cisco 2620 to Comcast trouble. 12 years 5 months ago #3564

  • sahirh
  • sahirh's Avatar
  • Offline
  • Honored Member
  • Posts: 1700
  • Karma: 0
The second message isn't a problem.. the first is.. encapsulation failed hmmm.. does your provider use PPOE or something similar ?
Sahir Hidayatullah. Staff - Associate Editor & Security Advisor
The administrator has disabled public write access.

Reply to post 12 years 5 months ago #3565

To be honest, I'm not sure about PPPoE.

There are 2 different ways I hooked it up and every thing just "worked". I can plug the catalyst 2924 into the cable modem, set the computers to be DHCP clients, and Comcast will give up to 4 IP addresses. However, past the 1st IP I pay $4.95 a pop. And I have 5 computers.

Or, I can connect an inexpensive router. I tried it with a Netear WGR614v4. It gets the IP from Comcast via DHCP, and does NAT on its own. I don't believe that it uses PPPoE

As soon as I tried it with the 2620, it didn't work. I got those encapsulation errors. Is it possible to set up the 2620 so I can try PPPoE? I've never dealt with that before.


The administrator has disabled public write access.

Re: Cisco 2620 to Comcast trouble. 12 years 5 months ago #3567

  • Neon
  • Neon's Avatar
  • Offline
  • Distinguished Member
  • Posts: 101
  • Karma: 0
I grabbed this from Cisco:

Something in the running-config of the 2611 router might spark a few ideas what may be missing…
The administrator has disabled public write access.
Time to create page: 0.095 seconds


Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V


  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup