Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: port forwading terminal services (RDP) with putty - ssh

port forwading terminal services (RDP) with putty - ssh 11 years 8 months ago #7550

  • LostBoy
  • LostBoy's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
I cannot RDP to a server behind a firewall. I can tunnel through an SSH server but using PUTTY and RDP I get:

'client could not connect. You are already connected to the console of this console of this computer. A new console session cannot be established'

I've read this is because XP doesn't allow connections to its loopback 127.0.0.1. I'm on XP SP2 so I 've read that I cannot use the other ips in the loopback range but the post -SP2 patch should fix this problem.

www.bluestream.org/Networking/SSHTunnelRDP.htm

and

web.ask.com/redir?u=http%3a%2f%2fwww.web...2fmessage438825.html

I've tried installing the SP2 patch.....yet when I checked it against Microsoft's website, it didn't list it as installed. Also when I tried pinging e.g. 127.0.0.155 it would reply with 127.0.0.1!

Also what should I put in my x display location (in the SSH/Tunnels) and what do I put in my source port and destination. and what IP am I connecting to in RDP. I've tried a number of IPs with no luck

Thanks.
The administrator has disabled public write access.

Re: port forwading terminal services (RDP) with putty - ssh 11 years 8 months ago #7556

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
I've tried installing the SP2 patch.....yet when I checked it against Microsoft's website, it didn't list it as installed. Also when I tried pinging e.g. 127.0.0.155 it would reply with 127.0.0.1!

Doesn't matter. That is standard behaviour. I also have this patch installed. You didn't mention that you had tried to connect again after installing the patch. It should work OK.

In the source IP/port field you can use 127.0.0.2:3389. 3389 is the standard RDP port. You can use any local source port as long as your RDP client allows to specify the port. But you can stick with 3389 just in case. For the destination IP/port field, you need to know the "local" address of the server. By "local" I mean the address of the server in its local network. If for example the server address is 192.168.0.1, then you can use 192.168.0.1:3389. Hope this helps.

You do not need to put anything in the X display location field.
The administrator has disabled public write access.

SSH 11 years 8 months ago #7572

  • TheBishop
  • TheBishop's Avatar
  • Offline
  • Moderator
  • Posts: 1719
  • Thank you received: 8
  • Karma: 5
I cna't get it to work either. Before applying the MS patch my RDP session just hung, after applying the patch I connect to my own machine. I've tried 127.0.0.2 and 127.0.0.10 (in case maybe the first three loopbacks were somehow associated with the internal RDP sessions). My SSH session is fully established and I'm logged in to the remote SSH host and can execute commands on it, but the RDP forwarding just isn't working right now
The administrator has disabled public write access.

SSH 11 years 8 months ago #7574

  • TheBishop
  • TheBishop's Avatar
  • Offline
  • Moderator
  • Posts: 1719
  • Thank you received: 8
  • Karma: 5
Okay we sussed this one out!!

DaLight wrote:
In the source IP/port field you can use 127.0.0.2:3389. 3389 is the standard RDP port. You can use any local source port as long as your RDP client allows to specify the port. But you can stick with 3389 just in case. For the destination IP/port field, you need to know the "local" address of the server. By "local" I mean the address of the server in its local network. If for example the server address is 192.168.0.1, then you can use 192.168.0.1:3389. Hope this helps

Me and DaLight have been playing with this :idea: :idea: .

What you need to do is:
1) Apply microsoft patch and reboot
2) Set your local source port to 127.0.0.2:3390
3) Set your destination port to (in keeping with the above example) 192.168.0.1:3389
4) Start up your Putty session to the remote host and log in to the remote host
5) Start your RDP session to "127.0.0.2:3390"

The problem seems to be that RDP 'grabs' port 3389 on your localhost and because the port is in use then your SSH port forwarding fails to set up. If you look in the Putty logs for the session you can see this is what happens. So if you use an unused local port insted (3390) then your port forwarding can work, and as long as you specify the new port when you launch RDP then it all works :D :D
The administrator has disabled public write access.

Re: port forwading terminal services (RDP) with putty - ssh 11 years 8 months ago #7576

  • LostBoy
  • LostBoy's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
I've got to say thank you very much. I've followed your advice and it's worked. Many thanks again.
The administrator has disabled public write access.

SSH 11 years 8 months ago #7577

  • TheBishop
  • TheBishop's Avatar
  • Offline
  • Moderator
  • Posts: 1719
  • Thank you received: 8
  • Karma: 5
No problem
The administrator has disabled public write access.
Time to create page: 0.080 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup