Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Redhat 7 and NIC not available

Redhat 7 and NIC not available 13 years 3 months ago #463

  • tfs
  • tfs's Avatar
  • Offline
  • Expert Member
  • Posts: 521
  • Karma: 0
I am starting to play with my Redhat 7 Linux program (had the box version for a couple of years and never used it).

I tried to install it and it went fine, except that where it is supposed to see my NIC and come up with the network setup screen, it doesn't. The documentation says if it doesn't see a NIC, it will skip this screen I have an Intel 10/100 NIC that works fine when I have my 95 HD in the system. For some reason, it Redhat doesn't see it.

Anyone know why and how I can get around this?

Thanks,

Tom.
Thanks,

Tom
The administrator has disabled public write access.

Redhat 7 and NIC not available 13 years 3 months ago #464

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
tfs,

If the system didnt detect the network card, try typing the following command as root:

insmod eepro100

If you don't get any errors, the module has been loaded and your nic should be working.

Now type ifconfig -a and see if its listed . If this is your first network card, it should be listed as 'eth0'.

Let us know how it went.

Cheers,
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.

Redhat 7 and NIC not available 13 years 3 months ago #465

  • tfs
  • tfs's Avatar
  • Offline
  • Expert Member
  • Posts: 521
  • Karma: 0
I tried ipconfig and insmod eepro100 and always get the message:

bash: ipconfig: command not found
or
bash: insmod: command not found

The prompt is:
[tfs@localhost tfs]$

if I "cd .." a couple of times I get to:
[tfs@localhost /]$

and get the same error.

Do I have to be logged on as the root user? If this is the case, how do I get to it? When I installed it, all it asked for was a root password, not a user login. However, I just tried using:

localhost login: root
along with the root password and I got the prompt:

[root@localhost /root]#

I assume that the "$" means a normal user and # a supervisor or root user.

Also, I am curious as to why I didn't get the Gnome GUI instead of the CLI as I told it to load it and the book said it automatically go into the GUI mode.

Thanks,

Tom.
Thanks,

Tom
The administrator has disabled public write access.

Redhat 7 and NIC not available 13 years 3 months ago #466

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
tfs,

You certainly need to be logged in as root. You are correct about the hash (#), it identifies a root log on.

Once logged in as root, try the commands again and let us know the outcome.

As for the GUI interface, thats easy to fix.
It seems like its defaulting to CLI, rather than the GUI. No harm done, simply log in as root and goto the /etc directory, from there edit the file called 'inittab'.

The file contains a section where you will have "id:3:initdefault:", simply change it to reflect the following :"id:5:initdefault:". Your basically changing the 3 to a 5, and if you look at the comments right above, you will see that 5= X11 which is the X server - your GUI interface

Once the changes are made, save the file and issue a 'init 6' command to reboot the system. If you find yourself looking for a editior, try 'pico' or 'vi'.

A quick search on google will show many sites with instructions on how to use the vi tool, which is very popular!

Cheers,
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.

Redhat 7 and NIC not available 13 years 3 months ago #467

  • tfs
  • tfs's Avatar
  • Offline
  • Expert Member
  • Posts: 521
  • Karma: 0
That worked, changing the 3 to a 5. I am now in the GUI.

The ipconfig still gives me the error, though. I did a find on '*ipconfig*' and all it found was plipconfig. I assume the networking routines didn't get loaded since it didn't see my Network card.

I did get Redhat 8 (with O'reillys book) and am going to play a little more with 7 and if I still can't get it to work, I may just load 8 and work with that. Maybe 7 is having a problem with my Intel card.

Here is my inittab, btw:
********************************************
#
# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Things to run in every runlevel.
ud: nce:/sbin/update

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf: owerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345 owerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
# xdm is now a separate service
x:5:respawn:/etc/X11/prefdm -nodaemon
******************************************

Probably doesn't tell you anything.

Thanks,

Tom.
Thanks,

Tom
The administrator has disabled public write access.

Redhat 7 and NIC not available 13 years 3 months ago #468

  • tfs
  • tfs's Avatar
  • Offline
  • Expert Member
  • Posts: 521
  • Karma: 0
I looked all over the place about setting up the NIC card and can find a few places where you set up the Network card (which it will do, even if the card is not there - I guess).

I can't ping or ipconfig (as I mentioned) as the problems are not on the system - as far as I can tell.

I assume that redhat 7 didn't install them for some reason. I don't know how to force this, so I will probably try to install 8 and see if that works any differently.

Tom
Thanks,

Tom
The administrator has disabled public write access.
Time to create page: 0.084 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup