1) gtk+ is split into two different development branches, so when they mention a dependency of >=gtk+ 1.2 they may mean specifically gtk+1.x. Try installing the latest gtk+1.2.x too if it's not present, though I guess you already have it otherwise xmms wouldn't be working at all.
2) try a "locate im-cyrillic-translit.so" or "find / -name im-cyrillic-translit.so" and do a symbolic link (ln -s) for it to /opt/gnome/lib/gtk-2.0/2.4.0/immodules/
4) try ./configure --help to see if that cyrillic-related thing is something optional that can be disabled at the Makefile through the autoconf utility.
you were right, i installed gtk+ v1.2.10 and now I'm passed that error. Unfortunatly i have a new one saying i need xmms 1.2.3 or higher, but no worries I should be able to figure this one out. And if i cant ill be sure to post.
Also while I was trying to install gtk+1.2.10 it gave me this error:
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed
linux:/home/cody/zippedFiles/glib-1.2.0 # locate ltconfig
so i edited the ltconfig file and where it said
I put the name of my box...after that it installed fine. Do you know if that was the right thing to do? Thanks agian!