Hot Downloads

×

Notice

The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: install problems

install problems 12 years 10 months ago #10894

I'm trying to install an avi-xmms but when i do it tells me i need to install gtk+ 1.2 or higher. So I downloaded gtk+ and when i try to install it i go

./configure - everything seems to go fine
make - everything seems to go fine
make install - and then i get the following message:

Cannot load module /opt/gnome/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: /opt/gnome/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot open shared object file: No such file or directory
/opt/gnome/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so does not export GTK+ IM module API: /opt/gnome/lib/gtk-2.0/2.4.0/immodules/im-cyrillic-translit.so: cannot open shared object file: No such file or directory
make[4]: *** [install-data-hook] Error 1
make[4]: Leaving directory `/home/cody/zippedFiles/gtk+-2.8.0/modules/input'
make[3]: *** [install-data-am] Error 2
make[3]: Leaving directory `/home/cody/zippedFiles/gtk+-2.8.0/modules/input'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/home/cody/zippedFiles/gtk+-2.8.0/modules/input'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/cody/zippedFiles/gtk+-2.8.0/modules'
make: *** [install-recursive] Error 1
linux:/home/cody/zippedFiles/gtk+-2.8.0 #


I'm really not sure whats going on here (which why I've come to you guys). I wish suse had apt-get install...heh

Anywho, your help is always appreciated.
Cody

Re: install problems 12 years 10 months ago #10897

  • nske
  • nske's Avatar
  • Offline
  • Expert Member
  • Expert Member
  • Posts: 613
  • Thank you received: 0
Things to try:

1) gtk+ is split into two different development branches, so when they mention a dependency of >=gtk+ 1.2 they may mean specifically gtk+1.x. Try installing the latest gtk+1.2.x too if it's not present, though I guess you already have it otherwise xmms wouldn't be working at all.

2) try a "locate im-cyrillic-translit.so" or "find / -name im-cyrillic-translit.so" and do a symbolic link (ln -s) for it to /opt/gnome/lib/gtk-2.0/2.4.0/immodules/

4) try ./configure --help to see if that cyrillic-related thing is something optional that can be disabled at the Makefile through the autoconf utility.

Re: install problems 12 years 10 months ago #11006

sorry its taken me so long to reply.

you were right, i installed gtk+ v1.2.10 and now I'm passed that error. Unfortunatly i have a new one saying i need xmms 1.2.3 or higher, but no worries I should be able to figure this one out. And if i cant ill be sure to post.

Also while I was trying to install gtk+1.2.10 it gave me this error:
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed
linux:/home/cody/zippedFiles/glib-1.2.0 # locate ltconfig
/home/cody/zippedFiles/gtk+-1.2.10/ltconfig

so i edited the ltconfig file and where it said
host=
I put the name of my box...after that it installed fine. Do you know if that was the right thing to do? Thanks agian!

Cody

Re: install problems 12 years 10 months ago #11007

So im having a problem with xmms...
I dont know how familiar you are with Suse's software management program but It says that I have xmms 1.2.10 installed, but when i ./configure it tells me:

configure: error: *** XMMS >= 1.2.3 not installed - please install first ***

so I tried downloading the source and this is the error that I get when i try to "make"

gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../xmms -I/usr/local/include/gtk-1.2 -I/opt/gnome/include/glib-1.2 -I/opt/gnome/lib64/glib/include -D_REENTRANT -I/usr/X11R6/include -I../../intl -I../.. -g -O2 -Wall -Wpointer-arith -finline-functions -ffast-math -funroll-all-loops -MT ir.lo -MD -MP -MF .deps/ir.Tpo -c ir.c -fPIC -DPIC -o ir.lo
ir.c:19: error: static declaration of 'keepGoing' follows non-static declaration
ir.h:53: error: previous declaration of 'keepGoing' was here
ir.c:22: error: static declaration of 'irapp_thread' follows non-static declaration
ir.h:52: error: previous declaration of 'irapp_thread' was here
make[3]: *** [ir.lo] Error 1
make[3]: Leaving directory `/home/cody/zippedFiles/xmms-1.2.10/General/ir'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/cody/zippedFiles/xmms-1.2.10/General'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/cody/zippedFiles/xmms-1.2.10'
make: *** [all] Error 2


Does you know why its telling me that xmms is not installed when yast is telling me that it is installed. Or why im getting this error when I try install the source.

Re: install problems 12 years 10 months ago #11159

Try removing xmms from Yast and then reinstalling it.

Either that or install your original package through Yast directly if it's available.

I'm lost without apt-get ;)
Sahir Hidayatullah.
Firewall.cx Staff - Associate Editor & Security Advisor
tftfotw.blogspot.com

Re: install problems 12 years 10 months ago #11199

yeah, apt-get rocks. I actually installed Ubuntu on my spare machine and liked it so much its now replacing suse on my main machine (dual booting with Windows). So I'm back with apt-get thankfully.

Also I did try uninstalling it and reinstalling it but I got the same problem...but ill put the problem off until i run into it again, heh.

Thanks for the help,
Cody
  • Page:
  • 1
Time to create page: 0.151 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup