Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: NATing two Interfaces on a Cisco Router

NATing two Interfaces on a Cisco Router 13 years 1 month ago #1349

  • slattont
  • slattont's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
I am configuring a Cisco Router (with 12.2 firmware) for an unusual application. The router has four interfaces. Two interfaces will be connected to an "outside" network. The other two interfaces will be "inside" and need to be NATed. I am unsure how to configure the NATing for the four ports?

[code:1]
! Outside interface for 172.16.0.0/23
interface FastEthernet0/0
ip address 172.16.0.254 255.255.254.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
! Outside interface for xxx.xxx.224.0/24
interface FastEthernet0/1
ip address xxx.xxx.224.254 255.255.255.0
ip nat outside
ip access-group deny-outside_192 in
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
! Inside interface for 192.168.172.0/23
interface FastEthernet1/0
ip address 192.168.172.10 255.255.254.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
! Inside interface for 192.168.224.128/24
interface FastEthernet1/1
ip address 192.168.224.10 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
!
ip nat inside source static 192.168.224.222 xxx.xxx.224.222
ip classless
ip route 192.168.224.0 255.255.255.0 FastEthernet1/1
[/code:1]

Tim S
The administrator has disabled public write access.

Re: NATing two Interfaces on a Cisco Router 13 years 1 month ago #1357

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
slattont,

No problem, we will be more than happy to assit.

To help us though understand the problem and what you need to do, please provide us a with an simple ascii diagram, ip addresses (you can use fake ones for the public interfaces is they are static) and explain what you need to do.

Cheers,
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.

Re: NATing two Interfaces on a Cisco Router 13 years 1 month ago #1464

  • slattont
  • slattont's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Here is a simple diagram:
[code:1]

172.16.0.0/23 xxx.xxx.224.0/24

Outside | | Outside
0/0 | | 0/1
| |
| |
| |
| |
|
|
|
|
|Cisco Router |
|
|
|
|
| |
| |
| |
Inside | | Inside
1/0 | | 1/1
192.168.172.0/23 | | 192.168.224.0/24
| |

[/code:1]
I am trying to Nat to the two inside ports. But when I attempt to create two different NAT pools, the router appears to merge the two.

Tim
The administrator has disabled public write access.
Time to create page: 0.083 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup