Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: So basic, it hurts to ask......

So basic, it hurts to ask...... 11 years 3 months ago #8861

So today I got my extra computer for free to learn Linux and setup a Firewall. It's been a long day and I'm no where close to done.

First off, my firewall computer has 2 nic cards and I'm running Smoothwall for the firewall. What my problem is, is that I cannot get logged onto the computer to set the parameters more. I should be able to type 192.168.1.1:81 and it will bring up a menu; however, it is not.

I have the one nic card's IP set up to be 192.168.1.1. I first tried connecting my rounter up to it, but was unsure how I should. Should I use a crossover cable or straight cable? Do I connect through the WAN or the Uplink? (I'm using a linksys 4 port router with uplink and I have a cable modem). This didn't work so I took a crossover cable and hooked it up to the nic card, still no luck. I even tried the other card just for fun to make sure I wasn't wrong.

So any ideas as to why this isn't working. This is frustrating me because I've read all the articles that are not in the forum on this page and understand networking very well, but when I put it into practice, it doesn't seem to work.

Also, what I'm shooting for is a system that is identical to the one in the networking section. Cable modem---->Firewall---->Router then it splits into two networks with one for webserver and the other private.

Laslty, I'm about 100% certain I have the Smoothwall setup correctly. I might have issues with connecting to the internet, but I'll save that for later. I want to get this fixed first.
The administrator has disabled public write access.

Re: So basic, it hurts to ask...... 11 years 3 months ago #8862

I was reading some other stuff trying to solve and remembered that I setup Smoothwall with automatic DHCP with the computers. I also tried assigning my own IP's and that didn't work either. It seems to me that I have exhausted all my options so I guest that is why I'm asking here.
The administrator has disabled public write access.

Cabling 11 years 3 months ago #8863

  • TheBishop
  • TheBishop's Avatar
  • Offline
  • Moderator
  • Posts: 1719
  • Thank you received: 8
  • Karma: 5
You need to connect the Uplink port of your router to whichever card on your machine you've designated the 'public' side of your firewall. A nornal (non-crossover) cable should work
The administrator has disabled public write access.

Re: So basic, it hurts to ask...... 11 years 3 months ago #8871

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
Just to add to what TheBishop said.

Make sure that your PC is connected to the card set to 192.168.1.1 using a normal cable. The router connection is not relevant at this stage as you can't even communicate with the Firewall on the internal interface (192.168.1.1).

Also since we're not sure if the DHCP service is running, you may try assigning your PC a static address in the same range. Also just to check, Smoothwall's default GREEN interface IP is 192.168.0.1. Are you sure you changed it to 192.168.1.1 during setup?

After checking all the above, boot your PC and try to ping the Firewall on 192.168.1.1 or whatever you set it to to establish connectivity.

Let us know how you get on. I personally use the IPCOP firewall distribution which originated from Smoothwall so I can help with any config problems.
The administrator has disabled public write access.

Re: So basic, it hurts to ask...... 11 years 3 months ago #8882

I did change my green side IP address to 192.168.1.1 and I did this so that my router would be my DHCP for the time of testing. I have since gotten tired of unhooking cables so I changed the green side IP to 192.168.1.1 and I'm still subnetting at 255.255.255.0, so there should be no problems. I did this to prevent conflict with anything else on the network.

Now once I did that I just took a regular cable and connected the green side card to a regular port on the router and I get nothing. I cannot ping it nor connect to it. I'm very certain I am doing things right, but something is not working. Does it sound like a hardware issue?
The administrator has disabled public write access.

Re: So basic, it hurts to ask...... 11 years 3 months ago #8886

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
Sorry, I made a mistake in my last post. You can't connect your client PC directly to the IPCOP with a normal cable. You connect a hub/switch to the GREEN side and then plug your client PC into the the hub/switch. Or you can use a crossover cable if you want to avoid using a hub/switch.

As for the router, you should definitely be connecting this to the RED side of your firewall.
The administrator has disabled public write access.
Time to create page: 0.081 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup