Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: CISCO ROUTER Problem! help!!!

CISCO ROUTER Problem! help!!! 11 years 9 months ago #7359

  • eli2983
  • eli2983's Avatar
  • Offline
  • New Member
  • Posts: 15
  • Karma: 0


Hi, I have a small LAN at my home! and also a cisco router (soho 91). i have a nat and a dhcp running on the router! but when i connect the router directly to my modem - all the pc's cant reach the internet! when i connect only 1 pc to the modem it reaches the internet. this is my main configuration:

interface Ethernet0
ip address 10.10.10.254 255.255.255.0
ip nat inside
load-interval 30
no cdp enable
hold-queue 100 in
hold-queue 100 out
!
interface Ethernet1
description ***link to cables via CM***
ip dhcp client class-id eth1
ip address dhcp
ip nat outside
duplex auto
no cdp enable

ip dhcp pool CLIENT
import all
network 10.10.10.0 255.255.255.0
dns-server 212.117.129.3 212.117.128.6
default-router 10.10.10.254
lease 0 2

ip route 0.0.0.0 0.0.0.0 ethernet 1

i have not configured dialer here,beacause it is automatic! when i connect 1 pc to the modem i have internet (without create dialer).

i will be very glad if someone can help me by solving this problem! if someone can redirect me to a web site which explains it i will be also glad thanks!!!
The administrator has disabled public write access.

Re: CISCO ROUTER Problem! help!!! 11 years 9 months ago #7402

  • tiamat
  • tiamat's Avatar
  • Offline
  • Distinguished Member
  • Posts: 102
  • Karma: 0
it doesn't appear that your natting is fully configured. you'll need to create an ACL for the hosts that you want to nat (your 10.10.10.0/24 network) and add the nat overload statement to the config.

something like this:

access-list 10 permit 10.10.10.0 0.0.0.255
ip nat inside source list 10 interface Ethernet1 overload

EDIT: Also, you'll want to eventually modify your DHCP scope to exclude the address that you've used for the router's own interface E0, otherwise you'll get a conflict (if you end up with more than 253 hosts on your network, which probably won't happen, but still). It's always a good idea to exclude something like the beginning and ending 10 addresses or so for static purposes like routers, printers, servers, etc.

EDIT (again): here is a link to the basic router config for a soho 91 on cisco's site:
www.cisco.com/en/US/products/hw/routers/...18d1a.html#wp1016195
The administrator has disabled public write access.

Re: CISCO ROUTER Problem! help!!! 11 years 9 months ago #7441

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
tiamat's post is correct - your NAT is not fully configured. Follow the guidelines given on the above post and let us know what the results were.

Cheers,
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.
Time to create page: 0.080 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup