Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: 3550 questions

3550 questions 6 years 8 months ago #33238

Hi,
I've come upon a problem that needs more smarts that I posses.

I'm the ET (Electronic Tech) here on an oil rig off the coast of Africa.
I've got a pretty good understanding of networks and computers (MCSE) but am very weak on Cisco and complex routing.

My situation is that we've just left the shipyard and all our equipment has been upgraded. I've laid in some fiber to various places and have a 4 vlans setup and all feeding into our satellite modem.

What I want to do is use an old 3550 to setup a network for some IPX applications we have. Yes IPX!! These are dos based applications even! Anyway.. I want to set the 3550 up as an IPX switch basically.
Overkill I know but when your orders take 6 months to a year to be delivered you have to improvise. The 3550 is the only thing I've got left with multiple ports in it.
I've gone in and cleared the config.text and have the router set to factory defaults.
Is there a way to turn the 3550 into a switch capable of passing IPX?

This will be temporary until I can get home and pick up a $30 switch to bring back.

Thanks for any and all help

James
The administrator has disabled public write access.

Re: 3550 questions 6 years 8 months ago #33241

IPX is a routed protocol, so the switch will ignore it at Layer 2. If you want to route at Layer 3 using the switch, then you need to use a routing protocol that supports IPX. If you have all Cisco kit, then EIGRP has to be the way to go.
To turn a 3550 interface from a switch interface to a routing interface, go to the interface command and simply type no switchport. This turns the interface in to a router interface.
Below is the show run output from a 3560 which has had no switchport configured on int fa 0/1...
Cisco_3560#sho run
Building configuration...

Current configuration : 1102 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Cisco_3560

!
interface FastEthernet0/1
no switchport

no ip address
duplex auto
speed auto
!


Now you can add an IP address to the interface, switch on IP routing (at global config) and configure EIGRP.
The administrator has disabled public write access.

Re: 3550 questions 6 years 8 months ago #33242

And the same switch with IP routing switched on;
Cisco_3560#sho run
Building configuration...

Current configuration : 1115 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Cisco_3560
!
!
ip routing
!
!
interface FastEthernet0/1
no switchport
no ip address
duplex auto
speed auto
!

Don't forget to do that IF you want to use the switch as a router as well as a switch :wink:
The administrator has disabled public write access.

Re: 3550 questions 6 years 8 months ago #33243

And finally, the same switch with an IP address configured on int fa 0/1 and EIGRP up and running;
Cisco_3560#sho run
Building configuration...

Current configuration : 1197 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Cisco_3560
!
ip routing
!
!
interface FastEthernet0/1
no switchport
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
<output truncated>
!
router eigrp 100
network 192.168.10.0
no auto-summary

!
ip classless

!
line con 0
line vty 0 4
login
!
end
The administrator has disabled public write access.
Time to create page: 0.083 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup