Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Port Security on Switch - Sticky MAC-Address Problem

Port Security on Switch - Sticky MAC-Address Problem 7 years 2 months ago #31106

  • gvkalra
  • gvkalra's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
Hey All, Hi
Before writing my question, here's the output from the Switch:


Switch#show running-config
(Showing only relevant Port)
[code:1]
Building configuration...

Current configuration : 1306 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/21
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky 001f.d0e7.9d31
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
ip http server
!
line con 0
logging synchronous
line vty 0 4
login
line vty 5 15
login
!
mac-address-table aging-time 10
!
end
[/code:1]
_________________________________
Switch#show port-security interface fastEthernet 0/21
[code:1]
Port Security : Enabled
Port Status : Secure-up
Violation Mode : Shutdown
Aging Time : 0 mins
Aging Type : Absolute
SecureStatic Address Aging : Disabled
Maximum MAC Addresses : 1
Total MAC Addresses : 1
Configured MAC Addresses : 0
Sticky MAC Addresses : 1
Last Source Address : 0000.0000.0000
Security Violation Count : 0
[/code:1]
_________________________________
Switch#show mac-address-table dynamic
[code:1]
Mac Address Table

Vlan Mac Address Type Ports
----


All 000b.5fae.71c0 STATIC CPU
All 0100.0ccc.cccc STATIC CPU
All 0100.0ccc.cccd STATIC CPU
All 0100.0cdd.dddd STATIC CPU
1 0000.0c92.54cf DYNAMIC Fa0/9
1 0010.7b3a.95f8 DYNAMIC Fa0/12
1 001f.d0e7.9d31 STATIC Fa0/21
Total Mac Addresses for this criterion: 7
[/code:1]

My Question is this:
Check these out again
[code:1]
(Quote1)switchport port-security mac-address sticky 001f.d0e7.9d31
(Quote2)Last Source Address : 0000.0000.0000
(Quote3)1 001f.d0e7.9d31 STATIC Fa0/21
[/code:1]

Why is (Quote2) showing Last Source Address as 0000.0000.0000? I did the same thing on Packet Tracer 5.1 and it is showing the sticky MAC-ADDRESS 001f.d0e7.9d31 in place of 0000.0000.0000 (which it should).

Any problem with the Switch?
The administrator has disabled public write access.

Re: Port Security on Switch - Sticky MAC-Address Problem 7 years 2 months ago #31110

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
hmmm, I tried it and it works with me on both packet tracer and my 2950 switch. You are right it should be working!!, got no idea why it doesn't :?

Did you by any chance reload the switch before issuing show port-security interface fastEthernet 0/21. The "Last Source Address" would not survive a restart/reload.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: Port Security on Switch - Sticky MAC-Address Problem 7 years 2 months ago #31120

  • gvkalra
  • gvkalra's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
No I didn't reloaded the Switch .... Looks like there gotta be some problem with the Switch IOS....
The administrator has disabled public write access.

Re: Port Security on Switch - Sticky MAC-Address Problem 7 years 2 months ago #31122

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Looks like there gotta be some problem with the Switch IOS....

Very possible, getting the latest IOS (if it's not already there) might help.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
Time to create page: 0.084 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup