Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Problem with NAT

Problem with NAT 7 years 9 months ago #28429

  • ghostphace
  • ghostphace's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
I have a 2600 router and i want to achive a goal of mapping a public ip to a private ip in the LAN so telnet & ssh can be accessible from outside the domain.

config:
ip nat inside source static tcp 10.0.0.1 23 1.0.0.1 23

i can ping the public ip and get a reply

SL-R2651#sh ip nat translations
Pro Inside global Inside local Outside local Outside global

tcp 1.0.0.1:23 10.0.0.1:23 --- ---


But the problem is i cant get telnet nor ssh to connect from outside the domain.

Regards
The administrator has disabled public write access.

Re: Problem with NAT 7 years 9 months ago #28431

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Your ip nat statement seems OK (for telnet). You will need to also add one for SSH (port 22).

[code:1]ip nat inside source static tcp 10.0.0.1 22 1.0.0.1 22[/code:1]

You need to also specify which interfaces on your 2600 are inside or outside, for example:

[code:1]interface FastEthernet0/0
ip address 192.168.1.97 255.255.255.0
ip nat inside
!
interface FastEthernet0/1
ip address 192.168.2.33 255.255.255.0
ip nat inside
!
interface Serial0/0
ip address 1.0.0.1 255.255.255.252
ip nat outside[/code:1]

If it still doesn't work after checking the above, then could you post a debug ip nat output for us ?
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
Time to create page: 0.074 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup