Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: VLSM (Variable Length Subnet Masks)

VLSM (Variable Length Subnet Masks) 8 years 2 months ago #27455

  • NeoTech
  • NeoTech's Avatar
  • Offline
  • Distinguished Member
  • Posts: 101
  • Karma: 0
Hey all firewall members and sneaky guests! :shock:

We have just started on CCNA 3 and i was wondering if there are any resources on variable length subnet masks in the alternate menu pages. Ive been through them briefly and can't find much.

As to my currently (very) limited understanding it seems like they're trying to say that you can use VLSM to subnet a subnet?! ??
The concept of this is a little confusing and i could do with an explaination that is a little better than we get from ciscos own study material. It would be great to hear it from somebody that has been in networking for a few years and can do this stuff standing on their head. To begin with i thought VLSM and 'subnetting' were one and the same, but apparently not.

All explaination attempts appreciated!

Cheers! :D

Neo
Tech
The administrator has disabled public write access.

Re: VLSM (Variable Length Subnet Masks) 8 years 2 months ago #27457

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Briefly said, VLSM as the name suggests allows you to use multiple (variable) subnet masks in different parts of your network. Suppose you have 3 networks one with 100 hosts, the second with 10 host and the 3rd is with only 5. The 100 hosts network will need at a least 7 bits in the hosts bits, Thats a subnet mask of /25 (or less: /24, /23, /22,,,,,) to accommodate for all hosts. However, The 10 hosts network will need only 4 bits (/28 ) and the 5 hosts will need 3 bits (/29).

To use a single subnet mask for all the nets, it has to be enough for the largest (100 host). So /25 will have to be used for all. BUT thats a big waste in the address space, isn't it?

VLSM allows you to use /25 for the 100 hosts. /28 for the 10 hosts. and /29 for the 5.

However, Not all routing protocols support VLSM. RIP and IGRP don't, RIPv2, EIGRP and OSPF do support VLSM. The reason why RIP and IGRP don't is because they DO NOT send the subnet mask with the routing updates, they just assume it's class-full (/8, /16 or /24).

This is very brief. I hope I did not confuse you. Check here for further explanation, there is a VLSM example:

www.cisco.com/en/US/tech/tk365/technolog...f5.shtml#vlsmexample
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: VLSM (Variable Length Subnet Masks) 8 years 2 months ago #27505

  • NeoTech
  • NeoTech's Avatar
  • Offline
  • Distinguished Member
  • Posts: 101
  • Karma: 0
Ok cheers, your explaination was sufficient for me :)

I think it would go in more if i understood how you configure them in a typical Cisco IOS. Anyone care to run me through it? I have an old 1600 series i can configure with RIPv2 or OSPF and try it out.

Cheers in advance! :P

Neo
Tech
The administrator has disabled public write access.

Re: VLSM (Variable Length Subnet Masks) 8 years 2 months ago #27520

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Suppose you have the following config for two interfaces/networks:

[code:1]interface FastEthernet0/0
ip address 200.1.1.1 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.0.1 255.255.240.0
duplex auto
speed auto
![/code:1]

As you can see the interfaces use differing subnet masks. For RIPv2 you would do this:

[code:1]Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 200.1.1.0
Router(config-router)#network 10.0.0.0[/code:1]

For OSPF:

[code:1]Router(config)#router ospf 100
Router(config-router)#network 200.1.1.0 0.0.0.127 area 0
Router(config-router)#network 10.1.0.0 0.0.15.255 area 0[/code:1]

If you have any questions, you're welcome to ask.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: VLSM (Variable Length Subnet Masks) 8 years 1 month ago #27695

  • NeoTech
  • NeoTech's Avatar
  • Offline
  • Distinguished Member
  • Posts: 101
  • Karma: 0
What is confusing me is this:
If you enter a different subnet mask for another part of the network, arnt you effectively putting that part on a different subnet?

Thanks again guys, im really having trouble with this thing lol.
:? :oops:

Neo
Tech
The administrator has disabled public write access.

Re: VLSM (Variable Length Subnet Masks) 8 years 1 month ago #27696

  • NeoTech
  • NeoTech's Avatar
  • Offline
  • Distinguished Member
  • Posts: 101
  • Karma: 0
Am i right in assuming that once you have set the subnets there is a different command to further divide one of the subnets in the routing protocols that support it? That would be the most efficient way as far as i can see... :(

Neo
Tech
The administrator has disabled public write access.
Time to create page: 0.083 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup