Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Ftp server using no-ip

Ftp server using no-ip 8 years 2 months ago #27440

  • kalale
  • kalale's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hi,

I've got a dsl line and im using a Zyxel IAD P2606 router, i setup a static ip on the pc, instaaled filezilla server and forwarded port 21 on the router, installed noip updater

when i enter ftp://mynoipaddress i get the page can not be displayed
when i enter http://mynoipaddress it opens my router configuration page.
what have am i doing wrong

thans in advance
The administrator has disabled public write access.

Re: Ftp server using no-ip 8 years 2 months ago #27443

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
I assume here that your behind NAT. If you can see your router config page by typing http://mynoipaddress from OUTSIDE your network this verifies that DNS/noip resolution is proceeding OK.

For FTP to work, I believe you need more than just forwarding port 21. There are two ways to do it, either "passive mode" or "active mode". I'll describe "passive mode" because I think it's easier.

In passive mode, you need to forward a range of ports (that are used by Filezilla server) in your router. Go to your FileZilla [Server Options] -> [Passive Mode Settings]. Check the [Use custom port range] then type a port range, say: 50000 - 50050. Now, choose the [Retrieve External IP Address from], this will ensure that your external IP is sent to the ftp client. Click [OK]

Go to your router, setup ports 50000 - 50050 to be forwarded to your FileZilla server (Just like you did for port 21). This should be enough to do it.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: Ftp server using no-ip 8 years 2 months ago #27450

  • kalale
  • kalale's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hi,

thx for the help, im now getting to the ftp page and when i click on "Up to higher level directory" it does this

Index of ftp://???.myftp.org/../../../../../../../../

Up to higher level directory
Name Size Last Modified
The administrator has disabled public write access.

Re: Ftp server using no-ip 8 years 2 months ago #27451

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Not sure what is it!. But have you setup a shared/root folder for your FTP user in the FileZilla server. Remember, that this folder will be the root you see in the FTP client. You can't see the parent (higher level directory) of the root. So if you want to see the parent, set it as your shared folder in the FileZilla server.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: Ftp server using no-ip 8 years 2 months ago #27461

  • KiLLaBeE
  • KiLLaBeE's Avatar
  • Offline
  • Expert Member
  • Posts: 466
  • Karma: 0
I'm guessing this "no-ip" application is some kind of dynamic DNS program that updates your DNS name on root servers with your dynamic IP address from your ISP...am I right?

My suggestion is that before you try to access your FTP from the outside, try to access it from within your network (this will confirm the functionality and most of the configuration of FileZilla and the FTP client that you'll be using). After this passes, try to access your FTP from the outside using your external IP address, which I'll assume is dynamically assigned by your ISP (this will allow you to confirm the functionality of your firewall/router's port forwarding along with some of FileZilla's configurations). After that passes, you can then try to access your FTP by DNS name (which will resolve to your IP address...granted enough time has passed for the DNS information to replicate to all root DNS servers).

As S0lo suggested, you'll have to define the shared folder for root FTP access (this will be the folder that users will see after they connect to the FTP), and grant the users appropriate rights to see the contents.
The administrator has disabled public write access.

Re: Ftp server using no-ip 8 years 2 months ago #27464

  • kalale
  • kalale's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Someone said the problem could be with the router, but before a start blaming the router, i'll take KiLLaBeE advice and try access it on the lan, some litthe things that we forget that might be very helpfull. wiil let you know once i try that
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.084 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup