Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Cannot open ports...

Cannot open ports... 12 years 2 months ago #5107

  • Mike2
  • Mike2's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Hello.

I'm making a program which requires to open ports and user connect to them.
Well I'm having a problem when opening ports.
I tried connecting to 127.0.0.1 and 192.168.1.3 (local ips) and it worked.
When I try to connect to my internet IP address it just won't connect... :roll:
What should I do?

Thanks! :)

Note: I'm using a Jetspeed 500i router and my connection type is ADSL
The administrator has disabled public write access.

Re: Cannot open ports... 12 years 2 months ago #5113

  • nske
  • nske's Avatar
  • Offline
  • Expert Member
  • Posts: 613
  • Karma: 0
welcome mike, I believe that makes us now 3 users from Greece participating at the forum.. excluding of course Chris. Not bad :D

btw I have the same router friend and it's a disaster :cry: :P

Regarding your question, did you set up port forwarding at your dsl router, forwarding requests at the specific port to the computer inside?
The administrator has disabled public write access.

Re: Cannot open ports... 12 years 2 months ago #5117

  • Mike2
  • Mike2's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Regarding your question, did you set up port forwarding at your dsl router, forwarding requests at the specific port to the computer inside?
Uhhh this is what I did:
1) Goto http://192.168.1.1
2) Click Security
3) Type passwords
4) Click "Advanced NAT Configuration..."
5) Click "Add Reserved Mapping..."
6) In the global IP textbox I entered my internet IP (0.0.0.0 would not work :roll: ), in the internal address textbox I entered 192.168.1.3 , in the "Transpot Type" combobox I selected "TCP" (that's what my program uses) and in the port number the port my program uses.
7) Click "Add Reserved Mapping"

After doing these steps nothing happened...
I still couldnt open ports... :(
The administrator has disabled public write access.

Re: Cannot open ports... 12 years 2 months ago #5122

  • nske
  • nske's Avatar
  • Offline
  • Expert Member
  • Posts: 613
  • Karma: 0
yep you did the right thing, and it will be working fromt he outside :)


Thing is that you are trying to access it from the inside, that's why ;)
The administrator has disabled public write access.

Re: Cannot open ports... 12 years 2 months ago #5123

  • Mike2
  • Mike2's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
Ah thank you :)
You were right:
I tried with an MSN friend and it worked!

Just a question: I dont have a static IP. will I have to change the global IP address?
The administrator has disabled public write access.

Re: Cannot open ports... 12 years 2 months ago #5125

  • nske
  • nske's Avatar
  • Offline
  • Expert Member
  • Posts: 613
  • Karma: 0
If you are referring to the NAT port forwarding table, well, supposingly, you can put "0.0.0.0" instead of the specific public IP address and it will always refer to the wan interface, regardless the IP. But this is intracom's jetspeed we are talking and it does whatever it wants whenever it feels like! :P

If you are referring to the default route of the router, necessary to have internet through NAT, then you can also put the wan interface's name as the gateway (instead of your current public IP address) so that you will not have to reconstruct the route each time IP address changes. I.E. "quick_wan" for the wan interface created by the webadmin's wizard (recommended). That, at least, appears to work ;)
The administrator has disabled public write access.
Time to create page: 0.079 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup