Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: access from outside interface, port range, ASA 5505

access from outside interface, port range, ASA 5505 6 years 5 months ago #34807

  • rrlangly
  • rrlangly's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
I have an ASA 5505 and I need to open up a range of ports from 28300 - 28400, 28600 - 28700, and SSH on port 22, all for access from the outside interface to any machine on the inside interface. Can anyone help out with the commands to do this? Here's my running-config.

[code:1]
# sh running-config
: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
enable password 8HgaP2T2asdbjsx1GBdq encrypted
passwd Ku287h/3Z9f25tj6 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh scopy enable
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.254 inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9977cf711682d26e5ca49800ac4e94c0
: end
[/code:1]
The administrator has disabled public write access.

Re: access from outside interface, port range, ASA 5505 6 years 5 months ago #34851

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Hmm, the SSH port is easy, like this:

[code:1]static (inside,outside) tcp interface ssh 192.168.1.20 ssh netmask 255.255.255.255[/code:1]

Replace 192.168.1.20 with the internal server.

But for large port ranges you need to create an object-group and an ACL and link it to the static NAT. Unfortunately, it didn't work when I tried it on my ASA, giving the error that says:

ERROR: access-list port specifies a range

If you want the code I can post it, but it's not working :roll:. Hope that some one else has better ideas.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
Time to create page: 0.080 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup