Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: 5505 ftp works one way not the other

5505 ftp works one way not the other 7 years 3 months ago #31371

PROBLEM HAS BEEN RESOLVED. THANKS FOR CHECKING THOUGH.

p.s. These are working configs so feel free to use them as a reference. The ips are in the process of changing. Please note that this is for a closed LAN in a lab environment and wont work on the internet.


So we had a consultant come in and set up two ASA 5505's with a site to site vpn configuration. When we left last night we could establish an ftp connection from home to site1 and the other way around. Now this morning I am able to ftp from home to site1 however not from site1 to home. All I had done was to change the password on site1. I can ping all over the place so connectivity is definately there. The configs are posted below with their respective 'show crypto isakmp sa' outputs. I am 100% that the ip addresses are correct.

The only difference between the configs, aside from the ip addresses, is the access-group lines located about 1/4 down the config. I have also noticed that when I show the crypto iskamp sa the home site is always the initiator and site1 is always the responder. It never changes. Idk if this is normal though.

I'm somewhere between a novice and a noob at this so any help is much appreciated.

SITE 1 CONFIG:
[code:1]ASA Version 8.0(4)
!
hostname AsaSite1
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.50.6 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list 10 extended permit ip any any
access-list 10 extended permit icmp any any
access-list inside_outbound extended permit ip any any
access-list 20 extended permit ip any any
access-list 20 extended permit icmp any any
access-list 30 extended permit ip any any
access-list 30 extended permit icmp any any
access-list 134 extended permit ip any any
access-list 40 extended permit ip any any
access-list 40 extended permit icmp any any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-613.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound
nat (inside) 1 0.0.0.0 0.0.0.0 outside
access-group 10 in interface inside
access-group 20 out interface inside
access-group 20 in interface outside
access-group 30 out interface outside
!
router eigrp 100
network 134.133.56.0 255.255.255.0
network 192.168.50.4 255.255.255.252
!
route outside 0.0.0.0 0.0.0.0 192.168.50.6 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 134.133.56.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANSFORM1 esp-aes-256 esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map VPN1 20 set pfs
crypto dynamic-map VPN1 20 set transform-set TRANSFORM1
crypto dynamic-map VPN1 20 set security-association lifetime seconds 28800
crypto dynamic-map VPN1 20 set security-association lifetime kilobytes 4608000
crypto map TO_HOME 56 match address 134
crypto map TO_HOME 56 set pfs
crypto map TO_HOME 56 set peer 192.168.50.5
crypto map TO_HOME 56 set transform-set TRANSFORM1
crypto map TO_HOME 56 set security-association lifetime seconds 28800
crypto map TO_HOME 56 set security-association lifetime kilobytes 4608000
crypto map TO_HOME 65535 ipsec-isakmp dynamic VPN1
crypto map TO_HOME interface outside
crypto map TO_HOME1 56 set security-association lifetime seconds 28800
crypto map TO_HOME1 56 set security-association lifetime kilobytes 4608000
crypto isakmp enable outside
crypto isakmp policy 1
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tunnel-group 192.168.50.5 type ipsec-l2l
tunnel-group 192.168.50.5 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:6f919e5d002b005a680f62c45965a9bc
: end



AsaSite1# show crypto isakmp sa

Active SA: 1
Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1 IKE Peer: 192.168.50.5
Type : L2L Role : responder
Rekey : no State : MM_ACTIVE
[/code:1]

HOME SITE CONFIG:
[code:1]ASA Version 8.0(4)
!
hostname AsaHome
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 172.30.1.5 255.255.255.252
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.50.5 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list 10 extended permit ip any any
access-list 10 extended permit icmp any any
access-list inside_outbound extended permit ip any any
access-list 20 extended permit ip any any
access-list 20 extended permit icmp any any
access-list 30 extended permit ip any any
access-list 30 extended permit icmp any any
access-list 40 extended permit ip any any
access-list 40 extended permit icmp any any
access-list 134 extended permit ip any any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-613.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound
nat (inside) 1 0.0.0.0 0.0.0.0 outside
access-group 10 in interface inside
access-group 40 out interface inside
access-group 20 in interface outside
access-group 30 out interface outside
!
router eigrp 100
network 172.30.1.4 255.255.255.252
network 192.168.50.4 255.255.255.252
!
route outside 0.0.0.0 0.0.0.0 192.168.50.5 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 172.30.1.4 255.255.255.252 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set TRANSFORM1 esp-aes-256 esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map VPN1 20 set pfs
crypto dynamic-map VPN1 20 set transform-set TRANSFORM1
crypto dynamic-map VPN1 20 set security-association lifetime seconds 28800
crypto dynamic-map VPN1 20 set security-association lifetime kilobytes 4608000
crypto map TO_SITE1 56 match address 134
crypto map TO_SITE1 56 set pfs
crypto map TO_SITE1 56 set peer 192.168.50.6
crypto map TO_SITE1 56 set transform-set TRANSFORM1
crypto map TO_SITE1 56 set security-association lifetime seconds 28800
crypto map TO_SITE1 56 set security-association lifetime kilobytes 4608000
crypto map TO_SITE1 200 set security-association lifetime seconds 28800
crypto map TO_SITE1 200 set security-association lifetime kilobytes 4608000
crypto map TO_SITE1 65535 ipsec-isakmp dynamic VPN1
crypto map TO_SITE1 interface outside
crypto isakmp enable outside
crypto isakmp policy 1
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tunnel-group 192.168.50.6 type ipsec-l2l
tunnel-group 192.168.50.6 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:4ab803cd550d56a7d533d42f7d26ad47
: end



AsaHome(config)# show crypto isakmp sa

Active SA: 1
Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1 IKE Peer: 192.168.50.6
Type : L2L Role : initiator
Rekey : no State : MM_ACTIVE
AsaHome(config)#[/code:1]

Thanks!
The administrator has disabled public write access.
Time to create page: 0.105 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup