Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Site to Site VPN ASA 5505 not creating tunnel

Site to Site VPN ASA 5505 not creating tunnel 7 years 4 months ago #31032

Im kindof a newb at this but I've been working at it like crazy and just cant seem to get this tunnel up. I have been trying to do a site to site VPN with two Cisco ASA 5505's. I have been using the ADSM wizard to create the connection but something isn't working right. :(

The two boxes are connected through the outside port using a single standard cat5 cable and they are on the same subnet. This is going to be on a closed lan so the ip addresses I use wont matter since it wont be connected to the internet. Here is my current config I would greatly appreciate any help you could give.


: Saved
:
ASA Version 8.0(4)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 134.133.56.251 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list outside_1_cryptomap extended permit ip 134.133.56.0 255.255.255.0 134.133.57.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 134.133.56.0 255.255.255.0 134.133.57.0 255.255.255.0
access-list outside_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-613.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 134.133.56.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 209.165.200.236
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set security-association lifetime kilobytes 4608000
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp enable inside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime none
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 134.133.56.252-134.133.56.254 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
tunnel-group 209.165.200.236 type ipsec-l2l
tunnel-group 209.165.200.236 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9ff1499a921e10760413603d38e5bb95
: end
asdm image disk0:/asdm-613.bin
no asdm history enable
The administrator has disabled public write access.

Re: Site to Site VPN ASA 5505 not creating tunnel 7 years 4 months ago #31068

  • sys-halt
  • sys-halt's Avatar
  • Offline
  • Frequent Member
  • Posts: 68
  • Karma: 0
hey chunalt787, I didn't see in your post that ASA-1 can ping ASA-2, can you please confirm that for us at first.

enable ping on the outside interfaces for both ASA and ping. I read that you are connecting them both using a cat5 cable is it a straight through cable or crossover one?

start troubleshooting at the physical layer, confirm the right cable is in use then confirm basic connectivity using ping after that we will look for VPN connectivity issue

waiting your confirmation

good luck
The administrator has disabled public write access.

Re: Site to Site VPN ASA 5505 not creating tunnel 7 years 4 months ago #31074

Thanks for getting back to me. I can use the ASA Gui to ping from box to box and it is set up as such:

Comp #1 --- cat5 --- (inside)ASA #1(outside) --- cat5 --- (outside)ASA #2(inside) --- cat5 --- Comp #2

IP addresses:
Comp 1: 134.133.56.101
ASA 1 Inside: 134.131.56.251
ASA 1 Outside: 209.165.200.226
ASA 2 Outside: 209.165.200.236
ASA 2 Inside: 134.133.57.252
Comp 2: 134.133.57.102
Note: theses are static and will not be hooked up to the internet at any time. IP addresses were arbitrarily chosen.

Comp 1 can ping ASA 1
ASA 1 can ping ASA 2(inside only)
ASA 2 can ping ASA 1(inside and outside)
Comp 2 can ping ASA 2

I just tried the crossover and that didnt seem to do any thing. I have been messing with ASA 1 too much so ASA 2 actualy has the config that is closer to being right. I have posted that down below. If you have any other questions please ask thank you so much for the help.

CONFIG FOR ASA 2:

: Saved
:
ASA Version 8.0(4)
!
hostname ciscoasb
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 134.133.56.0 inside-network2
!
interface Vlan1
nameif inside
security-level 100
ip address 134.133.57.252 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 209.165.200.236 255.255.255.0
!
interface Vlan5
no forward interface Vlan1
nameif dmz
security-level 50
ip address dhcp
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
access-list outside_1_cryptomap extended permit ip 134.133.57.0 255.255.255.0 inside-network2 255.255.255.0
access-list inside_nat0_outbound extended permit ip 134.133.57.0 255.255.255.0 inside-network2 255.255.255.0
access-list outside_access_in extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-613.bin
no asdm history enable
arp timeout 14400
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 0 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 134.133.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 209.165.200.226
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 1 set security-association lifetime seconds 28800
crypto map outside_map 1 set security-association lifetime kilobytes 4608000
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp enable dmz
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics host
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
tunnel-group DefaultL2LGroup ipsec-attributes
pre-shared-key *
tunnel-group 209.165.200.226 type ipsec-l2l
tunnel-group 209.165.200.226 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:ddfe8555ed8e621f9981d66890e80365
: end
asdm image disk0:/asdm-613.bin
asdm location inside-network2 255.255.255.0 inside
no asdm history enable
The administrator has disabled public write access.

Re: Site to Site VPN ASA 5505 not creating tunnel 7 years 4 months ago #31075

  • sys-halt
  • sys-halt's Avatar
  • Offline
  • Frequent Member
  • Posts: 68
  • Karma: 0
thank you for the confirmation chunalt787, although I am too lazy in reading others code especially if it is made through the ASDM and by the way I advice you to wipe out everything and re-create everything from scratch using CLI so you can gain more knowledge and become more power user.

now I have scan through your code and have not found any static route! you know that you can not go outside your network without a route right :) !

I think this is what is missing:

[code:1]route outside 0.0.0.0 .0.0.0.0 <outside-interface-ip-address> 1[/code:1]

add this line on both of the ASA and check if it will work.

also here is a nice websites that will help you in doing a site-to-site VPN through the CLI:

www.petenetlive.com/Tech/Firewalls/Cisco/s2svpn.htm
www.ciscoblog.com/archives/2009/05/base_config_asa.html

good luck, hope this will help you out[/quote]
The administrator has disabled public write access.
Time to create page: 0.090 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup