Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Cisco ASA 5505 config help

Cisco ASA 5505 config help 7 years 6 months ago #30345

I'll start by saying I'm pretty new to Cisco configuration. I checked around on this forum and could not find an answer, so here goes...

I am setting up a new 5505 for use in my office. It's a small network with the 5505 sitting between the internal network and my ISP. I currently have a PIX506 as the firewall and it is working fine. Right now I am just trying to get the 5505 to allow traffic to pass from the internal network to the internet using NAT to translate internal IPs on the 192.168.100.0 subnet to the external static ip of the outside interface.

I can ping outside IP addresses from the ASDM on the outside interface, but not from the inside or dmz interfaces. I'm not sure where I went wrong, but any help would be appreciated. Below is my running config:

Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname host
domain-name domain.com
enable password ******** encrypted
passwd ******** encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.100.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.249 255.255.255.240
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 50
ip address 192.168.150.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
switchport access vlan 3
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
domain-name barthavisual.com
same-security-traffic permit intra-interface
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 x.x.x.241 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.100.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.100.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.100.2-192.168.100.129 inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:eb3e51a97830356e6ff9e6b4b10de7b4
: end
The administrator has disabled public write access.

Re: Cisco ASA 5505 config help 7 years 6 months ago #30401

  • Blake
  • Blake's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
You are going to need another nat statement for your dmz for starters

nat (dmz) 1 0 0

you will also want to add something like the following, do you have access lists on the ASA that you did not list?

icmp permit 192.168.1.0 255.255.255.0 echo outside
The administrator has disabled public write access.
Time to create page: 0.079 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup