Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Problem ASA5505 IPSEC VPN

Problem ASA5505 IPSEC VPN 7 years 7 months ago #30207

  • Quen
  • Quen's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Karma: 0
Hey Guys,

I'm trying to set up a VPN Site-to-Site tunnel using a cisco ASA5505 and a Linksys WRV4400N. The tunnel is UP. But it isn't working. I think this is because of our tight access list. Can u please help.


Cisco ASA5505
External IP: 195.241.X.X
Internal IP: 192.168.135.0 255.255.255.0

Linksys WRV4400N
External IP: 195.93.X.X
Internal IP: 10.10.1.0 255.255.255.0

I will post my config below. Thanx in advance!
The administrator has disabled public write access.

Re: Problem ASA5505 IPSEC VPN 7 years 7 months ago #30208

  • Quen
  • Quen's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Karma: 0
: Saved
:
ASA Version 8.0(3)
!
hostname ciscoasa
domain-name ourcompany
enable password xxxxxxxxxxxxxxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.135.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp
!
interface Vlan5
shutdown
nameif dmz
security-level 50
ip address 10.0.0.1 255.0.0.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
switchport access vlan 5
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxxxxxxxxxxx encrypted
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns server-group DefaultDNS
name-server 195.241.X.X
name-server 195.241.X.X
domain-name ourcompany
same-security-traffic permit intra-interface
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list outside_access_out extended permit tcp any any eq www
access-list outside_access_out extended permit tcp any any eq https
access-list outside_access_out extended permit object-group TCPUDP any any eq domain
access-list outside_access_out extended permit tcp any any eq 3389
access-list outside_access_out extended permit tcp any any eq smtp
access-list outside_access_out extended permit tcp any any eq 8890
access-list outside_access_out extended permit tcp any any eq ftp-data
access-list outside_access_out extended permit tcp any any eq ftp
access-list outside_access_out extended permit tcp any any eq pptp
access-list outside_access_out extended permit tcp any any eq 2901
access-list outside_access_out extended permit tcp any any eq 8443
access-list outside_access_out extended permit tcp any any eq 8080
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any any eq 8443
access-list outside_access_in extended permit tcp any any eq 8080
access-list inside_nat0_outbound extended permit ip any 192.168.135.0 255.255.255.0
access-list Local_LAN_Access standard permit 192.168.135.0 255.255.255.0
access-list http-list2 extended permit tcp any host 81.58.X.X
access-list http-list2 extended permit tcp any host 81.58.X.X
access-list http-list2 extended permit tcp any host 195.241.X.X
access-list outside_1_cryptomap extended deny ip 192.168.135.0 255.255.255.0 10.10.1.0 255.255.255.0
access-list inside_access_in extended permit ip 192.168.135.0 255.255.255.0 any
!
tcp-map mss-map
exceed-mss allow
!
pager lines 24
logging enable
logging asdm informational
logging from-address This email address is being protected from spambots. You need JavaScript enabled to view it.
logging recipient-address This email address is being protected from spambots. You need JavaScript enabled to view it. level errors
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool WBadressen 192.168.135.100-192.168.135.105 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 8443 192.168.135.17 8443 netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.135.13 https netmask 255.255.255.255
static (inside,outside) tcp interface smtp 192.168.135.13 smtp netmask 255.255.255.255
static (inside,outside) tcp interface 3389 192.168.135.14 3389 netmask 255.255.255.255
static (inside,inside) 195.241.X.X 192.168.135.13 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
access-group outside_access_out out interface outside
route outside 0.0.0.0 0.0.0.0 195.241.X.X 255
route outside 10.10.1.0 255.255.255.0 192.168.135.254 1
route inside 192.168.136.0 255.255.255.0 192.168.135.231 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.135.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5 TRANS_ESP_3DES_SHA
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 195.93.X.X
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption aes-256
hash sha
group 5
lifetime 86400
crypto isakmp policy 50
authentication pre-share
encryption 3des
hash sha
group 1
lifetime 86400
crypto isakmp policy 70
authentication pre-share
encryption 3des
hash sha
group 5
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics
webvpn
enable outside
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
dns-server value 192.168.135.12 192.168.135.16
vpn-tunnel-protocol IPSec l2tp-ipsec
default-domain value ourcompany.local
group-policy DfltGrpPolicy attributes
group-policy ourcompany internal
group-policy ourcompany attributes
dns-server value 192.168.135.12 192.168.135.16
vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Local_LAN_Access
default-domain value ourcompany.local
webvpn
url-list value ourcompany
tunnel-group DefaultRAGroup general-attributes
address-pool WBadressen
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
tunnel-group ourcompany type remote-access
tunnel-group ourcompany general-attributes
address-pool WBadressen
default-group-policy ourcompany
tunnel-group ourcompany ipsec-attributes
pre-shared-key *
tunnel-group 195.93.X.X type ipsec-l2l
tunnel-group 195.93.X.X ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
class-map http-map1
match access-list http-list2
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ftp
inspect pptp
policy-map http-map1
class http-map1
set connection advanced-options mss-map
!
service-policy global_policy global
service-policy http-map1 interface outside
smtp-server 192.168.135.13
prompt hostname context
Cryptochecksum:e0069e11a7ef03b67364ea3869211d8f
: end
asdm image disk0:/asdm-603.bin
no asdm history enable
The administrator has disabled public write access.

Re: Problem ASA5505 IPSEC VPN 7 years 7 months ago #30228

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
If you suspect an acl issue, why don't you allow any any in your access list and see if that works before you start to tighten it.

However, from the config, I don't believe you are even making it through the isakmp stage.
The administrator has disabled public write access.
Time to create page: 0.102 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup