Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Site2Site VPN and Remote Client VPN

Site2Site VPN and Remote Client VPN 7 years 7 months ago #30036

  • haddock
  • haddock's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
Hey, I got somethings Im wondering about site2site I have tried to configure it up but I just get "no matching crypto map entry for remote proxy" when I check the ASDM. I have checked over my access-list's and for me they look fine I think it can have todo with my "nat (inside)" lines but Im not sure because if I try to set NONAT to "nat (inside) 0 access-list NONAT" my users can't logon with their clients. So I could really need some help with this. I also wonder why my port forwardings doesnt work but that aint that big of a problem if the vpn starts to work. Here is the 2 config's Im using. The first will be the one that both is using site2site and normal users can connect to.

: Saved
:
ASA Version 8.0(2)
!
hostname ciscokontor
domain-name engbergs.se
enable password encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.135.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address *.67.152.157 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd encrypted
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 195.198.219.6
domain-name engbergs.se
dns server-group swipnet
name-server 192.71.220.10
access-list inside_access_in extended permit ip any any
access-list VPN-TO-ASA2 extended permit ip 192.168.135.0 255.255.255.0 192.168.136.0 255.255.255.0
access-list nat0_acl extended permit ip 192.168.135.0 255.255.255.0 192.168.134.0 255.255.255.0
access-list outside_in extended permit tcp any host *.67.152.157 eq 3389
access-list outside_in extended deny ip any any log
access-list NONAT extended permit ip 192.168.135.0 255.255.255.0 192.168.136.0 255.255.255.0
access-list splittunnel standard permit 192.168.135.0 255.255.255.0
access-list rem-access extended permit ip any 192.168.134.0 255.255.255.0
access-list outside-in extended permit icmp any any echo-reply
access-list outside-in extended deny ip any any log
access-list outside-in extended permit tcp any host *.67.152.157 eq ftp
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool vpnpool 192.168.134.1-192.168.134.254
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nat0_acl
nat (inside) 2 access-list NONAT
nat (inside) 1 192.168.135.0 255.255.255.0
static (inside,outside) tcp *.67.152.157 3389 192.168.135.201 3389 netmask 255.255.255.255
static (inside,outside) tcp *.67.152.157 ftp 192.168.135.204 ftp netmask 255.255.255.255
access-group outside-in in interface outside
route outside 0.0.0.0 0.0.0.0 *.67.152.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.135.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set espSHA3DESproto esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address rem-access
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map IPSEC 10 match address VPN-TO-ASA2
crypto map IPSEC 10 set peer *.237.248.14
crypto map IPSEC 10 set transform-set espSHA3DESproto
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 20
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
telnet 192.168.1.2 255.255.255.255 inside
telnet 192.168.135.89 255.255.255.255 inside
telnet 192.168.135.201 255.255.255.255 inside
telnet 192.168.135.2 255.255.255.255 inside
telnet timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.135.2-192.168.135.33 inside
!

threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
group-policy remotevpn internal
group-policy remotevpn attributes
vpn-idle-timeout 30
split-tunnel-policy tunnelspecified
split-tunnel-network-list value splittunnel
username kjell password encrypted
username niklas password encrypted
username hans-erik password encrypted
username haddock password encrypted
username thomas password encrypted
tunnel-group remotevpn type remote-access
tunnel-group remotevpn general-attributes
address-pool vpnpool
default-group-policy remotevpn
tunnel-group remotevpn ipsec-attributes
pre-shared-key *
tunnel-group *.237.248.14 type ipsec-l2l
tunnel-group *.237.248.14 ipsec-attributes
pre-shared-key *
isakmp keepalive threshold 30 retry 5
prompt hostname context

And here is the second one.

: Saved
:
ASA Version 8.0(2)
!
hostname ciscogarage
domain-name engbergs.se
enable password encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.136.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address *.237.248.14 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name engbergs.se
access-list VPN-TO-ASA1 extended permit ip 192.168.136.0 255.255.255.0 192.168.135.0 255.255.255.0
access-list NONAT extended permit ip 192.168.136.0 255.255.255.0 192.168.135.0 255.255.255.0
access-list OUTSIDE_IN extended permit icmp any any echo-reply
access-list OUTSIDE_IN extended deny ip any any log
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0
access-group OUTSIDE_IN in interface outside
route outside 0.0.0.0 0.0.0.0 *.237.248.13 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.136.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set espSHA3DESproto esp-3des esp-sha-hmac
crypto map IPSEC 10 match address VPN-TO-ASA1
crypto map IPSEC 10 set peer *.67.152.157
crypto map IPSEC 10 set transform-set espSHA3DESproto
crypto map IPSEC interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
no crypto isakmp nat-traversal
telnet 192.168.136.2 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
tunnel-group *.67.152.157 type ipsec-l2l
tunnel-group *.67.152.157 ipsec-attributes
pre-shared-key *
isakmp keepalive threshold 30 retry 5
prompt hostname context
The administrator has disabled public write access.

Re: Site2Site VPN and Remote Client VPN 7 years 7 months ago #30077

  • hanapurna
  • hanapurna's Avatar
  • Offline
  • New Member
  • Posts: 9
  • Karma: 0
Hi,

I'll try this setup in the next days, so for now I can't help you.
But to prepare a little bit my implementation, I read this how to from Cisco, maybe it can help you :
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00807f9a89.shtml
The administrator has disabled public write access.
Time to create page: 0.092 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup