Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: ports on same vlan can not talk

ports on same vlan can not talk 7 years 11 months ago #28633

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
as5505.
2 vlans outside and inside
vlan 1 - et01/1,et01/2,et01/3,et01/4,et01/5,et01/6,et01/7
vlan 2 - et0/0

All ports work from outside world doing nat. Only problem I have is talking from any of the ports on vlan 1 to other ports also on vlan 1.

I am open for any suggestions. below is my config

:
ASA Version 7.2(3)
!
hostname iconnect
domain-name default.domain.invalid
enable password XXXXXXXXXXX encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address XXX.XXX.184.74 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd XXXXXX encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
object-group service PASVFTP tcp
port-object range 50000 51000
access-list outside_access_in extended permit tcp any host XXX.XXX.184.75 eq ftp
access-list outside_access_in extended permit tcp any host XXX.XXX.184.75 eq www
access-list outside_access_in extended permit tcp any host XXX.XXX.184.75 eq 3389
access-list outside_access_in extended permit tcp any host XXX.XXX.184.75 eq https
access-list outside_access_in extended permit tcp any host XXX.XXX.184.75 range 50000 51000
access-list outside_access_in extended permit tcp any host XXX.XXX.184.76 eq www
access-list outside_access_in extended permit tcp any host XXX.XXX.184.76 eq ftp
access-list outside_access_in extended permit tcp any host XXX.XXX.184.76 eq https
access-list outside_access_in extended permit tcp any host XXX.XXX.184.77 eq 3314
access-list outside_access_in extended permit tcp any host XXX.XXX.184.77 eq domain
access-list outside_access_in extended permit udp any host XXX.XXX.184.77 eq domain
access-list outside_access_in extended permit tcp any host XXX.XXX.184.79 eq 3306
access-list outside_access_in extended permit tcp any host XXX.XXX.184.80 eq 3307
access-list outside_access_in extended permit tcp any host XXX.XXX.184.79 eq smtp
access-list outside_access_in extended permit tcp any host XXX.XXX.184.79 eq pop3
access-list outside_access_in extended permit tcp any host XXX.XXX.184.79 eq 8484
access-list outside_access_in extended permit tcp any host XXX.XXX.184.79 eq 81
access-list outside_access_in extended permit tcp any host XXX.XXX.184.75 eq 81
access-list outside_access_in extended permit tcp any host XXX.XXX.184.3 eq 1645
access-list outside_access_in extended permit tcp any host XXX.XXX.184.3 eq 1813
access-list outside_access_in extended permit tcp any host XXX.XXX.184.3 eq 3305
access-list outside_access_in extended permit udp any host XXX.XXX.184.3 eq radius
access-list outside_access_in extended permit udp any host XXX.XXX.184.3 eq 1813
access-list outside_access_in extended permit tcp any host XXX.XXX.184.75 object-group PASVFTP
access-list outside_access_in extended permit tcp any host XXX.XXX.184.54 eq www
access-list outside_access_in extended permit tcp any host XXX.XXX.184.54 eq https
access-list outside_access_in extended permit tcp any host XXX.XXX.184.54 eq ftp
access-list outside_access_in extended permit tcp any host XXX.XXX.184.79 eq imap4
access-list outside_access_in extended permit tcp any host XXX.XXX.184.80 eq www
access-list outside_access_in extended permit tcp any host XXX.XXX.184.3 eq 1433
access-list outside_access_in extended permit tcp any host XXX.XXX.184.79 eq 8181
access-list outside_access_in extended permit udp any host XXX.XXX.184.79 eq 25
access-list outside_access_in extended permit tcp any host XXX.XXX.184.49 eq ftp
access-list outside_access_in extended permit tcp any host XXX.XXX.184.49 eq www
access-list outside_access_in extended permit tcp any host XXX.XXX.184.49 eq https
access-list outside_access_in extended permit tcp any host XXX.XXX.184.24 eq smtp
access-list outside_access_in extended permit tcp any host XXX.XXX.184.24 eq pop3
access-list outside_access_in extended permit tcp any host XXX.XXX.184.24 eq 8484
access-list outside_access_in extended permit tcp any host XXX.XXX.184.24 eq 81
access-list outside_access_in extended permit tcp any host XXX.XXX.184.24 eq imap4
access-list ouside_access_in extended permit tcp host XXX.XXX.184.73 host XXX.XXX.184.3 eq 1433
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 2 XXX.XXX.184.0 netmask 255.255.255.0
nat (inside) 2 192.168.2.0 255.255.255.0
static (outside,inside) 192.168.2.2 XXX.XXX.184.75 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.75 192.168.2.2 netmask 255.255.255.255
static (outside,inside) 192.168.2.14 XXX.XXX.184.77 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.77 192.168.2.14 netmask 255.255.255.255
static (outside,inside) 192.168.2.6 XXX.XXX.184.79 netmask 255.255.255.255
static (outside,inside) 192.168.2.7 XXX.XXX.184.80 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.79 192.168.2.6 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.80 192.168.2.7 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.3 192.168.2.5 netmask 255.255.255.255
static (outside,inside) 192.168.2.5 XXX.XXX.184.3 netmask 255.255.255.255
static (outside,inside) 192.168.2.3 XXX.XXX.184.54 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.54 192.168.2.3 netmask 255.255.255.255
static (outside,inside) 192.168.2.51 XXX.XXX.184.49 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.49 192.168.2.51 netmask 255.255.255.255
static (outside,inside) 192.168.2.24 XXX.XXX.184.24 netmask 255.255.255.255
static (inside,outside) XXX.XXX.184.24 192.168.2.24 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 XXX.XXX.184.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http XXX.XXX.184.0 255.255.255.0 outside
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.2.2-192.168.2.254 inside
dhcpd dns XXX.XXX.184.14 207.170.3.6 interface inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:1424f41ba4b9c23719bf6fd657b8b521
: end


My show switch vlan output:
VLAN Name Status Ports
----


1 inside up Et0/1, Et0/2, Et0/3, Et0/4
Et0/5, Et0/6, Et0/7
2 outside up Et0/0
The administrator has disabled public write access.

Re: ports on same vlan can not talk 7 years 11 months ago #28638

  • Kajitora
  • Kajitora's Avatar
  • Offline
  • Frequent Member
  • Posts: 40
  • Karma: 0
Try adding: same-security-traffic permit inter-interface
also, maybe add switchport access vlan 1 to the interfaces, I belive thats the default, but dont have a ASA infront of me.

I dont see why they woudnt talk, but give that a try.
itgamers.blogspot.com
The administrator has disabled public write access.

Re: ports on same vlan can not talk 7 years 11 months ago #28639

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
OK, I Played with your config on an ASA here. Try removing those lines:

[code:1]static (outside,inside) 192.168.2.2 XXX.XXX.184.75 netmask 255.255.255.255
static (outside,inside) 192.168.2.14 XXX.XXX.184.77 netmask 255.255.255.255
static (outside,inside) 192.168.2.6 XXX.XXX.184.79 netmask 255.255.255.255
static (outside,inside) 192.168.2.7 XXX.XXX.184.80 netmask 255.255.255.255
static (outside,inside) 192.168.2.5 XXX.XXX.184.3 netmask 255.255.255.255
static (outside,inside) 192.168.2.3 XXX.XXX.184.54 netmask 255.255.255.255
static (outside,inside) 192.168.2.51 XXX.XXX.184.49 netmask 255.255.255.255
static (outside,inside) 192.168.2.24 XXX.XXX.184.24 netmask 255.255.255.255[/code:1]

In short, remove all static statements with (outside,inside). Keep only the (inside,outside) ones. One (inside,outside) statement is sufficient to do both way translation between the inside and the outside and letting your servers appear with the right IPs to the outside world.

The (outside,inside) statements caused translation of local traffic to outside IPs before getting even switched to the write local ports. Try "debug icmp trace" to see that.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: ports on same vlan can not talk 7 years 11 months ago #28647

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
That was it! Thanks again!
The administrator has disabled public write access.
Time to create page: 0.088 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup