Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: ASA 5505 Lockup

ASA 5505 Lockup 7 years 9 months ago #28379

  • wg72
  • wg72's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
I have a ASA 5505 firewall that is suddenly locking up. It started 2 weeks ago when our provider changed from a static to a dynamic IP (i.e. they tied our MAC to a static IP). Since then every day or so the network will stop working. I am not able to ping the ASA or log into it. I can power off/on and everything starts working.

Can anyone give me help.
The administrator has disabled public write access.

Re: ASA 5505 Lockup 7 years 9 months ago #28384

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
If your ISP offers you a dynamic IP (i.e outside address via DHCP). I believe you need to use the command ip address dhcp on your outside interface. If you have already done that, then posting your config here can help. You can mask out any private info.

Also, when it happens, Are you able to login into the ASA by console? Or is it just telnet that it not working?
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

More Info 7 years 9 months ago #28388

  • wg72
  • wg72's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
Thanks for looking at this. When it locks up I connot log into the ASA with the ASDM software interface. I cannot ping the ASA. I can login using the telnet console, however I do know now to troubleshoot through the console.

Here is my configuration.


: Saved
:
ASA Version 7.2(3)
!
hostname IESASA
domain-name default.domain.invalid
enable password R8oXOL9vUpDFQFqu encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxxxxxx.2KYOU encrypted
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
name-server xx.xx.xx.xx
domain-name default.domain.invalid
dns server-group second
name-server x.x.x.10
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 192.168.0.64 255.255.255.192
access-list inside_nat0_outbound extended permit ip any 192.168.0.64 255.255.255.192
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool xxxPool 192.168.0.90-192.168.0.99 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcp-client client-id interface outside
dhcpd dns x.x.x.11 x.x.x0.10
dhcpd lease 3000
!
dhcpd address 192.168.0.100-192.168.0.150 inside
dhcpd dns x.x.x.11 x.x.x.10 interface inside
dhcpd lease 3000 interface inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
group-policy IESField internal
group-policy IESField attributes
vpn-tunnel-protocol IPSec
username Greg password jwZCgsQnwFOhibOu encrypted
username Greg attributes
vpn-group-policy IESField
username Dale password cy71EJcVepbOUtdk encrypted privilege 3
username Dale attributes
vpn-group-policy IESField
username wade password g/PYZqa8eAmBOTz/ encrypted privilege 15
username wade attributes
vpn-group-policy IESField
username Marty password m9dey/Qa07HKFbDz encrypted privilege 3
username Marty attributes
vpn-group-policy IESField
username KenWillis password Yam5ha/te4bN.tWR encrypted privilege 3
username KenWillis attributes
vpn-group-policy IESField
tunnel-group IESField type ipsec-ra
tunnel-group IESField general-attributes
address-pool IESPool
default-group-policy IESField
tunnel-group IESField ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:0322d14d3c01245eeeeac1d26ce4df1b
: end
The administrator has disabled public write access.

Re: ASA 5505 Lockup 7 years 9 months ago #28393

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Can't see what it could be. Can you show route before and after it happens?. I'm thinking the route outside 0.0.0.0 0.0.0.0 x.x.x.x 1 might be interfering with the ip address dhcp setroute since the "setroute" keyword autmatically causes the ASA to set the default route using the default gateway given by DHCP from the ISP. Try removing the route outside 0.0.0.0 0.0.0.0 x.x.x.x 1 command.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: ASA 5505 Lockup 7 years 9 months ago #28394

  • wg72
  • wg72's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
I did as you suggested, I removed teh route outside. Then I did a show route. Here it is if you would like to see it.

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is x.x.x.193 to network 0.0.0.0

C x.x.x.192 255.255.255.192 is directly connected, outside
C 127.1.0.0 255.255.0.0 is directly connected, _internal_loopback
C 192.168.0.0 255.255.255.0 is directly connected, inside
d* 0.0.0.0 0.0.0.0 [1/0] via x.x.x.193, outside

As I mentioned earlier, this problem only happens every day or so. I will wait and see if it happens again and keep you updated.


Thanks for the help.
The administrator has disabled public write access.

Re: ASA 5505 Lockup 7 years 9 months ago #28396

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
The last line in your routing table (d* 0.0.0.0 0.0.0.0 [1/0] via x.x.x.193, outside) shows that "setroute" is probably doing it's job correctly

Sure, take your time and tell us if it happens again or not :)
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.089 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup