Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Problem ASA5505; Cannot acces internal services...

Problem ASA5505; Cannot acces internal services... 8 years 2 weeks ago #28136

  • Quen
  • Quen's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Karma: 0
Problem ASA5505; Cannot acces internal services (mail/rdp etc) from inside via outside address (dns name for example).


Dear Firewall.cx user,

I have a problem at my work with the Cisco ASA 5505. The problem is:

We cannot open our external mail via the domain name inside (https:\\example.company.com). Offsite (at home for example) it works great. It is not only our mail, it is a problem for all services adressed via our external router ip that cannot be used from the inside.

The problem isn't the access lists, because there is no ACL error in the Cisco ASA Log.

Thnx in advance,

Quen :roll:
The administrator has disabled public write access.

Re: Problem ASA5505; Cannot acces internal services... 8 years 2 weeks ago #28139

  • r0nni3
  • r0nni3's Avatar
  • Offline
  • Distinguished Member
  • Posts: 107
  • Karma: 0
Ok so from what i understand is that you try to connect to a server using your public ip from the inside of your ASA? If thats true its not gonna work and your gonna have to use the inside address of the server.
Could you post your config (ofcourse with IP addresses masked) so i could take a closer look at it please ?


Ron.
Currently working as Cisco Engineer at Neon-Networking.

Certifications:
CCNA - Have it
CCNA Security - Have it
CCSP - Almost!!!!
CCIE Security - Not so far away dream
The administrator has disabled public write access.

Re: Problem ASA5505; Cannot acces internal services... 8 years 2 weeks ago #28142

  • Quen
  • Quen's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Karma: 0
Dear Ron, Thnx for the quick reply! Before we used a Zyxel and it worked fine. We could access the public interface of the zyxel and use it to go to our internal webmail server.


Here is my config.

: Saved
:
ASA Version 8.0(3)
!
hostname ciscoasa
domain-name xxxxxxx
enable password pglHB8qK7Hb.bnRD encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.135.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp
!
interface Vlan5
shutdown
nameif dmz
security-level 50
ip address 10.0.0.1 255.0.0.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
switchport access vlan 5
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxxxxxxxxxxx encrypted
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns server-group DefaultDNS
name-server xx.xxx.xx.xx
name-server xx.xxx.xx.xx
domain-name domain
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
access-list outside_access_out extended permit tcp any any eq www
access-list outside_access_out extended permit tcp any any eq https
access-list outside_access_out extended permit object-group TCPUDP any any eq domain
access-list outside_access_out extended permit tcp any any eq 3389
access-list outside_access_out extended permit tcp any any eq smtp
access-list outside_access_out extended permit tcp any any eq 8890
access-list outside_access_out extended permit tcp any any eq ftp-data
access-list outside_access_out extended permit tcp any any eq ftp
access-list outside_access_out extended permit tcp any any eq pptp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list inside_nat0_outbound extended permit ip any 192.168.135.96 255.255.255.240
access-list Local_LAN_Access standard permit 192.168.135.0 255.255.255.0
access-list http-list2 extended permit tcp any host xx.xx.x.xxx
access-list http-list2 extended permit tcp any host xx.xx.x.xxx
access-list http-list2 extended permit tcp any host xxx.xxx.x.xxx
!
tcp-map mss-map
exceed-mss allow
!
pager lines 24
logging enable
logging asdm informational
logging from-address administrator@domain
logging recipient-address systeembeheer@domain level errors
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool WBadressen 192.168.135.100-192.168.135.105 mask 255.255.255.0
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.135.14 3389 netmask 255.255.255.255
static (inside,outside) tcp interface https 192.168.135.13 https netmask 255.255.255.255
static (inside,outside) tcp interface smtp 192.168.135.13 smtp netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group outside_access_out out interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.x.xxx 255
route outside 192.168.136.0 255.255.255.0 192.168.135.231 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.135.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5 TRANS_ESP_3DES_SHA
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption aes-256
hash sha
group 5
lifetime 86400
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics
webvpn
enable outside
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
dns-server value 192.168.135.12 192.168.135.16
vpn-tunnel-protocol IPSec l2tp-ipsec
default-domain value domain.local
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol l2tp-ipsec webvpn
group-policy domain internal
group-policy domain attributes
dns-server value 192.168.135.12 192.168.135.16
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Local_LAN_Access
default-domain value domain.local
username Pietje password xxxxxxxxxxxxxxxxx encrypted
tunnel-group DefaultRAGroup general-attributes
address-pool WBadressen
tunnel-group DefaultRAGroup ipsec-attributes
pre-shared-key *
tunnel-group domain type remote-access
tunnel-group domain general-attributes
address-pool WBadressen
default-group-policy domain
tunnel-group domain ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
class-map http-map1
match access-list http-list2
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ftp
inspect pptp
policy-map http-map1
class http-map1
set connection advanced-options mss-map
!
service-policy global_policy global
service-policy http-map1 interface outside
smtp-server 192.168.135.13
prompt hostname context
Cryptochecksum:75659e4a934812a7f0a5717639615e33
: end
asdm image disk0:/asdm-603.bin
no asdm history enable
The administrator has disabled public write access.

Re: Problem ASA5505; Cannot acces internal services... 8 years 2 weeks ago #28143

  • r0nni3
  • r0nni3's Avatar
  • Offline
  • Distinguished Member
  • Posts: 107
  • Karma: 0
access-list outside_access_out extended permit tcp any any eq www
access-list outside_access_out extended permit tcp any any eq https
access-list outside_access_out extended permit object-group TCPUDP any any eq domain
access-list outside_access_out extended permit tcp any any eq 3389
access-list outside_access_out extended permit tcp any any eq smtp
access-list outside_access_out extended permit tcp any any eq 8890
access-list outside_access_out extended permit tcp any any eq ftp-data
access-list outside_access_out extended permit tcp any any eq ftp
access-list outside_access_out extended permit tcp any any eq pptp
You can remove this because it adds no value. The ASA permits traffic from a higher security level (inside) to a lower security level (outside) by default. So there is no need for this access-list.
route outside 192.168.136.0 255.255.255.0 192.168.135.231 1

The route outside should be changed to route inside. Because now your telling the ASA to look for the 192.168.136.0 subnet on the outside.

I don't see the reason why it shouldn't work but thats maybe because its allmost midnight and i'm pretty sleepy :p. You have your static and your access-list that permits traffic to the host.
I'll take another look tomorrow when i'm actually awake.



Ron.
Currently working as Cisco Engineer at Neon-Networking.

Certifications:
CCNA - Have it
CCNA Security - Have it
CCSP - Almost!!!!
CCIE Security - Not so far away dream
The administrator has disabled public write access.

Re: Problem ASA5505; Cannot acces internal services... 8 years 2 weeks ago #28144

  • Quen
  • Quen's Avatar
  • Offline
  • New Member
  • Posts: 10
  • Karma: 0
Thanx again Ron. I hope to hear more from you tomorrow! Sleep well. Quen :wink:
The administrator has disabled public write access.

Re: Problem ASA5505; Cannot acces internal services... 8 years 2 weeks ago #28166

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
You want to access your inside server from inside but using the external IP of the server. Is that what you want? If so, then its not going to work by default (As r0nni3 said in his first post). Because the ASA does not allow a packet to exit the same interface that it entered from. First you have to allow this by using:
[code:1]same-security-traffic permit intra-interface[/code:1]
Then you need to add static statements that will map from inside to inside. Like this:
[code:1]static (inside,inside) tcp <outside_IP> 3389 192.168.135.14 3389 netmask 255.255.255.255
static (inside,inside) tcp <outside_IP> https 192.168.135.13 https netmask 255.255.255.255
static (inside,inside) tcp <outside_IP> smtp 192.168.135.13 smtp netmask 255.255.255.255[/code:1]

Replace <outside_IP> above by your outside interface IP.

Yes, (inside,inside)!!. You can do this. the ASA is that flexible :).

Hope this helps.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
Time to create page: 0.096 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup