Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: PPTP VPN to external network issue (ASA 5505)

PPTP VPN to external network issue (ASA 5505) 8 years 1 month ago #27735

  • pvr02
  • pvr02's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Karma: 0
I'm pretty new to the cisco scene and have recently switched my linksys WRT54G with a Cisco ASA 5505. I have the ASA setup and working great with my intenet and VPN from the internet to my house. However my dad is having some issues connecting to his office from the house using a PPTP vpn connection.

It started off by timing out while trying to authenticate him. I make some changes to the firewall using the commands below and now it connects however when checking the traffic on the local computer it isn't receiving any packets and I can't ping their PPTP server or get to their file server which we were doing on the Linksys router.

Commands I used to get it connected:
policy-map global_policy
class inspection_default
inspect pptp

Result of the command: "show running-config"

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name xxxxxxxxxx.local
enable password xxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 172.16.0.1 255.255.0.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Vlan3
shutdown
no forward interface Vlan1
nameif dmz
security-level 50
ip address 10.1.1.1 255.255.0.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 3
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
domain-name xxxxxxxxxx.local
access-list inside_nat0_outbound extended permit ip 172.16.0.0 255.255.0.0 172.16.0.64 255.255.255.192
access-list inside_nat0_outbound extended permit ip any 172.16.0.64 255.255.255.192
access-list CiscoVPN_splitTunnelAcl standard permit 172.16.0.0 255.255.0.0
pager lines 24
logging trap informational
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool VPNDHCP 172.16.0.91-172.16.0.100 mask 255.255.0.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 172.16.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
vpn-sessiondb max-session-limit 2
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

group-policy CiscoVPN internal
group-policy CiscoVPN attributes
dns-server value 172.16.0.4 68.87.72.130
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value CiscoVPN_splitTunnelAcl
default-domain value xxxxxxxxx.local
username xxxxx password xxxxxxxxxxxxxx encrypted privilege 0
username xxxxx attributes
vpn-group-policy CiscoVPN
tunnel-group CiscoVPN type ipsec-ra
tunnel-group CiscoVPN general-attributes
address-pool VPNDHCP
default-group-policy CiscoVPN
tunnel-group CiscoVPN ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9c6e7082018a037f2d606e7dbce4a7a3
: end


I would greatly appreciate any help you may have.

Thanks in advance.
The administrator has disabled public write access.
Time to create page: 0.082 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup