Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: asa 5505 is driving me mad!

asa 5505 is driving me mad! 8 years 3 months ago #26404

  • fwmichael
  • fwmichael's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
Hi everyone,
I recently offered to help a friend setup his new business' network and he went out and bought a cisco asa 5505 without mentioning anything. Im now stuck trying to host an ftp site in its DMZ and i cant for the life of me get it working. Can anyone help?
Ive posted the latest running config below, removing all sensitive information. The isp gave him the following ip details:
He has the ip range x.x.x.16 with the mask of 255.255.255.240. Their router is on x.x.x.17. Ive put the asa on x.x.x.18 and am hoping to put the ftp site on x.x.x.19.
My first thought was that maybe i havent setup the external ip range correctly and thats causing problems.
Any help would be much appreciated! Thanks

ASA Version 7.2(3)
!
hostname london
domain-name london
enable password xxxxx encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.18 255.255.255.240
!
interface Vlan3
nameif dmz
security-level 50
ip address 192.168.3.254 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 3
!
passwd xxxxxx encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name london
object-group service FTP tcp
port-object eq ftp
port-object eq ftp-data
access-list outside_access_in extended permit tcp any host x.x.x.19
access-list dmz_access_out extended permit tcp host 192.168.3.2 object-group FTP any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
no failover
monitor-interface inside
monitor-interface outside
monitor-interface dmz
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 200 interface
global (dmz) 200 192.168.3.1-192.168.3.25 netmask 255.255.255.0
nat (inside) 200 192.168.1.0 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 1 192.168.3.0 255.255.255.0
static (dmz,outside) x.x.x.19 192.168.3.2 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group dmz_access_out out interface dmz
route outside 0.0.0.0 0.0.0.0 x.x.x.17 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.20-192.168.1.150 inside
dhcpd dns x.x.x.x x.x.x.x interface inside
dhcpd domain fwlondon interface inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:886393100af3b5fe165e28114adedcda
: end
asdm image disk0:/asdm-523.bin
no asdm history enable
The administrator has disabled public write access.

Re: asa 5505 is driving me mad! 8 years 3 months ago #26409

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
What bundle of the ASA5505 did your friend purchase. The basic security only supplies two security zones. There is a third security zone but that is a limited zone, where it can only communicate with one other zone.
The administrator has disabled public write access.

Re: asa 5505 is driving me mad! 8 years 3 months ago #26411

  • fwmichael
  • fwmichael's Avatar
  • Offline
  • New Member
  • Posts: 2
  • Karma: 0
aha! That may make total sense, he got the cheap bundle, ill check the specifics tomorrow.
One last question. Have i configured the outside IP addressing correctly? Ive been given a 255.255.255.240 subnet with the network address of x.x.x.16. The isp put a router at x.x.x.17 and ive put the outside interface at x.x.x.18 with the subnet of 255.255.255.240.
The administrator has disabled public write access.

Re: asa 5505 is driving me mad! 8 years 3 months ago #26412

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
Well, it falls withing the subnetwork.
aha! That may make total sense, he got the cheap bundle, ill check the specifics tomorrow.
One last question. Have i configured the outside IP addressing correctly? Ive been given a 255.255.255.240 subnet with the network address of x.x.x.16. The isp put a router at x.x.x.17 and ive put the outside interface at x.x.x.18 with the subnet of 255.255.255.240.
The administrator has disabled public write access.
Time to create page: 0.086 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup