Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: accessing other servers from internal

accessing other servers from internal 8 years 6 months ago #26310

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
I have 5 servers behind my asa5505. outside world gets to them perfectly and they go out perfectly. but i can not get server 1 to talk to server 2. (192.168.2.2 to talk to 192.168.2.5). any ideas? below is my config

: Saved
:
ASA Version 7.2(3)
!
hostname iconnect
domain-name default.domain.invalid
enable password ****** encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address xxx.xxx.184.74 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 3Xo1V7gQuBf5IAPD encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq ftp
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq www
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq 3389
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq https
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 range 50000 51000
access-list outside_access_in extended permit tcp any host xxx.xxx.184.76 eq www
access-list outside_access_in extended permit tcp any host xxx.xxx.184.76 eq ftp
access-list outside_access_in extended permit tcp any host xxx.xxx.184.76 eq https
access-list outside_access_in extended permit tcp any host xxx.xxx.184.77 eq 3314
access-list outside_access_in extended permit tcp any host xxx.xxx.184.77 eq domain
access-list outside_access_in extended permit udp any host xxx.xxx.184.77 eq domain
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 3305
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq 3306
access-list outside_access_in extended permit tcp any host xxx.xxx.184.80 eq 3307
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 1433
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 1645
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 1813
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq smtp
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq pop3
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq 8484
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq 81
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq 81
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 2 xxx.xxx.184.0 netmask 255.255.255.0
nat (inside) 2 192.168.2.0 255.255.255.0
static (outside,inside) 192.168.2.2 xxx.xxx.184.75 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.75 192.168.2.2 netmask 255.255.255.255
static (outside,inside) 192.168.2.3 xxx.xxx.184.76 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.76 192.168.2.3 netmask 255.255.255.255
static (outside,inside) 192.168.2.14 xxx.xxx.184.77 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.77 192.168.2.14 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.78 192.168.2.5 netmask 255.255.255.255
static (outside,inside) 192.168.2.5 xxx.xxx.184.78 netmask 255.255.255.255
static (outside,inside) 192.168.2.6 xxx.xxx.184.79 netmask 255.255.255.255
static (outside,inside) 192.168.2.7 xxx.xxx.184.80 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.79 192.168.2.6 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.80 192.168.2.7 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.184.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.2.2-192.168.2.254 inside
dhcpd dns xxx.xxx.184.14 207.170.3.6 interface inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
username xxxx password xxxxx encrypted
prompt hostname context
Cryptochecksum:0ad88733f9e4cdc13f98a125a6bec2f2
: end
iconnect#
The administrator has disabled public write access.

Re: accessing other servers from internal 8 years 6 months ago #26315

  • skepticals
  • skepticals's Avatar
  • Offline
  • Expert Member
  • Posts: 783
  • Karma: 0
How are you try to communicate between the two servers? Can you ping each other? Web?

Are both servers in a switch off the same ASA interface?
The administrator has disabled public write access.

Re: accessing other servers from internal 8 years 6 months ago #26321

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
Devices within the same layer 2 VLAN should not have any problems communicating with each other. Such communication does not pass through the firewall. The traffic gets dropped on the wire and the device with the MAC address in the destination field picks up the packet.

I have 5 servers behind my asa5505. outside world gets to them perfectly and they go out perfectly. but i can not get server 1 to talk to server 2. (192.168.2.2 to talk to 192.168.2.5). any ideas? below is my config

: Saved
:
ASA Version 7.2(3)
!
hostname iconnect
domain-name default.domain.invalid
enable password ****** encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address xxx.xxx.184.74 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 3Xo1V7gQuBf5IAPD encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq ftp
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq www
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq 3389
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq https
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 range 50000 51000
access-list outside_access_in extended permit tcp any host xxx.xxx.184.76 eq www
access-list outside_access_in extended permit tcp any host xxx.xxx.184.76 eq ftp
access-list outside_access_in extended permit tcp any host xxx.xxx.184.76 eq https
access-list outside_access_in extended permit tcp any host xxx.xxx.184.77 eq 3314
access-list outside_access_in extended permit tcp any host xxx.xxx.184.77 eq domain
access-list outside_access_in extended permit udp any host xxx.xxx.184.77 eq domain
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 3305
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq 3306
access-list outside_access_in extended permit tcp any host xxx.xxx.184.80 eq 3307
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 1433
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 1645
access-list outside_access_in extended permit tcp any host xxx.xxx.184.78 eq 1813
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq smtp
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq pop3
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq 8484
access-list outside_access_in extended permit tcp any host xxx.xxx.184.79 eq 81
access-list outside_access_in extended permit tcp any host xxx.xxx.184.75 eq 81
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 2 xxx.xxx.184.0 netmask 255.255.255.0
nat (inside) 2 192.168.2.0 255.255.255.0
static (outside,inside) 192.168.2.2 xxx.xxx.184.75 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.75 192.168.2.2 netmask 255.255.255.255
static (outside,inside) 192.168.2.3 xxx.xxx.184.76 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.76 192.168.2.3 netmask 255.255.255.255
static (outside,inside) 192.168.2.14 xxx.xxx.184.77 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.77 192.168.2.14 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.78 192.168.2.5 netmask 255.255.255.255
static (outside,inside) 192.168.2.5 xxx.xxx.184.78 netmask 255.255.255.255
static (outside,inside) 192.168.2.6 xxx.xxx.184.79 netmask 255.255.255.255
static (outside,inside) 192.168.2.7 xxx.xxx.184.80 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.79 192.168.2.6 netmask 255.255.255.255
static (inside,outside) xxx.xxx.184.80 192.168.2.7 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.184.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.2.2-192.168.2.254 inside
dhcpd dns xxx.xxx.184.14 207.170.3.6 interface inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
username xxxx password xxxxx encrypted
prompt hostname context
Cryptochecksum:0ad88733f9e4cdc13f98a125a6bec2f2
: end
iconnect#
The administrator has disabled public write access.

Re: accessing other servers from internal 8 years 6 months ago #26344

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
one is plugged into ethernet4 and other is in ethernet5. I have them plugged into the back of the asa 5505. The 2 servers can not ping each other at all. Maybe i dont have the ports included in the vlan maybe?
The administrator has disabled public write access.

Re: accessing other servers from internal 8 years 6 months ago #26346

  • skepticals
  • skepticals's Avatar
  • Offline
  • Expert Member
  • Posts: 783
  • Karma: 0
Which VLANs are those ports in?
The administrator has disabled public write access.

Re: accessing other servers from internal 8 years 6 months ago #26349

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
in Ethernet0/4 and Ethernet 0/5 I do not have those Ethernet ports labels in the Vlan. The above config is what is running. SHould I define unter the Ethernet0/4 and 5 interfaces that they are in the "inside" Vlan?
The administrator has disabled public write access.
Time to create page: 0.091 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup