Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: new on nating

new on nating 9 years 2 weeks ago #24096

  • armani
  • armani's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
Dear all
I'm a new person on Cisco ASA 5505. I'd like to configure nating between two hosts. can somebody guide me how to configure that.
lets assume:
pirvate ip address: 10.8.8.1
public ip address: 10.10.10.1
The administrator has disabled public write access.

Re: new on nating 9 years 2 weeks ago #24098

  • armani
  • armani's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
anyone could help me?
The administrator has disabled public write access.

Re: new on nating 9 years 2 weeks ago #24102

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
Why don't you attempt it first and and we'll help you. Giving you the answer is easy but that won't help you learn.
The administrator has disabled public write access.

Re: new on nating 9 years 2 weeks ago #24106

  • pfunix
  • pfunix's Avatar
  • Offline
  • New Member
  • Posts: 7
  • Karma: 0
this link is a great place to start.

www.cisco.com/en/US/products/hw/vpndevc/...186a008046f31a.shtml

goodluck,
pf
The administrator has disabled public write access.

configuration 9 years 2 weeks ago #24115

  • armani
  • armani's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
Hi All

Thanks a lot for your response. This is what i have done so far, but still can't ping another host and vice versa. can you just look at my configuration and guide me?

:
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password K2T/yDv1cYSJKgZq encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.3.3.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 10.2.2.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit icmp any any echo
access-list outside_access_in extended permit icmp 0.0.0.0 255.255.255.0 host 10
.2.2.3 echo-reply
access-list outside_access_in extended permit icmp host 10.3.3.2 host 10.2.2.3
access-list outside_access_in extended permit ip host 10.3.3.2 host 10.2.2.3
access-list outside_access_in extended permit icmp any host 10.2.2.3 echo
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 2 interface
nat (inside) 2 10.3.3.0 255.255.255.0
static (inside,outside) 10.2.2.3 10.3.3.2 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 10.2.2.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.3.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
dhcpd address 10.3.3.2-10.3.3.100 inside
dhcpd enable inside
!
dhcpd address 10.2.2.3-10.2.2.30 outside
dhcpd enable outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:f69cb9202da7b5f34390ae5bedaa158c
: end
The administrator has disabled public write access.

Re: new on nating 9 years 2 weeks ago #24121

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
based on your configuration:

inside - 10.3.3.0/24
outside - 10.2.2.0/24

1. Assign a physical interface to the outside vlan
2. Assign a physical interface to the inside vlan
3. Set the security for the inside vlan to 100 (just some big number)
4. Set the security of the outside vlan to 0 (just some number smaller than inside)
5. Define what needs to be NATted on the inside
6. Define the global pool on the outside
7. Make sure you have routing in place

That's all you need to go from the inside to the outside.

If you want to go from the outside to the inside:

8. Define a static translation for the inside host to appear on the outside
9. Create an access list which permits the traffic
10. Assign the access-list to the outside interface inbound
The administrator has disabled public write access.
Time to create page: 0.083 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup