Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: nating configuration problem

nating configuration problem 9 years 1 week ago #24034

  • amrins
  • amrins's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
Hi guys ,
I'm using ASA 5505. :cry: I'm having a problem in my nat configuration especially, when I pinged host B by host A. It was working before but the host B it was not responding to ping from host A in the same subnet.
So, my configuration currently is not pinging between two hosts Could you please look at my configuration below and guide me to solve my configuration problem?
Hint: I want to ping A to B and B to A .
inside IP -->10.3.3.1 outside IP -->10.4.4.1
IP host of A --> 10.3.3.3 and IP default-gateway --> 10.3.3.1
IP host of B --> 10.4.4.3 and IP default-gateway --> 10.4.4.1

ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password K2T/yDv1cYSJKgZq encrypted
names
!
interface Vlan1
nameif inside
security-level 50
ip address 10.3.3.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 10.4.4.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp host 10.4.4.3 host 10.3.3.3
access-list outside_access_in extended permit icmp host 10.3.3.3 host 10.4.4.3
access-list inside_access_in extended permit icmp 10.3.3.0 255.255.255.0 10.4.4.
0 255.255.255.0
access-list inside_access_out extended permit tcp 10.3.3.0 255.255.255.0 10.4.4.
0 255.255.255.0
access-list inside_access_out extended permit ip any any
access-list ouside_access_in extended permit icmp any any echo-reply
access-list inside_nat0_outbound extended permit ip any 10.4.4.0 255.255.255.0
access-list outside_access_out extended permit ip any any
access-list inside extended permit ip any any
access-list outide extended permit ip any any
access-list outside_acess_in extended permit icmp host 10.4.4.4 host 10.3.3.4
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 10.4.4.3 10.3.3.3 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 10.4.4.10 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.3.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.3.3.2-10.3.3.129 inside
dhcpd enable inside
!
dhcpd address 10.4.4.2-10.4.4.12 outside
dhcpd enable outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b5236af9e8fef5093f1a421ff8efbe06
: end
The administrator has disabled public write access.

Re: nating configuration problem 9 years 1 week ago #24036

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
Please write erase and start over. There's too much mess in the configuration.


You don't have any physical interfaces assigned to vlan 1. Your access list are wrong and theres too much mess there. Your static mapping is all messed up.




Hi guys ,
I'm using ASA 5505. :cry: I'm having a problem in my nat configuration especially, when I pinged host B by host A. It was working before but the host B it was not responding to ping from host A in the same subnet.
So, my configuration currently is not pinging between two hosts Could you please look at my configuration below and guide me to solve my configuration problem?
Hint: I want to ping A to B and B to A .
inside IP -->10.3.3.1 outside IP -->10.4.4.1
IP host of A --> 10.3.3.3 and IP default-gateway --> 10.3.3.1
IP host of B --> 10.4.4.3 and IP default-gateway --> 10.4.4.1

ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password K2T/yDv1cYSJKgZq encrypted
names
!
interface Vlan1
nameif inside
security-level 50
ip address 10.3.3.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 10.4.4.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp host 10.4.4.3 host 10.3.3.3
access-list outside_access_in extended permit icmp host 10.3.3.3 host 10.4.4.3
access-list inside_access_in extended permit icmp 10.3.3.0 255.255.255.0 10.4.4.
0 255.255.255.0
access-list inside_access_out extended permit tcp 10.3.3.0 255.255.255.0 10.4.4.
0 255.255.255.0
access-list inside_access_out extended permit ip any any
access-list ouside_access_in extended permit icmp any any echo-reply
access-list inside_nat0_outbound extended permit ip any 10.4.4.0 255.255.255.0
access-list outside_access_out extended permit ip any any
access-list inside extended permit ip any any
access-list outide extended permit ip any any
access-list outside_acess_in extended permit icmp host 10.4.4.4 host 10.3.3.4
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 10.4.4.3 10.3.3.3 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 10.4.4.10 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 10.3.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.3.3.2-10.3.3.129 inside
dhcpd enable inside
!
dhcpd address 10.4.4.2-10.4.4.12 outside
dhcpd enable outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b5236af9e8fef5093f1a421ff8efbe06
: end
The administrator has disabled public write access.

Re: nating configuration problem 9 years 1 week ago #24038

  • amrins
  • amrins's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
I will erase it all and start over but what shoud I start writing first?
The administrator has disabled public write access.

Re: nating configuration problem 9 years 1 week ago #24058

  • sp1k3tou
  • sp1k3tou's Avatar
  • Offline
  • Frequent Member
  • Posts: 65
  • Karma: 0
Is there a reason why your not assigning IP addresses to the interfaces? Also I would change your security level for the inside to 100. It is always good to use 50 for a DMZ.
The administrator has disabled public write access.

Re: nating configuration problem 9 years 1 week ago #24061

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
The ASA5505 has switch interfaces only, not layer 3 interfaces and as such you cannot assign IP addresses directly to the physical interfaces. You can, however, assign the physical interfaces to vlans and assign IP addresses to the vlans.
Is there a reason why your not assigning IP addresses to the interfaces? Also I would change your security level for the inside to 100. It is always good to use 50 for a DMZ.
The administrator has disabled public write access.

Re: nating configuration problem 9 years 1 week ago #24062

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
1. Assign high security to the inside interface
2. Assign low security to the outside interface
3. Assign a security level in between to the dmz interface
4. To go from high security to low security, you need a global and a nat.
5. To go from a low security to a high security, you need a static and an ACL.

Since you are learning and I want you to learn, I'll let you think about how these are setup and where to put the access-list. I'll come back later tonight or tomorrow to post more clues, if you still need them.



I will erase it all and start over but what shoud I start writing first?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.090 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup