Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: configuring ASA 5505 with Small Business Server

configuring ASA 5505 with Small Business Server 9 years 7 months ago #21477

I recently purchased a ASA 5505 to replace my Microsoft ISA server. As a test I set up MS Small business server as a test box to get familiar with configuring the ASA. The SBS has exchange server, DHCP and DNS all enabled. the DNS has forwarders pointing to my ISP DNS servers. My Client machines all point to the DNS server on the SBS Server. In the default configuration everything works fine and the client machine can access the internet without issue. Once I establish a static route to the server to publish the mail server, the clients can no longer resolve names outside of the local machines. I've tried may different configurations and ACL's and can't seem to get it to work. I was hoping that one of you might be able to point me in the right direction. Below is the show config that works (No Static route to the Mail server) and the Show config after I add the routes.

Thanks in advance!

Todd

Original Config

ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 209.XXX.XXX.6 255.255.255.128
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
monitor-interface inside
monitor-interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 209.XXX.XXX.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.254 inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9cd54b43626cea00e384c1552765c3bd

End Original Config

Config with Static route to Mail Server/ DNS

: Saved
:
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 209.XXX.XXX.6 255.255.255.128
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any host 209.XXX.XXX.8 eq smtp
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
monitor-interface inside
monitor-interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 209.XXX.XXX.8 192.168.1.2 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 209.XXX.XXX.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.254 inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9cd54b43626cea00e384c1552765c3bd


End Config with Static route to Mail Server/ DNS
The administrator has disabled public write access.

Fixed it Myself 9 years 7 months ago #21555

I changed the Static Nat rule to Enable PAT (TCP SMTP(25) to SMTP(25).

I then added a Static Nat rule for Inside IP to Public IP with PAT Enabled (TCP Domain(53) to Domain(53))

Added ACL’s to open outside to Public IP address for TCP ANY to SMTP(25) and ISP DNS Servers to public IP address for TCP ANY to Domain(53)
The administrator has disabled public write access.

Re: configuring ASA 5505 with Small Business Server 9 years 7 months ago #21593

  • anti-hack
  • anti-hack's Avatar
  • Offline
  • Frequent Member
  • Posts: 38
  • Karma: 0
great work,

could you please post the running config of the setup ??
The administrator has disabled public write access.

Re: configuring ASA 5505 with Small Business Server 9 years 6 months ago #21692

Upon Further Review, I didn't even need to set up the Nat and ACL for Port 53. So I removed it. Here's the running config. FYI I also mapped ports 80 and 443 to a different server 192.168.1.20. If you are using the SBS as your webserver for remote access you should map those over to 192.168.1.2

Todd


: Saved
:
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password ************* encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 209.xxx.xxx.6 255.255.255.128
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd ************** encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service Http_Ports tcp
port-object eq www
port-object eq https
object-group network DNS_Servers
network-object host 209.xxx.xxx.2
network-object host 209.xxx.xxx.5
access-list outside_access_in extended permit tcp any host 209.xxx.xxx.8 eq smtp
access-list outside_access_in extended permit tcp any host 209.xxx.xxx.8 object-group Http_Ports
access-list outside_access_in extended permit tcp object-group DNS_Servers host 209.xxx.xxx.8 eq domain inactive
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
monitor-interface inside
monitor-interface outside
icmp unreachable rate-limit 1 burst-size 1
icmp deny any outside
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp 209.xxx.xxx.8 smtp 192.168.1.2 smtp netmask 255.255.255.255
static (inside,outside) tcp 209.xxx.xxx.8 www 192.168.1.20 www netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 209.xxx.xxx.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.254 inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
ssl encryption des-sha1 rc4-md5
prompt hostname context
Cryptochecksum:********************
: end
The administrator has disabled public write access.

Re: configuring ASA 5505 with Small Business Server 7 years 1 week ago #32805

  • ratheesh1
  • ratheesh1's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hi Dude

you have to creat a access-list like this and apply in the direction inside on outside interface
access-list 101 extended permit udp any any eq domain


After that in ur SBS server go to dns in administrative tolls and go to properties in the query forward tab put ur public dns as per ISP.


This will solve ur issue.If not let me know

You can mail me at This email address is being protected from spambots. You need JavaScript enabled to view it.


Have a nice time

Regards
Ratheesh
The administrator has disabled public write access.

Re: configuring ASA 5505 with Small Business Server 6 years 9 months ago #33677

The first full static nat that you configured was binding the whole interface address to the SBS, so the clients could not get outside. I always use port redirection instead of full static nat in similar network cases.

Well done.

Harris
The administrator has disabled public write access.
Time to create page: 0.104 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup