Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: ASA 5505 Email Passthrough Problem

ASA 5505 Email Passthrough Problem 9 years 7 months ago #21223

  • gasman
  • gasman's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hello,
I am having a problem getting email to pass to my email server behind our ASA 5505. Computers behind the firewall can access the internet. The mailserver can send mail out messages. It cannot get mail through from outside. I have added Static NAT rules for SMTP and HTTPS but nothing is getting through from outside.

I have been working with routers for a number of years but I am new to the Cisco ASA 5505 series.

My network is a simple one.
Internet >>> ASA5505 >>>> Server + Workstations
XXX.XXX.74.51 > XXX.XXX.74.52 > 192.168.X.X

I am not sure if it is a NAT issue or an ACL one. Any help appreciated.

Below is my config file.
Any help appreciated.
hostname *********
domain-name ***.**
enable password ************ encrypted
names
name 192.168.*.* srv1 description File Server
name *.*.74.52 Out description Outside Interface
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.*.* 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address Out 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd *********** encrypted
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
domain-name ***.**
access-list outside_access_in extended permit tcp any eq smtp interface outside eq smtp
access-list outside_access_in extended permit tcp any eq https interface outside eq https
access-list outside_access_in extended permit icmp any any time-exceeded
access-list outside_access_in extended permit icmp any any echo
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp any any unreachable
access-list outside_access_in extended deny icmp any any
access-list outside_access_in extended permit tcp any host Out eq www
access-list inside_access_in extended permit tcp any eq smtp host srv1 eq smtp
access-list inside_access_in extended permit ip any host srv1
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,inside) tcp Out https srv1 https netmask 255.255.255.255
static (inside,outside) tcp interface smtp rv1 smtp netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 *.*.74.51 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
username administrator password ************* encrypted privilege 15
http server enable
http 192.168.*.* 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.*.* 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
ntp server srv1 source inside prefer
smtp-server 192.168.*.*
prompt hostname context
Cryptochecksum:9*******************************
: end
asdm image disk0:/asdm-522.bin
no asdm history enable
The administrator has disabled public write access.

Re: ASA 5505 Email Passthrough Problem 9 years 7 months ago #21371

  • Dubsy
  • Dubsy's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
I had to turn off the inspect esmtp in order to get inbound emails to propegate through the ASA... do you have an email gateway that sits on the DMZ and passes the message through or how does the process work for your set-up?
The administrator has disabled public write access.
Time to create page: 0.083 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup