Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Forcing proxy on IPCOP

Forcing proxy on IPCOP 9 years 10 months ago #19466

  • befree
  • befree's Avatar
  • Offline
  • New Member
  • Posts: 11
  • Karma: 0
Hi,

is there a way to force clients using proxy on ipcop?


Rgds

Robin
The administrator has disabled public write access.

Re: Forcing proxy on IPCOP 9 years 10 months ago #19474

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
You need to block direct IP access for all clients using iptables. That way, clients will have to specify the IPCOP as their proxy server in order to access the internet.
The administrator has disabled public write access.

Re: Forcing proxy on IPCOP 9 years 10 months ago #19481

  • befree
  • befree's Avatar
  • Offline
  • New Member
  • Posts: 11
  • Karma: 0
You need to block direct IP access for all clients using iptables. That way, clients will have to specify the IPCOP as their proxy server in order to access the internet.

Hi,
thanks for answering me.
Could you please explain me how to do that? I'm new on linux.

Thanks in advance


Robin
The administrator has disabled public write access.

Re: Forcing proxy on IPCOP 9 years 10 months ago #19483

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
You need to make changes to your rc.local file which is located in the following directory /etc/rc.d/

Add the following commands after the line containing "#!/bin/sh"
[code:1]
# Flush Custom Input Rules
/sbin/iptables -F CUSTOMINPUT
/sbin/iptables -F CUSTOMFORWARD

#bar access for all IPs
/sbin/iptables -A CUSTOMFORWARD -i $GREEN_DEV -s 0/0 -o $RED_DEV -j DROP
[/code:1]

The above rules simply block direct access for all clients.

After editing rc.local, you can run it by typing "/etc/rc.d/rc.local".
The administrator has disabled public write access.

Re: Forcing proxy on IPCOP 9 years 10 months ago #19497

  • befree
  • befree's Avatar
  • Offline
  • New Member
  • Posts: 11
  • Karma: 0
You need to make changes to your rc.local file which is located in the following directory /etc/rc.d/

Add the following commands after the line containing "#!/bin/sh"
[code:1]
# Flush Custom Input Rules
/sbin/iptables -F CUSTOMINPUT
/sbin/iptables -F CUSTOMFORWARD

#bar access for all IPs
/sbin/iptables -A CUSTOMFORWARD -i $GREEN_DEV -s 0/0 -o $RED_DEV -j DROP
[/code:1]

The above rules simply block direct access for all clients.

After editing rc.local, you can run it by typing "/etc/rc.d/rc.local".


Hi,
thanks for helping me.
I followed what you suggest but when I try to run the command, this warning appear:

root@ipcop:~ # /etc/rc.d/rc.local
Warning: wierd character in interface `-s' (No aliases, :, ! or *).
Bad argument `0/0'
Try `iptables -h' or 'iptables --help' for more information

Rgds

Robin
The administrator has disabled public write access.

Re: Forcing proxy on IPCOP 9 years 10 months ago #19499

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
Replace [code:1]/sbin/iptables -A CUSTOMFORWARD -i $GREEN_DEV -s 0/0 -o $RED_DEV -j DROP[/code:1]
with:
[code:1]/sbin/iptables -A CUSTOMFORWARD -i $GREEN_DEV -o $RED_DEV -j DROP[/code:1]

Also is your RED interface a modem or a network Card?
The administrator has disabled public write access.
Time to create page: 0.079 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup